Phone storage not full but unable to take photos

My phone claims to be full and won’t allow me to take photos saying I need to create space. I’ve got a screenshot (which it allows) to show this the error measage. Any solutions welcome. I’ve tried going into the setting and trying a clearing things up there. No help. I have storage manager on. I’ve tried turning it off…

Just tried clear cache on the camera app. Problem persisted. Tried clear cache on the photos app. Problem is resolved

Welcome to the Community Forum.

First question: Are you using an SD (SDXC) card in your Fairphone? If yes, do you know if you formatted the card as “phone storage” OR as “portable storage”? Phone storage (usually and unfortunately the first option offered when you’re prompted to choose a format) has caused problems exactly like those you are describing in the past.



Check how much memory you have 6Gb or less is known to present an issue, and as above do check if you have an SD card formatted as internal.

Clear more space ~ move some images off the phone ~ clear other cache etc. ~clear browser cache etc. # ~ # ~

If formatted as portable you should see an eject icon to the right under Settings > Storage

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.