Phone rings in do-not-disturb mode

Since a couple of days, when I am called and my FP2 is in do-not-disturb-mode, my phone rings nevertheless. If course it is annoying to be disturbed when it is (sometimes very) inappropriate. I can of course put the phone in flight mode, but that is of course for other reasons inconvenient.

Anyone know what might be the case?

Did you by chance allow some calls/callers in DND mode (i.e. are exceptions configured)?

1 Like

I have no idea how to do that and have not changed anything in that context either, during the last week. (Nor at any time in the past, that I know of.)
How can I check?

If you long press the DND icon in quick settings you should directly reach the DND settings.


(settings might still look a bit different on a FP2 to which I don’t have a access to at the moment)

There you may check.

1 Like

Thanks. I found that calls from contacts were allowed. Now disabled it.

Could it be that an update of the OS changed these settings?

1 Like

Don’t think so and have never heard about it. Still you never know… :person_shrugging:

Maybe this week was the first in many years of using the phone and do-not-disturb, that I was called a number of times precisely in that mode. Seems very coincidental to me, but it is possible.
Anyway, problem is solved. Thanks again for your help!

1 Like

Same occurred to me some time after upgrading from Android 7.1.2 to 9 (FP OS 21.12.0-rel.1). After that upgrade various settings turned out to be changed, and I took the DND
one to be one of those, even though I became aware of it only later.
No proof of causation obviously, but I don’t think it’s coincidental either!

1 Like