Phone not connected to Google Play Services after every reboot

Dear all,

since two days my phone won’t connect to Google Play Services - at least not automatically. The WiFi symbol stays grey.

In order not to confuse things with other threads in this forum:

  • I have Google Apps installed
  • my WiFi connection works – I can open websites etc.

From another thread I have learnt that installing a new app leads to a subsequent connection with Play Services - indeed this works for me! The thing is, once I reboot, my phone won’t connect again.

Of course I could install and reinsall some random app everytime I reboot, but that’s not really an option.

On the other hand, I am dependent on a Play Services connection because of Google Cloud Messaging, a feature my messenger relies upon.

The problems started a couple of days after updating, so I’m not sure whether all this is related to the latest OS release.

Can somebody help me with this? Or does anyone else experience this problem?


I seem to have a similar problem, and could not yet find the source. I have XPosed with XPrivacy enabled on my FP, and was assuming this was the culprit. See here, and note the reply @ralf_xda wrote:

FTR, I still haven’t updated to 1.8.5, so I’m still on Cherry. Will see if this changes, then.

Thanks Hans.

My problem somehow solved itself after three days, I have no idea how or why.

I have never installed Xposed etc., so that cannot have been the source of my problem.

It first occurred when I was in my parents’ home’s WiFi. As I mentioned above, I had already updated to 1.8.5 when that happened.

Same behavior here. I don’t know the moment it works fine.I had it with Fairphone OS 1.8 (before the update) too, some days later it was gone… I’ve installed no special apps.

I have the same problem and it drives me nuts to be honest. Tried so much. Uninstalling xprivacy and the xposed framework, downgrading the OS, reinstalling the goole play services, a hard reset. Nothing worked. By now I don’t know what else to do. Would be very grateful for every hint.

I just wrote a lengthy post with suggestions how to solve it when suspecting XPrivacy as the reason behing this. However, for me, the update seemed to have done the trick. Logging in from a WiFi directly after re-installing GApps in the third update step, whithout having the XPosed Framework activated, might have to do with it. I also keep loosing the connection when using TOR network, and it sometimes does not come back immediately after stopping Orbot (but nearly instantly returns if I update any app from the play store while not using TOR network).

@Alfonso_Muskedunder :
I also had the same issue and the problem solved when I installed a new app with the Play Store.

Still have the problem and doesn’t resolve itself after installing an app. I replied on the second thread but post the same reply here as I don’t think it is the xposed framework.


first of all thanks to @humorkritik for the long and informative post.
My problem unfortunatley hasn’t resolved itself yeat, but I am quite sure now that neither the Xposed Framework not Xprivacy is the reason for my phone’s inability to connect with GCM. I tried both of the options and nothing changed. Nevertheless it was worth a try.
At last I did one more hard reset and downgraded to 1.6 again. I tried to do the same thing as humorkritik and hoped that my problem was gone as well, but unfortunately nothing changed. The wifi symbol stay grey.
At the moment I mostly use mobile data and really need to get my messages so the whole thing grows on my nerves. Whenever I check my connectivity to the GCM servers, I get this message:

Device ID: xyz
Not connected
ReconnectManager: next reconnect attempt in x:yz s
Last network state notification: 0/unknown time xyz ago
active network type: -1
Type missmatch between polled and callback
active network type (polled): 0
active network state (polled): DISCONNECTED
Connected at: xyz
Network status: ON Previous Network status: OFF

To be honest, I can’t make too much out of that but maybe one of you can. I think humorkritik had the same message.
By now I have some kind of a workaround in place, but sure as hell is not a solution and I’m seriously thinking of getting rid of the phone because of the problem. I just need to be able to rely on getting my messages on time. I installed the push notification fixer as well as the gcm wifi fix. that does the trick after downloading an random app, but I don’t want to keep doing that every single time I reboot.

I also checked back with the emulator but the only thing that comes back is: Error: Not found; no service started.

So if you have anymore advice, I would be very grateful.

1 Like

Same here, ever since the update, I only get blue wifi/push messages by chance and it is really annoying. I believe in FP and I would sincerely hate to use another phone, but this is simply not working for me. Any ideas how to fix this?

Sometimes you need to download any app from the play store to reenable googles sync function and get the blue wifi symbol back.

I have the same issue, only way so far to fix it is to download an app from Play Store.

I have the same issue. I can’t get push notifications from my email-client and my calendar does not sync which is a pain. The workaround for me is to deinstall the google play services update. (only the update) With the factory Version of the Play-Services my Calendar and Email sync fine and the Wifi bars are staying blue.
But its very annoying since many other apps need the latest Version of Play Services. If anyone has an Idea how to solve this i would be very Thankful.
Best, Gunnar

After installing to OS 1.8.6 (in order to solve the [German roaming issue][1]) I’m back at square one, yay! Again, after switching on my phone the WiFi symbol will stay grey until I download some app from the Play Store.

I noticed something though: Although the WiFi symbol turns blue after installing some app, when entering ##426## in the dialer like advocated in [this thread][2], I do not receive something along the lines of “device is connected to” (which it did after the problem had solved itself), but it tells me:

“DeviceID: […]
Not connected
ReconnectManager: next reconnect attempt in […]
Last network state notification: 0/UNKNOWN, time: […]
active network type: -1
Type missmatch between polled and callback:
active network type (polled): 1
active network state (polled): DISCONNECTED
Connected: […]
Network status: ON Previous Network status: OFF”

Again: the WiFi symbol is blue.

Can anyone make sense of this…?
[1]: Roaming fix (O2, Eplus and MVNO's)
[2]: Help with Xprivacy settings relating to Google Apps

1 Like