English

Phone loses power quickly and overheats: interpreting Better Battery Stats

Hey people,

for the last two days my Fairphone 2 has been going from 100 % to 0 % battery in about an hour. Before the battery wasn’t the best but it took a sudden nosedive on Sunday.

I went through the battery guide and tried everything. Nothing worked excep when I booted it in safe mode. Then the battery held up better. So I downloaded Better Battery Stats to find the culprit app.

This has given me a bunch of information I don’t know how to interpret even with the guide. Can someone tell me what I can do given these screenshots?

Thanks!

Have you also checked the stats by Process?

For these extreme case bbs might not be the right tool. In fact, to me it doesn’t look like it shows the real culprit (except for some app probably requesting and holding a wakelock). I guess some monitoring app, or adb shell or terminal (what os are you on) and running top -m 20 will be more insightful.
We just had a thread about a similar problem where it was a rogue app. Out of the blue. Maybe some bad update or the like

Thanks for the responses!

Actually after the phone once again was out of battery and died and I recharged it, the probem was gone. Now deep sleep is at 74 % and awake (screen off) at 18 %.

I think it might have been the tripadvisor app. It was at about 5 % on the partial wakelocks but I already deleted it before I took the screenshot above. However, I didn’t restart the phone afterwards. Could that have been the problem, that I needed to reboot the phone for the uninstall to have an effect?

Otherwise I really don’t know what could have solved it. The weird thing is also that all the other partial wakelocks went down. Now, the highest is my antivirus at 1 %. Anyone have a clue what could have been the problem?

I still think your ratio is quite high, but maybe it was too short
Mine is

Otherwise, no idea. Software glitch, hardware problems, solved through n’th reboot…

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.