Phone is now completely dead - can't switch it on

Referring to this post Phone is now complete dead - can't switch on, because it’s quite similar.

My mother’s FP is not even one year old (bought in Dec 2018). She has been troubles since she got the phone: random reboots, problems with the power button, problems with charging and so on. By now we could always solve it by taking out the battery.

Now, the phone is completely dead. We tried to take off the cover, Sim card, SD, battery like suggested in ✏ A little Guide to... Random Reboots. if we just put in the battery and want to charge it it doesn’t even charge any more (also no light for charging). Although the battery was not empty!

In any case it just shows: fairphone powered by android. and the screen is hanging.

We therefore couldn’t safe any data on the phone and can’t use he FP any more. We ask for urgent help! Maybe the best is to send in the fairphone?

Wait, so is the phone completely dead or does it turn on?

If we push the power button it just says “fairphone powered by android” and stays like this.

Okay, so it isn’t dead, in the sense that it won’t turn on which would most likely be a hardware issue - that’s encouraging.

Can you boot to recovery by turning the phone on with power + volume up, or to fastboot mode by turning the phone on with power + volume down?


Unfortunately, whenever I press what you suggested, the phone vibrates once or twice, but the screen stays black. Nothing else happens. It’s not even showing “fairphone powered by android” anymore…

I guess you need to charge your phone now.

We already tried that. It’s not possible to charge the phone anymore (also no light for charging). Anyway the battery shouldn’t be empty…

This is going to be difficult to troubleshoot over the forum - if I had to guess, I’d say that the regular removal of the battery while the device is still running has created a software or hardware fault, causing the device to no longer be able to properly boot (for future reference: holding the power button for 12 seconds will turn the phone off reboot the phone, no matter how frozen it is). The fact that it won’t charge, even when it’s off, has me thinking it’s hardware-related - though the charging process also has software components.

You could see about contacting a Fairphone Angel, but as you are within warranty I recommend you contact Fairphone to get the issue resolved.

And here’s some advice that isn’t of much help to you now but may be to other people reading this thread: when your brand new FP has any issues, contact support immediately to get your phone repaired or replaced. Don’t just accept that you bought a broken device that you now have to troubleshoot; you have rights as a consumer and what’s more, I think Fairphone would much rather repair or replace your device than have customers get turned off from ever buying their products again because they keep using phones with factory faults.

1 Like

Small correction: This doesn’t turn off the phone, it forces a reboot … which then could be used e.g. to boot into the recovery and turn safely off from there.

1 Like

I already contacted Fairphone.

Just for record: of course we contacted FP after experiencing the first issues. Unfortunately, we never received any answers. They seemed to be quite busy.

Thanks for your advices! In some cases, though, holding the power button for 12 seconds doesn’t work…

That backs up my guess that it’s a hardware issue. Give FP a phone call, or just try emailing again - and be sure to tell them you didn’t receive a reply earlier. Something must have gone wrong with your ticket, but you are entitled to a working phone.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.