Phone can't connect to mobile network after booting


my girlfriend and I both have one problem with our new FP4: After (re-)booting the phone it does not connect to the mobile network. SIM-card is recognised though. One has to deactivate and then re-activate the SIM-card in the settings and it works fine and stable.

I remember that this didn’t happen when I booted the phone for the very first time but since then it’s always like this.

Not a big issue but somehow annoying and I wonder whether this is a problem in our settings or a bug.

I think you have both the same provider?
Mobile Data is set to “on” in configuration?

Sounds like maybe the APN settings are getting lost each time and having to be re-written when you re-activate the SIM.
This might be caused by a problem with the SIM itself, though since you’re both experiencing the same problem it’s more likely the network, if you’re both on the same - and as FairphoneHulk says, it sounds like you are.
Which network provider are you using? Some of them are rather tricky to deal with.

You might try creating your own APN settings record (just carefully make a note of all the values of the one that’s already there and then put the same values in a new record) and then select it instead of the one that was created automatically.
If you don’t know how to do this, just ask.

Had a similar issue with Orange Fr, had to install the carrier app which had an option to “Fix APN”, I did it once, uninstalled the app and never had any issue afterwards. Maybe something similar exists for your carrier ?

Thanks for your suggestions.

We have the same provider, discotel by Drillisch, they use O2 network.

I tried to copy the APN settings and also tried the APN settings published by O2 but it the problem persists. However, I noticed that directly after reboot it usually connects successfully for a few seconds and then looses the connection. Sometimes (seems to be quite randomly) the connection even holds permanently.

The provider also has a service app but with that it’s not possible to adapt phone settings.

Thought Discotel no longer exist, my prepaid card was moved to smartmobil 1-2 years ago?

How old are you SIM cards? I recently noticed in both my drillisch accounts that they would send a new one for free, because mine seem to be to old technical vice.

Else those are my settings working fine on FP2 and FP3, maybe you want to check against your settings

do you have already a solution for the problem?
We experience exactly the same issue - as well with O2/Drillisch - but PremiumSIM.
We have received today a brand new SIM card - unfortunately that didn´t helped at all.
We have multiple times tried different APN settings - without any success.

No luck so far. Also tried with the settings by yvmuell above but the problem remains.

I guess the secret is not to reboot the phone too often :laughing:

I also can’t send SMS but I can receive them. For my girlfriend this works, so I thought this might be a problem with my specific settings but even after trying several different solutions nothing worked… But who uses SMS nowadays…

1 Like

Huh, this sounds kind of similar to

Did you by any chance disable some of the Google apps on your device? :thinking:


Yeah, apparently I disabled too many Google apps. Re-activated the Carrier app and now I can send SMS again (at least something :grinning: ).

1 Like

Hi @ToPi
Do you confirm that this has also solved the main problem of your topic, i.e. the phone wasn’t connecting automatically to the mobile network after a cold start?

No, only the SMS issue, the actual topic of this post is still relevant.

Maybe I disabled another Google service I shouldn’t have disabled :thinking:

Well it would certainly be an idea to run through them and check what you’ve disabled, and why :wink:

Apart from that, you might try resetting (all) the network settings:
Settings > System > Advanced > Reset options > Reset Wi-Fi, mobile and Bluetooth.
This has been reported to solve reconnection problems in Wi-Fi, I don’t know about mobile though.
However remember that this will break your Bluetooth pairings and Wi-Fi passwords, so you might decide that the price is too steep for an uncertain result.

1 Like


same problem here, also Drillisch / O2 (PremiumSim). Everything worked fine, until I recently rebooted the phone. Since then it’s pretty much the same, which @ToPi already told: When rebooting again (or after using the flight mode in my experience) it sometimes connects for some seconds, but loses the connection again. Yesterday after rebooting one time the connection was actually stable for some hours, but then lost it again suddenly.

I just tried, what OldRoutard suggested, resetting WiFi, mobile and bluetooth, but it had no effect. I guess resetting the phone to default setting would solve the problem, but probably just until rebooting the phone once after that again.

@ToPi @Dendro : How old are your sim-cards? Mine is more than 3 years. I’m not sure, if the problem could be solved by a new one, but that’s just guessing around…

Even with a new SIM card it didn´t work…

Have you enabled VoLTE and/or Wifi Call? That can lead to strange issues, so maybe disable for some time to see if it changes something?


Interesting, disabling VoLTE and afterwards disabling and enabling SIM altogether seems to have an effect, at least for the last minutes. Everything works fine. Also after rebooting the phone it works fine and the issue hasn’t occured anymore.

Thanks for the suggestion @yvmuell

@dendro Did you try it as well? Does it also solve the problem?

Good point Yvonne. I never activate LTE or Wi-Fi calling and I don’t have problems with mobile data. Maybe there’s a relationship somewhere. Certainly worth trying.

I actually have it enabled for the SIM I use for mobile Data on the FP3. I use Drillisch Provider as well (Simply) and I dont see those issues. So if disabling VoLTE actually helps I would #contactsupport as to me it would proof there is some bug in the FP4 with this Network

Same her. Looks good now! Seems to be an issue with the combination VoLTE, FP4 & Drillisch.

PS: From my point of view the highlighted solution is not correct - it only worked partly. The post should be split - or changed to the actual solution provided by @yvmuell

1 Like