Phone and Contacts do not share

I have a new Fairphone 4. Android 11.
I loaded my contacts to the Contacts app from a .vcf file. This worked fine, and the contacts could be seen in the Phone app.
Then I removed the google account from the Accounts (in the Settings app).
Now the Contacts app still shows the contacts but the phone app can’t see them.
I have checked that both apps have the permissions needed.
Any solutions? (don’t tell me to go to google again, that does not help, and anyway I have no data on google’s machinery)

Hi and welcome to the community? Which phone App do you use? Are the contacts stored locally in the phone storage? If yes, I’m wondering if visible for the phone app🤔 never used the phone storage for contacts

Dear Fairphone angel:
The device is new. It comes with something blue called Phone and some other blue thing called Contacts.
The contacts were loaded from a .vcf file, hence local. I do not have anything whatever on any cloud (except my own server which is completely under my control).
When opening the phone for the very first time, somehow you have to give a Google account. I did that. I also set up some accounts to access my own server. Then I deleted the Google account (I don’t want anything to do with them), and it was after that that the Phone no longer saw the Contacts.
I don’t know if the two are related, i.e. if it was the deleting of the account or something else that caused the link between the two to break. The permissions seem to be OK.
When I open the contacts app, I can call from there.
When someone calls, the phone app works OK but no longer shows me the caller’s name because it does not seem to be able to get info from the contacts app.
I’m using the phone and contacts that were on the phone when I got it.

OK I asked about the phone app because you dont like Google so using another phone app could have been logical for me.

For the record, you can skip the Google Account setup in the beginning.

You say the phone app has all permissions, can your specif this?

Did you try to delete all contacts and re-load the vcf.?

Or try e.g. the simmple mobile tools dialer app

Hi again:

> OK I asked about the phone app because you dont like Google so using another phone app could have been logical for me.

Correct, but I just used what came with the phone.

> For the record, you can skip the Google Account setup in the beginning.

Thanks, but unfortunately I did not.
So: can I set the phone back to its initial state, with all my apps removed, the original apps restored, and all data gone? At this point I do not care if I lose all my data.

> You say the phone app has all permissions, can your specif this?

”All” is maybe exaggerated, since I don’t know what it would mean. But one permission the phone app asks for is to access the contacts. So I gave it that permission.

> Did you try to delete all contacts and re-load the vcf.?

Yes, I just did. See my general comments at the end.
But it did not help. When I try to reload the vcf, it still only gives one choice: “Phone storage (not visible in other apps)"

The Contacts app then does load all contacts and I can call from that app.

But when a call comes in, I see the number but not the name of the caller. And in the phone app there is no access to the contacts.

Or try e.g. the simmple mobile tools dialer app
Maybe. But that is in fact the app that is installed on the FP4.

As to the general comments: these comments apply equally to iOS as to Android (I had an iPhone since they appeared).
I think the whole smartphone stuff is actually about stupid-phones.

  • for deleting all contacts: it was hell to find out how to do that (there are 700 of them) but I managed after wasting a lot of time again.
    -It is never clear which app I’m in at any point.

-There is terrible incoherence between apps: where the search field is, what is displayed on the keyboard and so on. The incoherence is phenomenal: just imagine what it would be like if the pedals in each model of car would be in a different order!

-Settings for an app should only be inside the app. Some settings are terribly difficult to find. For example, in the e-mail app I had a choice for how often the mail is checked. There was no option “only on demand”. So I set it to 1000 minutes. But that was during first setup. I have wasted a lot of my time searching where to change that.

  • when I get a call through WhatsApp, the phone rings but does not light up and I have no idea what to do. If it happens when I am using the phone, it rings but nothing else happens. When I get to the WhatsApp interface, either the other party has hung up (in fact it is WhatsApp that decides to hang up!!), or I get a screen with no indication whatever, no “accept call” button.

The whole thing is an incredible pain in the backside.
And so on. Stupid-phones are a terrible waste of time.

I’ll wait for your reply. If that does not help, then I’m going temporarily back to the iPhone, then remove all the apps I downloaded to the Fairphone, then reset the Fairphone to factory state, and go through the whole mess again, hoping it will be OK.
And if it then is not OK, then I will simply sell the Fairphone or give it away.

:frowning:

yes you can do a factory reset (no need to first remove all apps) and start from scratch,hoping it will solve the issue

Overall I see your struggle, which might be normal when coming from iOS.

This could be a permission issue. Check the settings for notifications on lock screen Else I dont use WA calls, so no idea how it should look like when the phone is not locked, maybe it needs permissions to show over other Apps?

Maybe you have someone close who has a bit experience with Android Phones as I think overall its more Android issues than a Fairphone issues

1 Like

Well, I think both systems have very similar issues: there is incredible incoherence, hidden stuff, no idea where you are, etc. The main reasons I wanted to switch to Android is that I can have access to the file system and I can write apps without being on a leash of Apple. No, I really don’t think it has to do with coming from iOS. (I’ve been in computing since 1969; see (me)
So it’s not that. It’s just that I can no longer afford to waste my time.

Yeah, of course I had thought of that. However all people I know with android devices just hang off Google. They have no idea. I did have a Samsung Galaxy a long time ago. But then everyone in my family got an iPhone, and I have had Macs since 1984, so there…
All “help” pages on the net always start with “log in to your Google account” and therefore do not help at all.
I could go to a “smartbar” in MediaMarkt nearby. Those guys are really good. But as soon as it is not in the Google or Apple cloud, they too are stumped.
An example: I run my own server with CalDAV/CardDAV/https/ftp… services. This device sits in the basement of our house, and, no surprise, is called cailliaucloud. My wife and I sync our calendars through that, and use it as a shared file space. It also runs our surveillance cameras, so you cannot hack them as they are not directly on the web.
Perfect, but Android does not have the CalDAV protocol built in! (unlike iOS). So setting that up was already difficult: first install DAVx5 and so on. And it was not obvious to make an account with a user name that does not look like an e-mail address. I managed though.
No, it’s just that I’m fighting a battle against the commercial clouds with their leashes, and it becomes increasingly difficult because the details are hidden on purpose. Either you surrender to Google or you surrender to Apple. Then you will live in bliss.

Which brings me to another point: I’m going to have to find out how to make a backup without involving Google.

Thanks for all your suggestions though. Have a good evening.

1 Like

Hi Yvonne:
It’s late here, but I did manage:
1-removed SIM card (and the SD card, which is 1TB… )
2-did a factory reset
3-started without any internet connection and without SIM card
4-made myself a developer (tapping 7 times “build number”)
5-set the default USB configuration to File Transfer
6-used the macOS version of Android File Transfer to put the .vcf file into the Documents folder on the phone
7-imported with the Contacts app
8-found all contacts in the Phone app!

So it seems it’s OK again now. But I still have no idea why it went wrong.
Best,
Robert.

1 Like

My (wild) guess would be that the dialer app chooses to display only the Google contacts if such phonebook is available at initialization. By removing the Google account, that phonebook disappeared and the dialer app had nothing to display anymore. So it would probably have been possible to switch the displayed contacts to include the local ones. Now that you set up your device again without a Google account, the phone app used your local phonebook as a default.
But as I said, it’s only a guess.

By the way, I (and some others here) use Nextcloud and DAVx⁵ to sync contacts and calendar entries. I’m not quite sure if cailliaucloud is your own software creation or your name for an instance of owncloud/nextcloud or something similar. If the latter, you will find here for sure a lot of people who already went through the ups and downs of a Google free smartphone with one of these softwares.

This is both the curse and the blessing of Android in comparison to iOS. There are a lot of alternatives even to standard apps in the Android world and not many design rules for published apps in the PlayStore. Everyone developer does it the way he prefers or which was state of the art once. But once you found the apps you are happy with, you will probably love the freedom and possibilities of the android eco system. But since you currently go with the default apps and nearly all of them are developed by Google, it should be relatively consistent.

Otherwise I can recommend the Simple Mobile Tools collection. So of them are paid now in the PlayStore, but they are all available for free on F-Droid (which is another story).

2 Likes

Hi Max‑o,
Thanks for extensive comments.

Your guess about why the phonebook wentr wrong is probably correct.
I never had any data whatever with Google, I did use my google account when I was asked to specify how the contacts should be labelled. That is no longer true.

As Android does not have the CalDAV etc. protocols native, I also use DAVx5 for syncing calendar & contacts.
Cailliaucloud is just a mac mini that sits behind my router, runs macOS with Apple’s “server” interface and provides the protocols I need. It uses less than 10W and has been running since 2014. It has a DNS name and some ports through my router give access.

The hardest thing was to find a provider that allowed me to assign a fixed IP number to our router, and around here there is only one that does so, unless one pays a rate for enterprise services.
My security cameras are controlled by an application that on request provides a jpeg image of what they see, but does not allow control over their functions, unless one has a login and password.
The terrible interface incoherence is very similar on iOS: there too it is not clear what app one is looking at, the search boxes are in random places, and so on. I don’t find it any worse on Android. But it is just as annoying.

I understood that the Fairphone default apps ara in fact the simplemobiletools collection, but I may be wrong. Their icons are identical. I have installed some extra ones from the simplemobiletools site.

Thanks again,
R.

Thats def not the case and you can easily identify the simple mobile tool apps by their orange colour.

1 Like

Yvonne: yes, I checked and their provenance is different indeed. They look dentical and that is probably done on purpose.

OK, thanks for your help, the problem is solved (for now anyway).

Did you consider (instead of just disabling some Google stuff and not creating a Google account) to change to an OS free of any Google services like /e/OS, iodéOS or calyxOS? You may find more information at our #oslist .

1 Like

Hi Volker,

I suppose I could have considered that.
However… Every so often I have a look at some Linux version for the laptop/desktop. I admire the goals, but I simply have no time to “live inside the OS”.
This is for a discussion on a different forum, but let me quote my friend Ted Nelson (from “Geeks Bearing Gifts”, some while ago):

“Steve Jobs has a superb understanding of the soul of the user. Microsoft at least knows the user exists. The Linux guys have no clue.”

I need to walk the difficult line between being in Apple’s gilded cage and advancing slowly, machete-wielding, in the open-source jungle.
I try.
:slight_smile:
Have a nice WE,
R.

I don’t completely agree. Maybe now, that you already have your device, it would take some time. But it’s possible to buy pre-installed /e/OS and iodéOS devices. So in this case I don’t see that it’d takes more time or effort to run a Google-free device.

2 Likes

Hi Volker:
I’d love to discuss the open source environment, but we should do it elsewhere I think. My email is [redacted]

Please remove your email as it will attract spam. You can you the Private|Direct message option.

2 Likes

I’ve removed it, just to be safe.

The Discuss category might be a nice place for such a topic as well:

4 Likes

Sorry guys, I should indeed not have put an e-mail address there.
Thanks for catching that mistake and correcting it.

2 Likes