Phantom 1.17 update on FP3+ /e/

Hi,
I have an FP3+ with /e/ 1.16.

I received the system message twice, announcing the availability of 1.17 update.
Entering the setting screen confirm this availability.
But when I enter the update screen no update is listed.
Doing a check give no update avalaible.
See attached screenshots.
Anyone had the same problem? Is there any solution?

Many thanks. Marco


Have you tried to tap the “reload” icon (next to the three dots in the top right) 3-4 times?

1 Like

Super weird! I obviously already done that a lot of times.

But, just in case, I retried.
First 4+ reload make only the message on setting screen disappear.
Second 4+ reload after restarting the phone again make update appear again.
Immediately starting update, just in case … !

Thanks.

1 Like

While it may look weird, there’s nothing weird or phantom at the core of it.

/e/OS updates tend to be released in a staggered (or staged) rollout in the beginning. This means that a new update will not be available to every device immediately. This has advantages considering server load and detection of issues with the update (in which case not everybody will be affected immediately).

The way /e/OS technically achieves this looks like they randomise availability. At one moment the update server will offer the update to the /e/OS updater when contacted, at another moment it will not.
(This can easily be seen by looking at and refreshing the respective server page in a browser. The page in your case is https://ota.ecloud.global/api/v1/FP3/stable, and we’re looking for 1.17-s in it … sometimes it will be there, sometimes it will not, currently.)

So, what you are seeing would most likely be by design, and @urs_lesse would be correct … just try to refresh the updater. Since it looks random, more tries than 3 - 4 times could be needed as well.

1 Like

If @urs_lesse suggestion doesn’t help you could try to clear the storage of the updater.
Go to the app “Settings,” and type in the search bar : updater. Open Updater “App info” then open “Storage & Cache”. Clear Storage and Clear Cache. Close settings and then open “Settings”, “Updater” and Updater App worked again.

2 Likes

Quite interesting, many thanks.
IMHO it is a proof of digital complexity impairing user experience, but is probably also a proof that also the most skilled developer & sysadmin cannot completely shield users from complexity, given the current sw developement processes.

OTOH, I tested the “:updater” trick but nothing was found by the serch, so i cannot follow your instructions.

Many thanks again. Marco

On the Fairphone 3 it’s
Go to the app Settings
Go to Apps
tab on > See all … apps
tab on the three vertical dots in the right upper corner of the screen
tab on Show system
scroll down and tab on Updater
tab on Storage and cache
tab on Clear storage.

edit supplemented by instrutions in Italiano

Andare alle Impostazioni dell’app
Vai a App
scheda su > Mostra tutte le … app
scheda sui tre punti verticali nell’angolo superiore destro dello schermo
scheda su Mostra sistema
scorrere verso l’alto e selezionare Aggiornamenti
scheda su Spazio di archiviazione e cache
scheda su Cancella dati archiviati

1 Like

The updater name gets translated into the chosen system language.
It’s the first item in the Settings in recent /e/OS. According to the screenshot it would be “Aggiornamenti” here.

Alternatively, one can set the phone to English, follow the necessary steps, and then set it back to the native language.
Settings - System - Languages & input - Languages - (add English here and/or if it’s there but not in the first position just long-tap and drag it into the first position).

Got it.
But the app name is an i18n victim … :slight_smile:
In italian “Aggiornamenti” is on the opposite side of a very, very long list of app.

Many thanks. Marco

This try was for me the right step. But my last running system is e/OS 1.14.
Can I install the newest update or do I take step by step install the next update up to 1.17?

You can ask this question the best at the forum of /e/OS.
The user Manoj will know.

You can install the newest update. /e/OS update files are complete installs, not incremental.

3 Likes

Thank you. I will do it.

Addendum:
Thank you. You have helped me with my problem and is solved.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.