People don't see my number if I call

I am guessing the question I am posing is embarrassingly easy to answer, but as it happens, I tried to look for a solution myself and I didn’t find one.
This week a friend of mine told me that she didn’t see my number when I had tried to call her. She did see she had a missed call, but from an unknown number.
This is rather problematic as I need to make more phone calls and I don’t want people to think they have a stalker.
I figured there is a setting on the FP2 that makes my number private, yet I could not find it. Does anyone have an idea?

Got tho the Phone app, open the menue in the upper right corner and then go to
Settings–>Call settings --> SUBS Settings–>GSM call settings–>Additional settings–>Caller ID

1 Like

Thanks a lot! It worked.