✏ B2G beta (formerly Firefox OS)

I you can, add something like “I think there is no matching device/function defined for “FP2” in the script, this is why the flashing fails” to your bug report. It’s more about the flashing script, the build works.

The script for FP2 will more or less do the following:

Go to the target out dir for the images and do:
fastboot flashall

if i type terminal code: fastboot flashall it gives out this:
error: neither -p product specified nor ANDROID_PRODUCT_OUT set

and also if i tryed to do manual but
novski@novski-MacBookPro:~/firefox_os/B2G$ fastboot -p FP2 boot out/target/product/FP2/boot.img
novski@novski-MacBookPro:~/firefox_os/B2G$ fastboot -p FP2 system out/target/product/FP2/system.img
novski@novski-MacBookPro:~/firefox_os/B2G$ fastboot -p FP2 recovery out/target/product/FP2/recovery.img

it did not spit out a failure but it als did not seam to make anythng. the phone started up as normal in android like from factory…

how can i flash manual?
Regards, Novski

interesting…
did you copy / paste all commands at once or did you enter them one by one? could you leave the -p FP2 out? It worked for me without specifying the device…
The other way around, did you try fastboot flashall -p FP2 ?

Running these commands is he manual way of flashing :slight_smile:

Thanks for that reply.

Did you manage to start firefox os? because i didn’t until now…
wich way did you do it? i mean what .img did you copy first, and how did you then reboot to firefox os?
Regards, Novski

edit:
thats the output of

Quite interesting…

Other people (including me) had the same problem with the FPOS, see here and here.

PS: Btw, instead of inserting images of your terminal, you could copy and paste the output into your posts here. There is even the possibility to display these as code (the </> icon in the menu or the shortcut Strg+Shift+C or four empty spaces at the beginning of the line). This would save storage space on the server (and probably be faster). :wink:

Didn’t you forget the flash command in here? Like:

$ fastboot flash boot out/target/product/FP2/boot.img
1 Like

Please try

cd out/target/product/FP2/
fastboot flashall

the info fastboot is looking for should be there. But I never used/installed Firefox OS/B2G so I’m just guessing. Make sure you use a terminal that you use for the build, maybe some environment variables/paths/functions need to be around and set as well (just guessing again).

I can confirm this, see my second link above. I described there (see the paragraph “3. Try”) that I had the same problem and needed to run the setup for these environment variables etc. (but not the whole build) again in a new terminal before I could flash.

hi and many thanks to that help here…

seams to be the same…
novski@novski-MacBookPro:~/firefox_os/B2G$ cd out/target/product/FP2/ novski@novski-MacBookPro:~/firefox_os/B2G/out/target/product/FP2$ fastboot flashall error: neither -p product specified nor ANDROID_PRODUCT_OUT set novski@novski-MacBookPro:~/firefox_os/B2G/out/target/product/FP2$ fastboot -p FP2 flashall error: could not load android-info.txt: No such file or directory


flashing manual directly worked somehow, but the phone is now unbootable and it took me a while to get it back to fastboot mode (pressing pwr & vol.down for about 10s while repluged)

`novski@novski-MacBookPro:~/firefox_os/B2G$ fastboot flash boot out/target/product/FP2/boot.img
target reported max download size of 536870912 bytes
sending ‘boot’ (14994 KB)…
OKAY [ 0.473s]
writing ‘boot’…
OKAY [ 0.179s]
finished. total time: 0.652s
novski@novski-MacBookPro:~/firefox_os/B2G$ fastboot flash system out/target/product/FP2/system.img
target reported max download size of 536870912 bytes
erasing ‘system’…
OKAY [ 0.284s]
sending ‘system’ (305361 KB)…
OKAY [ 9.715s]
writing ‘system’…
OKAY [ 6.327s]
finished. total time: 16.327s
novski@novski-MacBookPro:~/firefox_os/B2G$ fastboot flash recovery out/target/product/FP2/recovery.img
target reported max download size of 536870912 bytes
sending ‘recovery’ (13622 KB)…
OKAY [ 0.436s]
writing ‘recovery’…
OKAY [ 0.156s]
finished. total time: 0.593s
novski@novski-MacBookPro:~/firefox_os/B2G$ fastboot reboot
rebooting…

finished. total time: 0.001s

`
Any ideas? :slightly_smiling:

did you reset cache and userdata after flashing the new system? you should be able to do that from recovery…

no didn’t but i can’t access recovery anyhow. Is that because i flashed also a recovery.img to the phone?

edit:
whent throug some files searching for that android-info.txt (think somewhare must that text apear. Then i found something strange:


the second Line export GECKO_TOOLS_PREFIX=/home/novski/firefox_os/B2G/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.8/bin/arm-linux-androideabi- has a unfinished end. and i don’t find that file like that in the folder… Is that normal?

(sorry for the printscreen but it makes it more clear here. will try to not upload pictures anymore where text can do same…)
Regards, Novski

If you did that while booting your phone, you should be in recovery. With that little Android Icon and such? Alternatively try PWR + Vol. Up Key on startup.
If your Recovery partition is really damaged, than you should try to fix that first, before attempting to do anything else, as the recovery is your only option to rescue your phone if someting goes very wrong while flashing your new system…

That should actually be found directly in out/target/product/FP2/ (at least for me it was with the FPOOS).

I’m new to this whole stuff as well, so don’t count on me, but to me it seems plausible that a variable called PREFIX is just that - a prefix with an unfinished end. :wink:

No problem, the images are actually smaller than I would have guessed. Such an image with comparatively low resolution and about 100KB is quite ok, I’d think. (Maybe you could try to cut down resolution even more …, but don’t know how much until it gets unrecognizable.)

I don’t think so. Power+VolDown is in fact the correct key combo to get in fastboot mode, whereas Power+VolUp is for the recovery.

1 Like

I don’t see anything (blackscreen…)

seams like i can’t get to recovery anymore. https://fairphone.zendesk.com/hc/en-us/articles/201149588-How-to-boot-my-phone-in-Recovery-Mode
I don’t see anything if i don’t attach a cable. If i have a cable attached the phone goes in to fastboot mode after some times… (even if i press vol up button…)

where can i get a recovery again? :grin:

Hi,
there was a trivial error on the flash.sh script that has been corrected by the guys of Mozilla.
Now it works for me even if I do not have a Fairphone 2 to make real test. Can you try to flash your Fairphone 2?

The fixed script @erotavlas talks about can be downloaded here or just updated with git pull.

https://raw.githubusercontent.com/mozilla-b2g/B2G/f7276c96cf8f8646069fc93b91428e08b38c074a/flash.sh

They just added “FP2”

+"panda"|"maguro"|"crespo"|"crespo4g"|"mako"|"hammerhead"|"flo"|"shamu"|"FP2")

1 Like

Sounds ugly that your recovery is gone and that the one you build does not work. Somewhere, it has been discussed whether an image of the recovery could be shared because it may not contain blobs, but there was no proper conclusion and I didn’t find a shared stock recovery image in the relevant topics. You could build the FPOSOS yourself and gain a recovery image (and a whole working ROM) this way. There is also an experimental TWRP recovery image, but this may not be suitable for your case. :wink:

If you have a recovery then, you could try flashing it via fastboot:

$ fastboot flash recovery .../recovery.img

Hi
Sorry @tphysm i whent over with flashing firefox os and was amused with playing around with it. So amused that i forgot to tell you guys that it now works. yes it flashes now correctly. jipey! Big thanks also to @fp1_wo_sw_updates and especialy @erotavlas for his supper eagle eyes to see that the name was mixed with the Devicename! Im glad to have that device rinning now.
but -and i awaited that- there are still some things to do. as:

Hardware report:

  1. The SIM card does not get active so calls are not possible by now…
  2. WLAN does not work ehter…
  3. The clock resets after a restart…

There are some working things:
bluetooth works well so a connection to a BT-Hotspot can be made to get internet. Uhhh…

over all i can say i love the feeling of that OS. Its decent. the sounds are absolutely phenomenal and the config is everyware clear. not as android what feels to me like always pountching a matress and sounds like a 1980 atari.

somehow i managed to get a prerelease 2.6.0.0 Version of Gecko

looking forward to get that nice device running. :grinning:
Regards, Novski

2 Likes

Hi Novski,
great, finally we solved the problem of flash.sh script together with Mozilla guys.
Thank you reporting the current bug of Firefox OS on Fairphone. Did you tried to flash only version 2.6 or also most stable version 2.5? If the second possibility is correct, please report your bug on bugzilla thread of Firefox OS porting.

1 Like

Very cool! Don’t apologize - you were our BETA tester for that. :wink: It sounds good, so I may give it a try soon (though unfortunately building takes hours on my machine). Thanks a lot for your testing!

actualy i was not aware of what version i built… And i don’t know how to change the version to be built as well… so if you have the knowledge about please let me know how to change.

It wold be great to have a comparison of some one who didn’t break his phone before! :joy:
I still don’t have a clue where the SIM problem comes from, because there is only one vendor in the proprietary blobs i think assume thats the driver for WLAN and is why it does not work but the SIM should work in my eyes…

and against my sugestion to be able to connect over bluetoth to internet it doesn’t work with my iPhone5s nor with a FP2-Android (i have 2 available here in my House…)

@MaartenD : what version are you running and how does it work on your side?

Regards, Novski

edit:
tryed to get a branch v2.5 but failed:
`root@novski-MacBookPro:~/firefox_os/B2G# BRANCH=v2.5 ./config.sh fairphone2
Get git://github.com/mozilla-b2g/b2g-manifest
remote: Counting objects: 3037, done.
remote: Total 3037 (delta 0), reused 0 (delta 0), pack-reused 3037
Receiving objects: 100% (3037/3037), 1.47 MiB | 1.35 MiB/s, done.
Resolving deltas: 100% (1850/1850), done.
From git://github.com/mozilla-b2g/b2g-manifest

  • [new branch] b2g-ota -> origin/b2g-ota
  • [new branch] bug_1226452 -> origin/bug_1226452
  • [new branch] master -> origin/master
  • [new branch] revert-203-bug1025788-v2 -> origin/revert-203-bug1025788-v2
  • [new branch] revert-226-v1.3t -> origin/revert-226-v1.3t
  • [new branch] revert-316-bug-1149387 -> origin/revert-316-bug-1149387
  • [new branch] v1-train -> origin/v1-train
  • [new branch] v1.0.0 -> origin/v1.0.0
  • [new branch] v1.0.1 -> origin/v1.0.1
  • [new branch] v1.1.0hd -> origin/v1.1.0hd
  • [new branch] v1.2 -> origin/v1.2
  • [new branch] v1.2f -> origin/v1.2f
  • [new branch] v1.3 -> origin/v1.3
  • [new branch] v1.3t -> origin/v1.3t
  • [new branch] v1.4 -> origin/v1.4
  • [new branch] v2.0 -> origin/v2.0
  • [new branch] v2.1 -> origin/v2.1
  • [new branch] v2.1s -> origin/v2.1s
  • [new branch] v2.2 -> origin/v2.2
  • [new branch] v2.2r -> origin/v2.2r
  • [new branch] v2.5 -> origin/v2.5
  • [new tag] B2G_1_0_1_20130213094222 -> B2G_1_0_1_20130213094222
  • [new tag] B2G_1_1_0_hd_20130530182315 -> B2G_1_1_0_hd_20130530182315
  • [new tag] B2G_1_1_0_hd_20130530182315_BASE -> B2G_1_1_0_hd_20130530182315_BASE
  • [new tag] closing-nightly -> closing-nightly
    fatal: manifest ‘fairphone2.xml’ not available
    fatal: manifest fairphone2.xml not found
    Repo sync failed`

can somebody declare me if thats a bug or just a miss understanding the code of me?
source: https://developer.mozilla.org/en-US/Firefox_OS/Preparing_for_your_first_B2G_build
thanks.