✏ B2G beta (formerly Firefox OS)

I didn’t yet test or read the source of the flash.sh-script but does it change the partition table / bootloader of the phone? If not, I cannot imagine how you could brick a fairphone. You should always be able to reboot to the bootloader (using the vol - key) and then use fastboot to re-flash Android or something else again?

1 Like

First many thanks for your work. I tryed to exactly do how described but unfortunately it gives out the same as MaartenD already sayed.

I installed on a Mac with Parallels Ubuntu 14.4LTS.
Regards, Novski

Can you “talk” to the device in any way? (adb devices as an example? I’m not sure if Parallels will really work well with USB. Just wondering …).

Yes i think it works exactly as if its a linux machine. By connecting it asks where to connect it to. I can then choose from OSX or Ubuntu. Then i see the Android and also the sdcard as drives. But im not a pro so maybe ther is a difference. But in this stadium i think it should not harm. It stoped to early.
By the way i tryed to go through the setup for building my own FxOS and came across a config.sh file where FP2 is listed.
Github says its just 5days old. So maybe erotavlas can update his git B2G files and make a new version?

I don’t understand how or where to manage the ccache. Can somebody enlighten me about how to configure that?
Its not realy clear what to do, for me…

Thanks for any Help…

Can you “talk” to the phone from the command line?

I did not ready all the messages. However, according to this https://developer.mozilla.org/en-US/docs/Supported_build_configurations, I think that it will be good to have the Fairphone 2 at least in Tier3 since Tier1 and Tier2 devices are directly used for developing Firefox OS.

1 Like

please keep us updated and especially report what are your impressions about the two versions of Firefox OS master and 2.5.
Thank you

1 Like

thank you for reporting the various issues. I cannot understand why it does not work since now it should. I think that a virtual machine HAL is not able to abstract the hardware of Fairphone in proper way.
Can you try directly from Mac OS X?
Moreover, I’m updating the code and a new build will be soon available.
The ccache is used to speed up the building process.

Hi, I thank you for your help!

I now tried the same on mac with the same result.

Where im not sure about is the connection option to set on the phone. Do i have to connect MTP or maybe disable all?
I have tried both with exact the same result… so im not shure witch one wold be right…
As soon as i have a spare minute i wil install a native ubuntu to go shure its not a OS related problem. (there are some comments in the thread that make me unsure about.)

May you explane me how that ccache command can be executed?
Im not able to execute in terminal and searching for a folder named ccache didn’t find something on my system. All throug apt-get install cchache states that the newest version is already installed…

Regards, Novski

Hi Novski,
thank you for your report. I do not why it does not work. Maybe the best thing to do is to build your own build of Firefox OS and try if the flash script works. In such a way it will be possible to understand if I have not copied all the necessary files or if the problem is something else.
In order to build your own build of Firefox OS, please follow this guide https://developer.mozilla.org/en-US/Firefox_OS/Building_and_installing_Firefox_OS, it is very clear.
According to your question, the answer is on one page of the previous link. You have to type

prebuilts/misc/linux-x86/ccache/ccache -M 50G

in order to speed up building process.
For any question ask here.

hi erotavlas, thanks for the replay.
I noticed something. The maual has a command to make the USB connect under normal user.
im following this page: link
the code copyes a file to the system with several vendor specific IDs and names.

This is just a part of it because its quite long. But whats ovious is that the Fairphone is missing totaly.
I came across that because i noticed that the help of adb stats a command called “devices” wich should print connected devieces and my FP2 does not apear…
So digged deeper. There is a Developer mode. Accessed by typing 7 times on the build number in the last section of settings. but that whas not all. after that sudo adb devices still didn’t show any device so i whent to the usb settings and tryed all types. And it seams as to decheck all modes is another hiden mode. it now connected as a 7 digit number ended by device. So. I think that cold bring us further…
Im tired so i will go on tomorrow. maybe mac will work like that as well… we will see.
Regards, novski

just found that in developer mode you have to activate the USB-Debugging.

1 Like

So did you solve the problem? Can you see the device from the operating system? If not, with high probability, something is missing and we have to inform Mozilla developers. Unfortunately, I do not have the device in order to try to flash.
Insert at the beginning of flash.sh script this line of code set -x in order to track the script execution.

1 Like

seams to me as you built with jdk-6. is that so?
.config - file:


im trying to make a build but its failing… don’t know where until now…
Regards, Novski

Hi erotavlas
I now built my own firefox os and had the exactly same situation. It stats that:
“Unsuported device “FP2”, can’t flash”
So its not something with your build its something in the build…
Can you more clearly describe where and what all i have to paste to the flash.sh script?

Thats a quite long file…
Regards, Novski

edit: add of printscreen for developers…
please don’t be irritated its a macbook pro with native ubuntu 14.4…

1 Like

I don’t know a lot (I’ve never tried it), but the build looks good. It’s just the flashing that fails.


sh -x flash.sh


bash -x flash.sh

(Could be a bash script, I see more and more useless, not portable bashism scripts these days, why?)

And post what the script is trying to do.

ok. both in one screenshoot. Thanks for help…

Regards, Novski

I think the script is looking for the right way to flash a “FP2” but it is not finding a matching device so it bails out and prints this error message (there is no matching device defined for “FP2”).

I would say screw this script and just flash the images by hand. :slightly_smiling: Or see if someone can update this script for you. Flashing by hand is not so hard, but it’s good to know what you do. If you look at your first screenshot you can see where the images are located.

See: “Flashing images” in here:

Hi novski,
yes you correctly built your firefox OS build. Your screenshoot related to flash.sh output confirm that the script is wrong, you have the same output of mine even if I do not have any fairphone 2 connected. Moreover, your system can see an attached device via adb. So if you want to try your build, follow the suggestions of fp1_wo_sw_updates.
I will open an issue on firefox OS.
Thank you for your time. We are slowly converging to a working version :slightly_smiling:

1 Like

hi erotavlas,

I already opend one, https://bugzilla.mozilla.org/show_bug.cgi?id=1244519
Regards, Novski

1 Like