English

✏ B2G beta (formerly Firefox OS)

If you did that while booting your phone, you should be in recovery. With that little Android Icon and such? Alternatively try PWR + Vol. Up Key on startup.
If your Recovery partition is really damaged, than you should try to fix that first, before attempting to do anything else, as the recovery is your only option to rescue your phone if someting goes very wrong while flashing your new system…

That should actually be found directly in out/target/product/FP2/ (at least for me it was with the FPOOS).

I’m new to this whole stuff as well, so don’t count on me, but to me it seems plausible that a variable called PREFIX is just that - a prefix with an unfinished end. :wink:

No problem, the images are actually smaller than I would have guessed. Such an image with comparatively low resolution and about 100KB is quite ok, I’d think. (Maybe you could try to cut down resolution even more …, but don’t know how much until it gets unrecognizable.)

I don’t think so. Power+VolDown is in fact the correct key combo to get in fastboot mode, whereas Power+VolUp is for the recovery.

1 Like

I don’t see anything (blackscreen…)

seams like i can’t get to recovery anymore. https://fairphone.zendesk.com/hc/en-us/articles/201149588-How-to-boot-my-phone-in-Recovery-Mode
I don’t see anything if i don’t attach a cable. If i have a cable attached the phone goes in to fastboot mode after some times… (even if i press vol up button…)

where can i get a recovery again? :grin:

Hi,
there was a trivial error on the flash.sh script that has been corrected by the guys of Mozilla.
Now it works for me even if I do not have a Fairphone 2 to make real test. Can you try to flash your Fairphone 2?

The fixed script @erotavlas talks about can be downloaded here or just updated with git pull.

https://raw.githubusercontent.com/mozilla-b2g/B2G/f7276c96cf8f8646069fc93b91428e08b38c074a/flash.sh

They just added “FP2”

+"panda"|"maguro"|"crespo"|"crespo4g"|"mako"|"hammerhead"|"flo"|"shamu"|"FP2")

1 Like

Sounds ugly that your recovery is gone and that the one you build does not work. Somewhere, it has been discussed whether an image of the recovery could be shared because it may not contain blobs, but there was no proper conclusion and I didn’t find a shared stock recovery image in the relevant topics. You could build the FPOSOS yourself and gain a recovery image (and a whole working ROM) this way. There is also an experimental TWRP recovery image, but this may not be suitable for your case. :wink:

If you have a recovery then, you could try flashing it via fastboot:

$ fastboot flash recovery .../recovery.img

Hi
Sorry @tphysm i whent over with flashing firefox os and was amused with playing around with it. So amused that i forgot to tell you guys that it now works. yes it flashes now correctly. jipey! Big thanks also to @fp1_wo_sw_updates and especialy @erotavlas for his supper eagle eyes to see that the name was mixed with the Devicename! Im glad to have that device rinning now.
but -and i awaited that- there are still some things to do. as:

Hardware report:

  1. The SIM card does not get active so calls are not possible by now…
  2. WLAN does not work ehter…
  3. The clock resets after a restart…

There are some working things:
bluetooth works well so a connection to a BT-Hotspot can be made to get internet. Uhhh…

over all i can say i love the feeling of that OS. Its decent. the sounds are absolutely phenomenal and the config is everyware clear. not as android what feels to me like always pountching a matress and sounds like a 1980 atari.

somehow i managed to get a prerelease 2.6.0.0 Version of Gecko

looking forward to get that nice device running. :grinning:
Regards, Novski

2 Likes

Hi Novski,
great, finally we solved the problem of flash.sh script together with Mozilla guys.
Thank you reporting the current bug of Firefox OS on Fairphone. Did you tried to flash only version 2.6 or also most stable version 2.5? If the second possibility is correct, please report your bug on bugzilla thread of Firefox OS porting.

1 Like

Very cool! Don’t apologize - you were our BETA tester for that. :wink: It sounds good, so I may give it a try soon (though unfortunately building takes hours on my machine). Thanks a lot for your testing!

actualy i was not aware of what version i built… And i don’t know how to change the version to be built as well… so if you have the knowledge about please let me know how to change.

It wold be great to have a comparison of some one who didn’t break his phone before! :joy:
I still don’t have a clue where the SIM problem comes from, because there is only one vendor in the proprietary blobs i think assume thats the driver for WLAN and is why it does not work but the SIM should work in my eyes…

and against my sugestion to be able to connect over bluetoth to internet it doesn’t work with my iPhone5s nor with a FP2-Android (i have 2 available here in my House…)

@MaartenD : what version are you running and how does it work on your side?

Regards, Novski

edit:
tryed to get a branch v2.5 but failed:
`root@novski-MacBookPro:~/firefox_os/B2G# BRANCH=v2.5 ./config.sh fairphone2
Get git://github.com/mozilla-b2g/b2g-manifest
remote: Counting objects: 3037, done.
remote: Total 3037 (delta 0), reused 0 (delta 0), pack-reused 3037
Receiving objects: 100% (3037/3037), 1.47 MiB | 1.35 MiB/s, done.
Resolving deltas: 100% (1850/1850), done.
From git://github.com/mozilla-b2g/b2g-manifest

  • [new branch] b2g-ota -> origin/b2g-ota
  • [new branch] bug_1226452 -> origin/bug_1226452
  • [new branch] master -> origin/master
  • [new branch] revert-203-bug1025788-v2 -> origin/revert-203-bug1025788-v2
  • [new branch] revert-226-v1.3t -> origin/revert-226-v1.3t
  • [new branch] revert-316-bug-1149387 -> origin/revert-316-bug-1149387
  • [new branch] v1-train -> origin/v1-train
  • [new branch] v1.0.0 -> origin/v1.0.0
  • [new branch] v1.0.1 -> origin/v1.0.1
  • [new branch] v1.1.0hd -> origin/v1.1.0hd
  • [new branch] v1.2 -> origin/v1.2
  • [new branch] v1.2f -> origin/v1.2f
  • [new branch] v1.3 -> origin/v1.3
  • [new branch] v1.3t -> origin/v1.3t
  • [new branch] v1.4 -> origin/v1.4
  • [new branch] v2.0 -> origin/v2.0
  • [new branch] v2.1 -> origin/v2.1
  • [new branch] v2.1s -> origin/v2.1s
  • [new branch] v2.2 -> origin/v2.2
  • [new branch] v2.2r -> origin/v2.2r
  • [new branch] v2.5 -> origin/v2.5
  • [new tag] B2G_1_0_1_20130213094222 -> B2G_1_0_1_20130213094222
  • [new tag] B2G_1_1_0_hd_20130530182315 -> B2G_1_1_0_hd_20130530182315
  • [new tag] B2G_1_1_0_hd_20130530182315_BASE -> B2G_1_1_0_hd_20130530182315_BASE
  • [new tag] closing-nightly -> closing-nightly
    fatal: manifest ‘fairphone2.xml’ not available
    fatal: manifest fairphone2.xml not found
    Repo sync failed`

can somebody declare me if thats a bug or just a miss understanding the code of me?
source: https://developer.mozilla.org/en-US/Firefox_OS/Preparing_for_your_first_B2G_build
thanks.

Hi,
according to this https://developer.mozilla.org/en-US/Firefox_OS/Preparing_for_your_first_B2G_build you can change your branch via
BRANCH=branch-name ./config.sh <device>
at the moment that you run config.sh.
You are right v2.5 does not build. I checked this https://github.com/mozilla-b2g/b2g-manifest/commit/d8be0d5112a2db6837dbd83adc2c22bed570c359 and Fairphone 2 is present only in the master so I was wrong.
In my opinion, you should report your impression and probably bugs on the Bugzilla thread of Firefox OS porting.

@novski: I’m now running ./config.sh fairphone2. Have read through this discussion. Is my understanding correct that there was a typo (“fairphone2” instead of “FP2”) which caused your problems? Is this now fixed or do I have to manipulate the source code myself? For the config command I needed to use “fairphone2” instead of “FP2”. At first glance, this made me think that it’s not yet fixed. However, then I realized that this is more a ‘user-related’ variable and so “fairphone2” might just be more reasonable than “FP2” there. Anyway, my actual question is: Are the issues fixed or do I need to fix sth. by myself?

This is totaly correct.
The bug is fixeg and if you sync the repo it will load the corrected files.
The bug was in a different part. Not related to the choose of Devices…
Are you aware that no functionalities that you espect from a phone are working jet?
Regards, Novski

edit: firefox developers have tested the os with no bugs so mine might be related to my manual flashing and braking of my recovery. if anyone else cold set up and give me a note if its running i wold be glad to hear… scroll all down… Link

How did you insert the blobs? Did you follow the adb pull command from the FirefoxOS-instructions or did you insert them using https://code.fairphone.com/projects/fp-osos/dev/fairphone-os-build-instructions.html#getting-the-binary-components? In the latter case, how do I do that? Just with exactly those commands executed in the B2G directory? Or do I have to copy them around?

Yes, I think I got that. :slightly_smiling: But where was it or maybe better: What was it? Was it that they wrote “fairphone2” in one place (as sort of a variable) and “FP2” in another and those didn’t match? I’d just like to understand. :wink:

Yeah. I’m just curious to try FirefoxOS, only as a test (for my “productive” OS I’ll probably get back to FPOSOS). :wink:

Thanks for your help!

Because you chose fairphone2 in the ./config.sh it knows the path to go and download it by it self. You will see it in the start of the ./build.sh that it first goes to download that… I even see that its checking for updates and gets the newest…

Yes exactly. Its described here: Link
And you can clearly see it in one of the Links in that Bugpost… Link

Be careful the firefox os is mutch more delightful. You cold get stuck to it… Android is a wreck.
And by the way if you read the first link at the end you can read that there is a developer who made most working already… Seams like mine is a exception, so im currious how yours will work. Please keep us updated here…
Regards, Novski

Tried building last night. It failed in the end. Don’t know exactly why. As far as I understand from the build logs, making recovery image was successful and then a few lines after “Construct recovery from boot” the build failed. Don’t know what to take out of that, though.

Cool. Unfortunately, I downloaded, extracted and ran the the blobs sh by myself and build afterwards. Could this be the reason for the build failure?

I’ve not seen this in my build log. Seems to still use blobs version 2.0.0

Well, maybe I’ll try building again after

$ rm -rf objdir-gecko
$ rm -rf out

Is that enough to wipe out the blobs I’ve manually added?

Fairphone publishes their blobs, so I think showing the script the files from the unpacked tar file would be the easiest way. But I have not tired building FFOS yet or looked at scripts. I just think it would be easier.

Wait with that. I think there is a problem with the repo in general. Im trying to find out with @erotavlas.

True. I thought i have seen that in past…

Im actually also not shure so if somebody know exactly what steps are to be repeated and what part have to be wiped out please let us know…
Regards, Novski
edit: the new bugfile

Due to this comment I thought the issue had been fixed and here seemed to be a patch. After a repo sync this patch wasn’t included though, so I manually edited those two files and tried ./build.sh -j1 which was successful. I flashed it and it rebooted, but I had major problems:

During the language and time setup the OS suddenly crashed (at least I guess so) and the screen was black. Moreover, several windows opened on my desktop (as if I had plugged in several external devices) with additional warning popups (e.g. sth. like “Android can’t be mounted”). Needed to unplug the phone from the PC for this to stop. Additionally, I needed to hold the power button longer than normal to (re?!)boot the phone (I interpret this as a hint that the phone was not yet powered off). I noticed that the back of the phone got really hot (probably the CPU) which may be related to the crash. The procedure is the same after every reboot.

Btw the Fairphone logo which pops up directly after reboot is smaller than it normally is (i.e. it does not fill the whole screen).

Recovery and fastboot mode were still accessible and I reflashed the FPOSOS successfully.

Hi,
I confirm that now building work again with the latest update. You can find latest build here https://mega.nz/#F!2UsjWBZY.