PDF reader crash when opening PDF file

Hi Folks!

Whenever I open a PDF file (currently using “PDF reader” or “VuDroid”) the app immediately crashes.
Both apps appear to run when I start them directly, but they fail to browse the files correctly (I can’t navigate to my PDFs). So maybe this is a permissions issue? (I’m on a self compiled OS)

Anybody else having this issue? I don’t even know how to tackle this problem. Is there way to make the apps tell me something more usefull?

I’d really appreciate it, if somebody could help!


Did you already try this workaround?
Re-enable Privacy Impact by unticking the option found at: Settings > Sound & Notifications > Privacy Impact

Good idea, I already forgot about that issue.
I have Privacy Impact enabled, as something else would’t work otherwise.
I tried ticking and unticking anyway, but without any difference.
Do you have a working PFD reader installed? Maybe I can at least rule out that I’m using a broken reader (unlikely, but still…)
Danke für Deine Zeit!

I had that problem too. Try “WPS office”

I use Foxit PDF and until now, I’ve had no problem with any file. But since there are different PDF versions made with different programms, on my FP1 I ended up with three or four different PDF readers to be able to open all PDFs people email to me.

Thank you both! I tried Foxit PDF, and it appears to be working.
So apparently, it’s not a problem with the OS. (After all this compiling, rooting, and modifying I’m … wary)
Now that I know it’s not hopeless, I’ll go on a hunt for a FOSS app :slight_smile:
Thanks again for helping so quickly!

For future reference: “PDF Reader”, “VuDroid”, “APV PDF Viewer” don’t work (in the manner described in OP); while “MuPDF” appears to be working.

1 Like

I was just about to recoment MuPdf as well.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.