Parts of the touchscreen don't work - See first post for troubleshooting

Cleaning the pins and the contact area with pure alcohol before reassembly may probably help.

Hi all,

I’m having some issues with my FP2 since yesterday. Since then the touch screen does not allow me to type the letter [i] when held vertically and instead types [o]+[u], similarly it does no longer allow me to type the letters [q] or [a] (I am using an English UK keyboard).

Due to the location of the unresponsive parts of the screen I am also not able to accept incoming calls.

I have tried to change the settings of “Touch and delay” but to no effect. I was also unable to enter the Factory mode to see if this was a hard– or a software issue; all the information I could find on the matter was for the FP1.

It may be relevant to note that my FP2 also does not allow me to hang up 75% of the time, unless I keep the phone on speaker. I have thus as of 5minutes ago changed the settings to be able to hang up with the power button.

Finally, as far as hardware is concerned the FP2 has not been experiencing anything out of the ordinary in the last week – i.e. it was not dropped on a hard surface or in any liquids. I am in the Colombian Amazon right now but I do not think that the generally high level of humidity is at cause as this FP2 has already been through rougher patches in that regard.

I moved your post here as you describe the same issue.

Hard Reset works the same on FP2 as on FP1 except Power is used to select instead of Volume Up.

I am having this Problem since the last update. I am very sure it wasn’t there before.

same issue here,
there is an area on the left side of screen which doesn’t react since i made the update to 1.3.6:

any advice?

Me too here.
After the Update to 1.3.6 i got first the weird input bug:Fairphone 2: Crazy touch inputs (touchscreen issue) - workaround (for some): increase touch & hold delay
The workaround helped, but one part of the screen (left side like directly above) is not touchable.
So is also think, it is a software-bug …

Olease can anyone Help me.
The right side of the screen of my fp2 isnt working anymore. I tried to switch to another keyboard, but that makes no difference. And i cannot move an app to the right sided screen! Also tried to change some keyboard settings like keyboard hight andso on. But still the same oroblem.
Where can i check or activate edge swioe?

U know what some of the ‘o’ s need to be in this text because i cannot type the letter right of it and am using dictionary to type.

Please help, this is very Unoractical

1 Like

I moved your post here. As you can see, you’re not the only one with this problem. I suggest you read through the topic.

To get back to my previous post (way back): Due to the number of tickets coming in, it took a while for Fairphone to get to mine. Then I became the blocker, backing up the phone, packing for transport and having to schedule the phone pick-up. Once Fairphone got the phone, repair and return was pretty fast. Also I found calling them is a pleasant experience, no long waiting delays, and good answers. Now I’m happy with a new screen, and in the process of installing the new Open Source Android OS.

My advise: walk the official path (creating a Zendesk issue), and make sure you don’t block the support process. You can already start backing up your phone, and preparing for sending through the postal service.


Hello Fairphone users ! :slight_smile:
So today this happened : for absolutly no reason the very left side of the touch screen stopped working.
I didn’t use the phone that much today (just to send text messages), I didn’t fall it on the ground… and about one hour ago it stopped working ! I tried to reboot it and it’s still not working. It’s very anoying because I can’t type some letters because of this :frowning:
Did it happen to you ? :confused:

Here’s a sketch to help you understand :

Now I have two screen strips that don’t work - lining up with the Q and the I! Until I get a chance to send it in, it is like a puzzle trying to get anything done. Often having to rotate to get a button into a different position. And vital is the Swype shortcut that can move the keyboard to the left and to the right. But then sometimes I get to the final hurdle and still can’t hit what I need to!

I have a similar issue since yesterday, a whole column on the right does not work:

The phone did not fall or something like that. It just occured that it rebooted some kind of - but not a whole reboot as this would had asked for the encryption password, but it showed the booting animation for about a minute and then I was back in Android without having to enter the sim pins - kinda strange.

I removed the display and set it back in - no change.

Where can we find a phone number to call them ?

At the bottom of the page Fairphone Support.

Is there a waranty ?

There’s a warranty of two years.

okay, thank you both for your answers ! :slight_smile:
so this means that I can replace my screen for free by contacting them :slight_smile:

hey @nicorikken … can you please tell us, if the bug comes again after you got the new display?
The main question is: is it a software, or a hardware-bug?
Sometimes, my screen works everywhere, but mostly a part on the left dont work …

So I installed the Open Source version of the Fairphone OS and while being in the recovery menu I recognized the screen does not work there, too. So this is not a software issue on my side.

Blaming the connector is bullocks if you look at your screen there is on their what is probably clearly a management chip which means that this chip is communicating data with your phone and therefore an individual pin on the connector at not relate to a particular area of the screen but then these people have already been caught out with shoddy products so lying is probably the next best thing