Out of the blue USB-C connector won't work

Hi all,

So here it is, this morning it take my phone from the charging cable like every morning, full battery, all good.

This afternoon I needed to charge my phone again (I had navigation to work, did quite a lot with the phone), so I try and plug the cable that’s always ready on my desk, but it is like it won’t fit until the end. Feels like the last millimeter won’t go, and the connector won’t click in place.

I thought there might be something in the connector, bit it’s just clean.

I have tried 5 different cables of which I am certain they worked perfectly yesterday still.

I ended up having the keep a cable in place with a bunch of elastic bands so i could charge the phone.

Is there a known issue with the connector that might explain this?

Welcome to our Community Forum :slight_smile:

You might want to check if the USB-C port is still firmly connected or has gotten loose:

I have done this myself 2-3 times already, all without an opening pick and without a spudger.

However, if you feel uncomfortable doing so, you might want to contact Fairphone Support first (they might ask you to send in the device though).

1 Like

Did you try to clean it or did you only checked it optical? I my experience it often in looks clean but when you go scratching carefully inside the connector with plastic or wooden tools there is compressed dust which causes this behavior.

I use a thin plastic toothpickto to do this with patience and a good light source is helpful …
Good luck


I have cleaned it gently with a thin wooden toothpick, i thought I saw some fluff, i got the tiniest bit of dust out, but what I thought I saw appears to be integral part of the phone. As far as I have been able to see and feel, there’s nothing more in there, but it still won’t work unless I actively keep the plug pushed in.

@urs_lesse this seems to refer to the middle plate of the charger port am I right?

See two photos of the isolated USB port spare part here:

1 Like

A normal wooden toothpick is too thick, I split it in half to get in.
If I look into the connector I see silver, metal sheet color around the “pin header”. If you can see it too there is maybe another problem and no dust or debris inside.
Good luck

1 Like

Little update:
a couple of days ago I started opening my phone to see what was going on…
It was really easy to get the USB connector out, it wasn’t out of place and made contact properly.

Once I held it under a good working lamp I saw there was actually some highly compacted fluff inside.
It was so compact that at first when I went over it with a toothpick it felt like it was part of the metal casing, and the same colour too.

Luckily, having the connector out offered a lot more freedom to pry the thing out. Now it’s all working fine again!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.