OsmAnd just disappeared after Android OS update

This is weird, my OsmAnd app completely disappeared from my phone (not even able to locate it neither in Amaze or Ghost commander) after the latest FP2 Open OS update. I downloaded it again from their website, but I have no idea how to put the maps I had downloaded into the new version. I do have a TWRP backup on my SD card, so they should be somewhere to find, but I fail to understand where.
I have of couse also reported this in the app itself, but if anyone has an idea here, I’d be very grateful.

If you use Amaze or whatever on the phone, the downloaded offline maps should be in /storage/emulated/0/Android/data/net.osmand.plus/files as OBF files.
(However, when connecting the phone in MTP mode to my Windows PC, these files are not visible in Internal Storage/Android/data/net.osmand.plus/files although they exist.)

Momentarily I can’t seem to find a way to browse the contents of a TWRP backup for individual files without restoring it … the tools I googled to browse nandroid backups or EXT4 partition images (Nandroid Browser, Ext2read, OSFMount, DiskInternals Linux Reader) somehow don’t work with my backups (after unzipping), or they might be outdated, or I’m missing something simple (offset some bytes or something like that?), so I’d need some help with that myself :frowning: .

1 Like

Same problem here. Osmand disappeared after the latest update (and so did Endomondo). So I reinstalled Osmand, but now it crashed immediately after starting it up.
Couldn’t find any solutions at this forum yet.

It looks like it must have something to do with the problems the updated OS has with recognizing and using the SD-card. I had saved the Osmand files at this SD-card before the update.

For now I will try to install another nav app and wait and see if anyone finds a solution.

I just tried Maps.me from f-droid, but it seems it’s only possible to search for a route from where you are, which is a pity (for a planner like myself). We’ll see if anyone else here has any ideas, or could at least forward it to the developers of FP Open.
I managed to install OsmAnd again, though, but it says “only 7 maps”, something I didn’t have a problem with before, without paying. I do get that they may need money, it’s just difficult to pay without gurgle installed.

Have you tried copying the TitaniumBackup Files to the internal storage and setting the folder there? Maybe then you can reinstall from backup.

Did you install it from F-Droid? The F-Droid Version is free and unlimited.

1 Like

Titanium backup? I’m missing out on something here :smiley:
I also noted that Pocketmaps has lost the only map I had downloaded. Must be something with external storage.

I couldn’t even find it on F-droid at first, and now that I have found it, it says “Unknown application”. I’ll install it when I get to a WiFi.

The signatures of the Google Play and F-Droid versions are different. When switching between these two versions, you have to uninstall the other version first.

1 Like

I missunderstood, that you had backuped using TB. If you have the maps in a backup file, just copy & paste them to the new directory and everything is fine.

Is there any solution available? I do have the same issue. Moreover I bought the “plus” version, but I am not able to install it. The installer returns with “-505”. Does anybody know how to overcome this issue?
Thank you in advance. I am using FP open with GAAPS pico. It worked with Android 5…

Check under Settings > Apps (or whatever it is called these days) to see if it is still listed. If it is, uninstall it. If that doesn’t work, check this:


Afterwards, you should be able to reinstall the app.

Hi Johannes,
thank you for your advices. These are my experiences:

  • OsmAnd+ was not available in Settings | Apps
  • In Security | Administrators I could find the free version of OsmAnd. But it was not activated-
  • I have deinstalled the free version of OsmAnd
    - OsmAnd disapeared from Security | Administrators
    - the folder /storage/emulated/0/Android/net.osmand has been deleted.

Since there was still a folder/storage/emulated/0/Android/net.osmand.plus I deleted this manually.
In addition I removed the SD-Card to which I had moved some files before I upgraded to Android 6.

But finally there is the same error-message “-505” when I try to install the plus-version…
I would appreciate, if you would have some more ideas. I was planning to use this app the next weeks on a hiking trip.
thank you

I’d try deleting the data and cache for the google play store and google play services. If that doesn’t help, this post over on the google support forums seems a pretty complete summary of things that might help.

1 Like

Thank you again.
I have followed the instructions of your link but I was not able to install the plus version. Finally I have deleted all net.osmand.plus-folders and installed the version 2.7.5 from F-Droid. This worked fine. Unfortunately I do now have to buy the contour-lines, which I could install yesterday at the free version. Today it is not installable from F-Droid and costs 1.19€ in Google play-store. This would certainly be affordable but I am hesitating because of all the troubles mentioned above.
I will do some further investigations…
Best regards

I cannot install the Plus, since I don’t have Google on my OS, so it seems we’re stuck with the free version. I guess it’s better to ask the app developers to let us buy it from their website, without strings to Google.

The f-droid osmand version has the same features as those present in plus. Stuff like the contour lines is currently a bit more tricky (see here). If you take the f-droid route, consider donating to OsmAnd development.

I sure don’t mind donating, it’s a great app, I just don’t understand why I couldn’t find this one in F-droid before? Do you have any inside information as to whether or not it has been out of F-droid for a while?

Not sure, but a lot of apps on f-droid have been disappearing and reappearing. Might be the same thing as is discussed for the contour plugin (issues with signing of source code, or certain other aspects of the code itself). So I guess it just wasn’t there when you looked for it.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.