English

OsmAnd: GPX records nothing (no track)

Tags: #<Tag:0x00007f05e49448c8>

Hi and thanks for helping

Phone: Fairphone 2 / Android 7.1.2
App: OsmAnd+ 3.3.8
Extention: GPX (Streckenaufzeichnung),

The extention “GPX Tracks recording (Streckenaufzeichnung)” are running well, everything are correctly arranged (Profile “walk”, interwall, …) and I can start / stopp the GPX-Track and “save the track”, but not track recording are running and no track will save in any folder. Please have a look on the screenshot / grafic:

Thanks for any help & best regards

Is your storage full? I got weired and unexplainable results when I found another app has stored too much on the particular storage.

1 Like

Hi Amber

Thanks for answer. No, my storage has a lot of free space and
no other App are a problem.

Any other ideas?

When I start the recording I get the following options:


If you select “show it on map” (if you get the dialogue), does it show you a red line for the way you’ve moved?
For me it works on Osmand 3.3.8.

Hi Volker - thanks for your answer.

  • Yes, the start are the same
  • No, I can’t see a red line … & also the distance and time are always “0”.
    I can start / new track save / stopp and every other settings I can make, but not track, nothing is being recorded. Under “settings” > “my places” > “tracks” are no new track (see screenshot / grafic from my first post)
  • Yes, I got the same version 3.3.8

I’d seen that. I’m sure there’s nothing saved as there’s nothing recorded. So analysis should go in this direction (why is nothing recorded instead of why is nothing saved or why can’t saved file be found…).

Whenever you’re in the my tracks menu, is the time counting there?


…or did you just refer to this time counter there?

Edit:
With “Android 7.1.2” you mean FPOS 19.05.3?
When you move around, do you see the blue flash in osmand then?

:slight_smile:
No. No time or distance is ever counted.

FPOS: 19.02.1 - will make update now - give a feedback after …
I see a blue arrow moving with my position.

Good idea. As some have had problems with/after the update I recommend to do a backup before the update (if possible)…

Maybe it can be resolved in the addon’s option, increasing the minimal precision of the location to be recorded, or the minimal speed ?

Hi bolika
Everything tried, but without improvement.

Have updatet to FPOS 19.05.3 and make a try to save the tracks in a new/different folder. No changes :frowning:

As I’ve said I don’t think saving is the problem but recording…
When I’ve time I may try to install FPOS 19.05.3 an try it on that platform…
Have you checked if Osmand has any available right allowed in the system? (at least for a test you may give it ANY right…)

I’ve just installed Osmand+ on a fresh FPOS 19.05.3. Recoding (and saving it) works fine. So there must be something in your configuration…
If you have a working backup you might try to clear cache and data of your Osmand and try again then…

1 Like

I have given OsmAnd+ the rights camera, microphone, memory and location. No improvement.

O.K. - but where :slight_smile:
Have deletet all date and cache. New install of used maps and all specific rights and settings again. Tracks can still not be recorded/saved.

I give Cam, Micro, Storage and Places - no improvement.

I think that after installing osmand I only enabled the recording plugin and started recording (and I think I had to give osmand rights to access location service). Did you change more settings?

Thanks. I’ve already tried everything - no change.

Dear all
I’m trying to stop using osmand+ with gpx. That doesn’t work. I will use another app. Thanks for your support!