English

Oooh. Ohhh. Lineage 15.1 (testing)

I finally got :cookie::cookie: working. For TitBackup you need a su-root .ZIP file. I tried it with the 14 Version,didn’t work.
@chrmhoffmann ist there a root zip?

2 Likes

If you try this, then why not with the 15.1 version of the su addon :wink: ?

Else … you can just activate root in the developer settings of the test build so far without further ado, so I thought it would be already rooted, but I could of course be wrong.

Does Titanium Backup complain about missing root?
Edit: Ok, apparently it does, I missed that.

1 Like

@AnotherElk Seems that activating root in developer settings is not enough.

1 Like

I did it and it works, great ! :smile: Now I was able to restore all my app+settings with Titanium!

3 Likes

Mee too ! :cookie::cookie::cookie::cookie::cookie:

2 Likes

Strange. I installed titanium backup. It requests root access and once granted, it seems to work. No root zip needed - I build the rom with su support enabled through developer settings.

Chris

3 Likes

I installed Oreo yesterday and am still testingn and installing my apps. I found the following bugs:

  • TitaniumBackup cannot access my SD card
  • Reboot to Recovery always boots the system, not recovery (have TWRP installed)
  • I use 2 SIM cards. When I boot I enter the SIM1 PIN, then SIM2 PIN is asked, but dissapears again. Sometimes I have to unlock the phone, then I am asked for SIM2 PIN. Other times it appears itself. I will see, if I can find a rhythm.

Nice-to-have:

  • FP ringtone already set as standard. :sun_with_face: :musical_note:
2 Likes

I borrowed one of the demo FP2 that we have for the next #austrianfairphoners event (thanks to @werner_noebauer, who did a same-day-delivery) and now successfully installed LineageOS. These are the steps I took:

  1. Boot to recovery.
  2. Select “Boot to bootloader”
  3. Flash TWRP using fastboot
  4. Wipe Format data using TWRP.
  5. Sideload LOS 15.1

First I did not do (4) and was stuck in a bootloop…

I will report back if I run into issues.

2 Likes

First question: I cannot find how to setup WiFi with the WPS button on my router. Can anyone help me?

Ps: In the WiFi dialogue the three-dot-menu seems to be missing.

Edit: Ok, found it. It’s hidden in WiFi settings > Advanced > WPS push button.

1 Like

Do you know how I can give installation permission to the default file manager?

Oh, and another issue: Scrolling down in the default browser most often works, but scrolling up fast most often doesn’t have the fade-out effect (e.g. the page slows down - instead it apruptly halts). This one is pretty annoying when browsing. Edit: And it reminds me of https://forum.fairphone.com/t/firefox-problem-with-touch-events/5843 , though it’s different.

If I go for example to the develop options (for the sake of having a long list to scroll), I don’t see this behaviour.

I just noticed one more thing: IPv6 works in tethering mode! :tada::tada::tada::tada::tada:

4 Likes

The following worked for me:

Yes, I read that, but I didn’t have a microSD card at hand. I managed to install F-Droid via adb install.


Could you check out your Installed Apps in F-Droid? My F-Droid thinks that I have almost all apps installed that start with an “A”… (This also make it impossible for me to install AntennaPod because of a signature problem.)

I tried to upload a screenshot here, but after clicking the screenshot in the upload dialogue, it closed and didn’t upload anything. Now the upload button in the lower right corner of the post editor doesn’t do anything.

I just tried was able to install Antennapod.

Also within F-Droid (in German: Optionen > Installierte Anwendungen verwalten) it shows exactly the apps I installed via F-Droid).

Which F-Droid version are you on? I’m on 1.2.2.

F-Droid version 1.2.2 here, too.

I could install AntennaPod now, but the installed apps still show many apps that aren’t really installed on my system.

Did you format the data partition before installing LineageOS?

Yes, I did “Format Data” in TWRP.

Edit: Funny thing: F-Droid on my FP1 also shows apps as installed that aren’t installed at all… :upside_down_face:

Edit: I just rebooted, cleared Data of F-Droid and updated the repository again. After restarting F-Droid it only shows the apps that I have actually installed.

Once you open an APK, it asks for it. I wasn’t able to grant it to the default “Files” app, though, in LOS 15.1 on my Nexus 4.

I’m actually on latest unstable F-Droid in my Nexus 4, which solves various issues in Android O (e.g. repeatable automatic installations).