English

Oooh. Ohhh. Lineage 15.1 (testing)

Some problems I encountered

  • poweroff does reboot with new camera modules (happens on 14.1 as well)
    • rebooting into lineage recovery + poweroff there is ok
  • after booting, there is a message that the owncloud app was stopped
  • owncloud app cannot download files, gives error that it failed to finish download (it does have permission to access files)

Things that work and not mentioned yet

  • screen mirroring via WiFi direct and a Samsung BluRay player
  • boot time feels shorter than with 14.1
4 Likes

Code is also on gerrit now.

Chris

1 Like

Build installed via TWRP 3.2.2-0 (Releases)

The following things work for me so far:

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network
  • location
  • compass
  • screenshot
  • main camera (new module, flash works correctly with Open Camera, not with the stock Camera App)
  • selfie camera (new module)
  • USB connection to PC / MTP
  • alarm
  • MyPhoneExplorer 1.8.9
  • root (Settings - Developer Settings - Root Access)
  • USB OTG
  • WiFi hotspot
  • Bluetooth (music playback, data connection)
  • FM radio

Confirmed. LED works for the battery status now :+1: .

It reboots with the new camera modules.
Without them it powers off.

And with encryption in place it powers off from the start pattern/ PIN/ password even with the new camera modules.

7 Likes

Would it be possible at some point to repartition so as to support A/B updating?

1 Like

Some more problems: I wanted to download the fdroid app from their webpage in Firefox. After tapping the download button, I see “Starting download…” in the Firefox status bar at the bottom. But then nothing happens.

For the moment I installed it via adb install /path/to/FDroid.apk from my PC.

Then I wanted to install the fdroid priviledge extensions. Installing the OTA package puts the actual install ZIP file in /data/user/0/org.fdroid.fdroid/ota which then needs to be installed from recovery. But that failed with the lineage recovery

  • navigating to the above folder was impossible; if the folder/file list is too long, you can scroll down but when you tap the desired folder, it actually evaluated the tap as if you hadn’t scrolled at all (tapping “user” actually opened a folder starting with “a”)
  • after copying the ZIP file to the SD card I could select it for install but then the installation failed

So I switched to TWRP and got it working.

1 Like

Related? …

That’s what I think, too. But I haven’t found a way to find out more. In the logcat I didn’t see anything that looked related (system is rooted).

How did you download firefox / owncloud app then?
I think I cannot reproduce that.

Chris

I have occasionally the same problem in LOS 14.
I even cannot take any pictures.

Unfortunately I haven’t created a bug report yet.

In Open Camera, you could enable “Use Storage Access Framework” and then select a folder where to store the pictures, that should help at least for that App.

1 Like

I downloaded all apps via play store.

Just tried downloading fdroid with the built-in browser and that worked fine after allowing access to files.

Edit: one more thing I tried is typing something in Jota text editor and then saving. The save dialogue shows 3 folders below /storage. No matter which one I tap, the error is always “access denied”.

It won’t solve the problem for messenger apps.
Only power off, wait some seconds power solves it. Just pressing restart in the power menu doesn’t work

I have finally compiled my own build. Everything seems to be working fine. I had to remove the camera modules to encrypt my phone (the phone is crashing upon reboot with the new camera modules).

Performance is great! The animations seem a little smoother that on 14.1 which makes it pleasant to use.

I’ve downloaded F-Droid and couldn’t launch the APK installer somehow. After moving the APK to the external sd card, I was able to install it without any issues.

Encryption works (as described by @AnotherElk), I can confirm though that TWRP cannot deal with the encryption (I’ll try to get some debug information on that later).

It takes some time to get used to the new icons and menus. My favorite feature so far: Being able to change the font size and display scaling. I have reduced the size of everything just a bit, which gives me a bit more screen space.

EDIT: Forgot to mention that dual SIM works great now! Thanks @chrmhoffmann!

Here are some screenshots from the initial screens (changed the wallpaper and the theme to dark):

6 Likes

Great!!! The dark theme looks definitely amazing…

LineAge 14.01 has this aswell though…

1 Like

Here is the part from logcat when owncloud fails to download files: https://pastebin.com/X3kVvX3J

07-22 18:51:38.932 11299 11339 E DownloadRemoteFileOperation: Download of /Notes/Einkaufsliste.txt to /storage/emulated/0/owncloud/tmp/foo@bar%2Fbaz%2Fowncloud/Notes/Einkaufsliste.txt: Unrecovered transport exception
07-22 18:51:38.932 11299 11339 E DownloadRemoteFileOperation: java.io.IOException: No such file or directory

In fact there is no /storage/emulated/0/owncloud/ folder (it exists on Lineage 14.1).

I have added my bits concerning that to GitHub as proposed by @z3ntu

On another try I’m happy to report that you can leave the top module in the phone, disassembling the main camera module was enough for me.

2 Likes

What if you create it manually?

1 Like

Once I create all necessary sub-folders, I get a permission denied instead of file not found.

Basically no saving/accessing of files works with non-preinstalled apps. Even taking pictures with Camera ZOOM FX downloaded from the play store cannot save the pictures I took.
Taking a picture with the built-in camera cannot be opened with QuickPic.
That’s of course always granting the apps permissions to files when they ask for it.

I think I found the “download” issue. I had to reimport sdcardfs. Looks like my old version was broken/imcomplete for O. Anyway firefox downloads at least seem ok.

Will upload a new version soon.

Chris

5 Likes