OI Share Olympus App not working on FF4

I have an Olympus Camera OM-D which has an app, OI Share, to download photos on phones. I can’t make it work on FF4!! The phone connects to the App and I see the photos, but it fails to download them.
A forum suggested latest Android updates as cause, followed the suggestion of resetting it all, to no avail. I wrote to Olympus but given it works fine on my old phone still, I feel it is to do with FF4!
It is kind of a dealbreaker so hope I can get it resolved and keep my FF4!

Thank you! Ch.

Welcome to the Fairphone community,

Do you happen to have a SD card installed in your phone?

Hi Incanus,
Yes, I do. The setting is for photos to go there at present.
That said, I also tried to change it to body, it failed that too

Is the SD card possibly formatted as internal memory? A lot of errors like yours are coming form that.


Can’t remember what a chose, but it is possible.
Would it not have worked thou with download on body option if the issue was the SD?

Please check the settings in the memory overview.

What exactly do you mean with ‘body’? The camera?

1 Like

You can check the formatting via Settings > Storage There’s an option to see what you have, Top right three dots, if you have an eject button that’s portable and would hopfeully avoid some issues.

Hi both
@Incanus yes, sorry, by body yes, I mean the camera memory

@anon9989719 thanks, on the 3 dots I have: Rename, Eject, Format as Portable - I guess it means internal formatting?
I could try reformat, though that requires some work to first save or if possible transfer to internal memory. Yet I suppose I wonder why the IOApp doesn’t download to phone memory if the issues is the SD… if that makes sense?

Yes saving your stuff is the next hurdle, :frowning:

The SD is seen as part of the internal memory and is encrypted so
a) there is only one memory [Internal Main + SD }
b) being encrypted means you will either have to try and manually move thing to an OS folder or use something like Google account and cloud to uplaod everything and then retrieve it once you have reformatted the SD


Ok, it could be then. Only one (painful) way to find out… I🫣

1 Like

Resolved! Photos are now downloading

Thank you @anon9989719 and @Incanus for your help!!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.