English

Official LineageOS is here!

@snevas and @chrmhoffmann: I miss in this topic a hint of how to update the modem files. And a matching sha256 hash. Also the note which modem files are recommended with LineageOS. There is no hint on the [official install page] (https://wiki.lineageos.org/devices/FP2/install).

I’ve asked @jnsp if he has a location where he collects all the modems and then I’m going to mention it in the start post.

2 Likes

Additionally, instructions how to make the modem.zip yourself would be nice.
Hints were here …

1 Like

I’ve added the modem location to the migration instructions. Maybe @z3ntu / @chrmhoffmann can add these to the lineage wiki?

Thanks @jnsp!

3 Likes

Also for reference (and for postmarketOS) I have created a git repository which contains the contents of the modem files here: https://github.com/FairBlobs/firmware

1 Like

I currently have problems connecting unencrypted wifi’s, which have 2.4 and 5GHz access points at the same time. Does anyone have a similar problem? And there is no switch in the wlan menu to change that behaviour.

Just changed to the official build, everything went smooth and everything’s working . Perfect. Thank you for all your work!

2 Likes

What about sending some logs.
Chris

Moved to the Official LOS right now without problems. Surprise - settings/ launcher had been kept :slight_smile:

Switched to LOS 31-10 version from FPOOS 17.04 (yes, still Android 5 :blush:). Switch went without a hitch. Caveat: there was not a lot of data on the phone itself.

I really like the improvements I see. Battery is so much better in my usage (phone is mostly idle). It seems snappier but that might be my excitement :grinning:.

Great work @chrmhoffmann, @snevas and everyone else who worked on this.

I have some issues still left:

  • can’t connect to servers on my home network (DNS problem)
  • still have to install microG for the following:
    • location
      A first try as normal app didn’t give me location. I’ll give it a try again as system app as indicated on the microG website.
    • installing some apps from g* play story

I’m also wondering how much work an upgrade will be (tingle, fdroid privilidged, home CA cert as system cert).

For posteriority: I installed GmsCore in /system/priv-app as follows:

  1. remount /system as rw: mount /system -o rw,remount
  2. Create directory /system/priv-app/GmsCore whith following permissions: root:root and rwxr-xr-w
  • mkdir /system/priv-app/GmsCore
  • chmod 755 /system/priv-app/GmsCore
  1. Copy GmsCore.apk into this folder
  2. reboot

I think their are many users who never used a terminal before and give up with installing LineageOS when reading something like “adb” or “USB debugging”. I’m thinking about an easy way for them to install LineageOS without adb and USB debugging.
May be someone can verify that my idea works!?
If yes, I think these steps would be possible even for users who are a bit shy with computers.

  1. Install FP Open with Method 1. (This is using Amaze and FP OS Updater. The advantage is that FP Open comes with the recovery named TWRP that you need for the following steps.)
  2. If you like you can give yourself root. (This is not necessary.)
  3. If you like to install the newest version of TWRP you can download and install the twrp app to flash the newest version. (This is not necessary.)
  4. Follow the official steps for Installing LineageOS from recovery. (You have to download the lineage-…fp2…zip and installing it by clicking in TWRP).
2 Likes

Save yourself the work for future updates, :slight_smile: :

6 Likes

That’s cool.

How can I use it when I have already installed the apps. Would it be sufficient to add a file to addon.d ? Or do I have to sideload the whole zip ?

Second question: what would be the advantage of the DroidGuard Helper ?

That would be a good idea. With a full-time job and family, I don’t have a lot of time anymore to spend nights figuring things out.

Would be great if we could have a ROM that included commonly used apps and tweaks. Maybe starting from the microg.me and adding osmand, … so it becomes really functional out of the box.

Of course, that opens another can of worms: what are the default apps :stuck_out_tongue:

The community couldn’t even settle on F-Droid. :wink:

1 Like

A way to please almost everybody would be the OpenGApps way … LineageOS “zero” (bare LineageOS) … LineageOS “pico” (some stuff added) … LineageOS “nano” (some more stuff added) … and so on :slight_smile:

Next time you update the system (today tuesday should be released a new OTA), install it. It will clean your modifications, so after that, you can sideload my ZIP safely, preserving your microG apps data. Next week and further you should only install the OTA normally, :+1:.

Also, don’t forget to Tingle-patch each LOS update (the patch cannot be made survival, unfortunately).

Tried to update from 17.10.2. Installed lineage-14.1-20171031-nightly-FP2-signed.zip without any Problems using twrp-3.1.1-2-FP2.
Installed open_gapps-arm-7.1-stock-20171101 before rebooting the system.
At the first start everything worked well, but after a short time I had problems with my SIM-Cards (I have two). I think, the issue started after I changed SIM 1 from LTE to 2G as preferred mode and SIM 2 to 4G.
After a reboot, I failed to enter the SIM, where I got an error message (error when entering the SIM card), but without the SIM card was locked after three attempts.
So I went back to 17.10.2. :sob:Thank’s to TWRP.

1 Like

3 posts were split to a new topic: Problem with Garmin gadgets / app