Official LineageOS is here!

I’m glad you’re asking this… I haven’t got a clue about any of this, it’s all new to me. I’m just glad there are people like @jnsp and @chrmhoffmann around :wink:

Thanks for all the work you’re all doing!!

1 Like

Does anybody else have the problem, that when the phone is off and charging, it won’t boot? I have to unplug it, boot it and then replug it.


Yes, I do have the problem too…

My Problem was not any more getting Access to the system at all. I failed the moment I tried to enter the PIN for the SIM. I did not have access to the settings anymore.

Try new lineage from today.


Yes, the baseband blob hasn’t changed.

1 Like

To apply this week update we need to update modem file right? in that case I just queue it in the TWRP install? First the LOS upload followed by the modem?


The is completely independent from the operating system.

It is not required to flash the file, it is only recommended in order to get the latest security fixes for the proprietary qcom modem firmware (that is stored on a seperate partition).

It does not matter in which order you flash LOS and the ;).


Just remove your back camera, boot, encrypt, plug the cam back in. It worked for me.


Hi Chris, I just also experienced that the mobile data no longer connected. So I managed to install ADB and capture logcat and dmesg. Where should I supply these files to (I am running the latest nightly)?
Thanks, Christian

Just go to and navigate to the lineageos project. There you’ll find the issue re losing mobile date

1 Like

Thanks, I added my logs to

I just upgraded from the old OTA and everything went fine.
It’s even better, as I noticed that the call volume issue (LineageOS 14.1 with OTA updates for FP2) seems to be fixed in the official builds. I am not sure whether a reflash of the old OTA would have fixed it anyway.

Just one question: How do I change the name of the device?
Jottacloud now has my phone identified as FP2 and my girlfriends’ phone as FP2(1) and I cannot change this manually in the application/website… So I am wondering how to change the name of the device to make these names somewhat more clear.
I saw an option in the developer options, but that doesn’t seem to be the correct one.

I justed checked, a bug was already opened for this issue.

1 Like

Looking forward seeing that in LOS (maybe version 15.x?)

1 Like

I am not registered at the “Lineage OS on Fairphone 2 bug tracker”, so I am posting this information here. Maybe it is related:

1 Like

2 Questions about configuration of SIM-Cards (Network type):
I installed 20171107-nightly and it’s working (random reboots with Google Maps which I already had with several versions of FPOS).
What I don’t understand, is: in the Menu of the SIMs I can configure two SIMs to use 4g as Network type, which I learned shouldn’t be able because of hardware limitation (only one 4g-Modem).
I wanted to use my first SIM for telephone (2G) and the SIM 2 for Internet (4g), but I’m not shure it is working well.
Can I configure both SIMs to LTE (4G)?
Does it matter which SIM I use for which network type?

Update installed via TWRP 3.1.1-2

The following things work for me so far:

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network
  • location
  • compass
  • screenshot
  • main camera (new module)
  • selfie camera (new module)
  • USB connection to PC / MTP
  • alarm (incl. swiping it off)
  • MyPhoneExplorer
  • root

… and Netflix 5.


Strangely there’s 2 14.1 Nov 14 versions for me. I went with the top one (latest I suppose) cause I guess its a minor bugfix.

Do you have to reinstall open gapps every time you upgrade LOS btw?

1 Like

Two things I noticed since upgrading to official (7 and now 14 november (top one) version. Baseband is 4437.1):

  1. Main camera (new module) is not recognised. I can’t switch from selfie to main camera and even the torch does not work.
  2. Mobile data sometimes is not available, even though the status icons mention they should work fine. Airplane mode and back fixes this. It’s very similar to a bug that was in one of the earlier OTA versions.
    [edit: Same issue is when using wifi. After 10 minutes, all internet connection is lost and not regained until airplane mode is used]

Anyone else experience these?