Official LineageOS 20 FP4

I can’t tell how smooth the upgrade work, as I haven’t done one on FP4. For other phones this work without losing data as long as you follow every part of the upgrade wiki for the depending phone.

It’s hard to compare OpenGapps with MindTheGapps as there is only one whole package against up to 12 without sharing exactly the same apps in any of them. Best comparision would be against a OpenGapps nano package with some extra apps, but not quite as “large” as the micro package. As I used both of the packages a long time, I would currently prefer MindTheGapps for newer phones.

A factory reset wasn’t needed at all when I switched OpenGapps to MindTheGApps on an older phone while upgrading LOS 18 to 19. All apps worked as expected after the upgrade, maybe you have to redo your app settings for some apps and wait until the apps have updated themself to their current version.


It’s great that LOS is now official for FP4! :tada:

Security Updates Fairphone 4:

The CalyxOS releases for it only contain the latest fixes to the open source components, such as the OS code and the Linux kernel. Proprietary components such as the bootloader, modem firmware, and other firmware get updates as soon as the stock OS update is available.

@mikeNG How is it with LOS for the FP4? How often are there updates for OS code and the Linux kernel? Monthly, every 2 months, …?

Looking at the change log for the next build and the Jan security update is ready to be deployed. I would say the security updates will be quicker but for updates to the phone’s hardware we will have to rely on FP.

1 Like

Hi all,

I have installed the new update of the official LineageOS through the OTA from the update menu on the smartphone.

The update was done successfully, but it take a very long time.

The first step to download the update and second step to install was done quickly, but the 3rd step to finalize the installation package take more than 3 hours.

Is it really normal that it take so long?

Thanks in advance

had the same thing, took forever to update,never seen it before, but my old phone would always boot into twrp to update, and this one is staying in the os. i was able to keep magisk going so thats a plus :slight_smile:

I upgraded to the official release at the weekend. First tried to replace the keys as stated in the wiki. But my packages,xml didn’t contain any keys, so the script did nothing. Then I just dirty flashed the official build over mine. That worked fine. No issues so far.
TLDR; Just flashing the official build should work.


It is indeed as simple as that, just tried it, everything went perfectly well.

On another topic, I’ve been rocking LOS with manual update for so long that I don’t remember how OTA updates handle root and GApps…
=> Do I need to restore image through magisk → proceed to OTA → install magisk in second slot through magisk ?
=> Are gogle apps wiped when proceeding to OTA updates ?

1 Like

Some questions regarding LineageOS 20 on the FP4:

  1. Can I use ext4 as Filesystem on the external SD?
  2. Does Android Auto work via USB?
  3. Does Volte and Vowifi work?
  4. How is your experience with the camera? LOS camera and GCam?
  5. What is the selinux status?
  6. Does it pass safety net checks?

Thanks a lot in advance

Has anyone successfully locked the bootloader after installing LineageOS?

Following happens on my phone:

  1. fastboot flashing lock_critical → works and boots fine
  2. reboot into bootloader
  3. fastboot flashing lock → always boots into bootloader.
  4. Boots fine when fastboot flashing unlock

As far as I read, LineageOS 20 still does not support relocking, correct?

I played around with this for a couple hours yesterday, but didn’t get it to work. I’ll keep trying though.


It passes on my side yes, I did a LOT of stuff to get GPay/Wallet working so I don’t quite remember everything but here’s a peak of what I have as we speak (keep in mind that this is an exhaustive list of what I have installed on my device, some might not be relevant):

Magisk modules:

=> MagiskHide Props Config
=> Systemless Hosts
=> Universal SafetyNet Fix v2.3.1
=> GPay SQLite Fix (this one is only mandatory for GPay, will not do anything for safetynet check)


This one is kinda important as you won’t ever pass safetynet on LOS with default FP4 device fingerprint, I don’t get why this is not necessary with stock rom, but the fact is I know for sure this step is mandatory.

=> Changed my device signature to trusted device, chose: Fairphone 3/3 plus

Magisk settings:

=> Zygisk enabled
=> Force exclusion list
=> Excluded:
- Play Store
- Wallet
- Google Service Framework

You have to clear the cache of said applications before adding them to exclusion list, then reboot.
I think I remember setting my device in airplane mode before clearing cache of those app and disabling it after reboot. This might be necessary.

That’s about all I can think of. But it does pass.

You are a brave lad ! You might not be aware but there’s heavy history of fairphone users who bricked their device to the point where RMA is the only way to get back working, by relocking the bootloader. Including with stock OS.


I’m only trying to do this to get my banking app working. However, since I can still use my bank account via their PC app (for which I obviously need a VM, because of course there is no Linux version), so I’m not in a hurry to fix it. I wrote my bank an email asking about if the problem lies with SafetyNet in the first place, since I could save a lot of time if it wouldn’t work either way anyway.


To make matters worse I did it on my main phone.
But I wanted to test out the backup system anyway. My workflow worked pretty well and I am almost back to before.

Relocking the bootloader would be such a great thing in order to have an ‘as close to Stock experience’ as possible.

But since it removes all data everytime I wont tinker around any more than up to this point right now.
Does anyone have any idea what it takes to get this working? I do not have a test device but would like to understand if there is any way for me to help out to get this working.

1 Like

my safety net works, like above
MagiskHide Props Config set to FP3
props - 1 - f - 5 -2 - y - y to reboot
Universal SafetyNet Fix
and shamiko blacklist blocking all off Play Store, Wallet and Google Service Framework.
if you have a banking app that is tripping the safety net, put that in block list as well. my banking apps always work so dont have that issue.


Regarding banking apps, maybe try out ih8sn? You will need a ih8sn.conf file, I wrote a shell script to create that and asked in the moto g7+ forum to generate the output on stock android for me:

Here are the values my wifes fp4 gives with stock android

bernd@e7270 fp4>./ 
BUILD_DESCRIPTION=FP4eea-user 11 RKQ1.210503.001 FP4I release-keys

My moto g7+ on LineageOS20 has all fields filled in - I have no idea if the empty fields are import - ih8sn is not well documented. And to get ih8sn working one seems to need the value from stock android - I don’t have that for my g7+ yet, so I can’t comment if it works (with French BNP).

1 Like

thanx for that, i was looking into ih8sn but i had already flashed and setup my phone. so didnt want to go back to stock just to get that build fingerprint.

looking in the hidemyprops module it actualy shows origional fingerprint Fairphone/FP4eea/FP4:11/RKQ1.210503.001/FP4I:user/release-keys so i doubt that ih8sn will work

I just did the switch from the unofficial LOS 19 build to the official LOS 20 build with Mindthegapps 13.
Worked like a charm :smiley:

Thanks again for all the support here!

Regarding the banking app topic:
Not sure if that helps somehow, but my banking app from DKB works fine so far.


not all apps use safety net, my swedish stuff works without issue, but google pay won’t (does now with magisk)