Official LineageOS 18.1 for Fairphone 3/Fairphone 3+

I also have a re-locked bootloader. That might be the reason why the 2nd May build ist not working?! I hope devs will fix this in future releases - fingers crossed.


@Cudo I can confirm that I’m running the built from 05/02/22. My bootloader is unkocked.


@TeamB58, after a power off from the running old build > fastboot --set-active=[other slot] > FP logo > vibration > FP logo and bootup in the old build, /sys/fs/pstore was empty. Could this mean that the new kernel doesn’t even boot up because the bootloader already rejects it on my locked device for some reason?

1 Like

Thanks for this additional information. I was confident that kernel was in good shape. Looks like it is not. I’ll start investigating this.

Apologies for this mess.

If it’s affecting more users then shall I get the build removed from server?


I have no clue how many users re-locked their bootloaders, which may/appear to be the affected ones. Anyway, they don’t really suffer from a broken functionality in their daily usage as “only” the installation won’t succeed. But the unlocked users benefit from the update as their camera now works. As long as several installation attempts of the users with locked devices won’t break anything or force a wipe, I’d say the current update more helps than harms. But certainly the decision is up to @dk1978 and you!


Worked well for me (unlocked bootloader), and it solved my call volume issue : Call volume too loud, call volume slider does not have any effect
Thanks a lot !

I really suffer from broken functionality in my daily usage because of the bugs in my current version (e. g. broken camera functionality). The update should work for users with locked and unlocked bootloader.

@aes0p, I fully agree and I trust @TeamB58 will make it work also for us with the locked devices soon. As far as I understood, he was just wondering whether to withdraw the 20220502 update or not …

1 Like

OK… So the issue is only with locked bootloader is it? Can you confirm?

I could get the logs and I see some issues with device-mapper which I am currently investigating.

Sorry again for this issue as I did not face this. Hence I could not test.


My bootloader is locked and the update failed.

My bootloader is locked and update failed.

Same here: locked bootloader and back on previous build.

We trust you all the same :grinning: don’t worry

Good news!!
I’ve identified the root cause and fixed it. Confirming it now with a clean build.

Special thanks to @z3ntu for his continuous support.


I have 2 usefull features that don’t work on my FP3 :

  • USB tethering (but wifi tethering works)
  • USB file transfer (but PTP - picture transfer works)
    Is it supposed to work, or is it known bugs ?


I can confirm that both these features are working.

  • USB tethering was successful and I even browsed some pages online.
  • USB file transfer works(Drop down status bar and click USB options. Choose File transfer). I am able to browse the internal storage in Windows explorer.



Great news! Thank you for your effort. I’m looking forward installing the next build.

Just successfully installed the May 9 build on my re-locked FP3, thanks again to all!

I also just installed it on my locked phone and had to move the folders for osmand and Podcast addict and redownload the data, but camera and so on work fine again. Thank you for your work.

Thank you @TeamB58 to make it work - the new build successfully installs on my locked phone.

I’m just a bit concerned about privacy, security and battery consumption as many new proprietary APKs/services are now included with the step to the new blobs e.g. from Qualcomm. Are they really vital to run LineageOS? Please drop as many of them as you can!

Hi All,
I am glad that the new update is working fine.

Regarding the inclusion of new QC proprietary components, the message from LineageOS seniors states that until and unless there is a strong reason(critical crash, incompatibility) none of the proprietary components can be dropped from the build.

In fact, for Android 12 I have this commit for which I had to give a justification.

Thanks for understanding.

1 Like