Official LineageOS 18.1 for Fairphone 3/Fairphone 3+

I agree. I never use auto-brightness, so the high low-level really bugs me. I think a high low-level brightness used to be a problem that was fixed in 17.1, but that may also have been my old phone and I’m mistaking something. Anyway, the last bit of the slider really doesn’t change anything and it’s way too bright for me in very dark surroundings.

1 Like

See also my prior post about this.

People have also complained on Reddit and even filed a bug report. I knew people were not going to be that happy and I will try to see if it is somehow possible to decouple manual and automatic brightness treatment. In other words, if manual brightness is used, then allow the old minimum value of 1 - but for automatic brightness restrict Google’s weird algorithm to not push display brightness below 10.

If that fails I suppose we can put it up to vote whether we just revert the last change.


Today’s update somehow killed my sd card. Now I have to format it in order for my FP to recognise it again. I’m not too happy about that. Is there a way to revert back to the LOS version I had before? I thought I might just give it a try by switching the active slot using fastboot. But since my bootloader is locked, this would erase all data. Am I right?

Have you verified with another device, e.g. a notebook if you can access the data stored on your SD card?

My laptop can access data without any problem. Meanwhile I somehow managed to get my FP recognise it again. But don’t ask me how…

I described the way here, if you want to try.

1 Like

Thanks! I tried it despite my sd card working again. It gave me a mini heart attack though because the other slot’s version seems to have been corrupted in the update process. After unsuccessful restart I landed in recovery stating that somethings wrong.

Fortunately I got my FP working again by switiching back to the slot with the current version. :no_mouth:

1 Like

Thanks for trying, at least we now know it can be done with a locked bootloader.

I did this myself a few times in my early Fairphone 3 days without a problem, and since supposedly the bootloader should do this automatically when it detects a few consecutive failed boot attempts e.g. after an update, I think this should work.
Since I saw an unsuccessful try from an /e/ user, too … do Custom ROM updates break this safety net? Not good.


Any solution for us with unrooted phones to set zram?

1 Like

The only way I can think of is to unlock the bootloader and edit some files on the root-partition by using twrp and/or adb. But I don’t know if that would cause SafetyNet to not pass or if it affects the ability to lock the bootloader again. :man_shrugging: I don’t have much experience with unrooted phones and locked bootloaders.

This happens a lot with consumer grade SD cards. Expect your SD card to get broken forever any time now, and take appropriate countermeasures.

Thanks for your reply! I bought my 400GB SanDisk Extreme earlier this year, so I hope the case you described does not hit me. Before that I have been using a 64GB SanDisk in several phones for ages…

Seems shaky. Any chance of zram getting enabled in the default LOS distribution?

I have come to the point where performance is unbearable. This morning I tried to take a photo. Phone hung for 2 minutes on NGCam. Then I got a popup saying that user interface had hung. I tried to reboot, but phone just went black.

Now when rebooted, phone is as snappy as ever, but it gets worse with time until everything breaks down like above. I don’t know if there’s a memory leak or whatever, but I have to do something drastic. Like installing stock ROM or something.

Ran into an app (Hyundai Bluelink Europe) that would not run on our beloved LOS 18.1. The app exits saying ‘… the device is rooted’.

Technically, my FP3 is not rooted AFAIK - it runs with a re-locked bootloader. I disabled Developer Options to no avail. I have read about Magisk but for the moment I would rather not install it (seems a bit beyond me).

I would appreciate some suggestions!

Tomorrow’s update will revert the minimum brightness fix - users will be able to adjust it manually back to 1 again. I have also adjusted the configuration curve that defines how bright the display should be set in response to the data from the ambient brightness sensor. By default it will keep the display brightness at a higher level in low light conditions.

So all in all, I hope we have reached a workable compromise. If you don’t like what the automatic brightness is doing, just use manual brightness. Also remember that it is possible to train the automatic brightness by adjusting the slider position manually. Please report your experience with the new setting.


I can’t install that app via Aurora Store apparently, but if you feel like it, then send me a link to the apk somewhere and I will look into this.


I would appreciate that a lot!

The app is

Download link:

Managed to install Bluelink - saw this in the log:

10-26 19:54:48.803  5434  5434 V RootBeer: b: b() [152] - ro.debuggable = [1] detected!
10-26 19:54:48.819  5434  5533 V RootBeer: b: b() [152] - ro.debuggable = [1] detected!
10-26 19:54:48.899  5434  5434 V RootBeer: b: b() [152] - ro.debuggable = [1] detected!
10-26 19:54:48.899  5434  5533 V RootBeer: b: b() [152] - ro.debuggable = [1] detected!

There are several well-known ways to defeat RootBeer, including Magisk, or even funny scripts, but you are probably stuck since you have a locked bootloader. I am not sure you would get much further anyway, since the app also complains about this:
10-26 19:54:50.289 5543 5579 W GooglePlayServicesUtil: requires the Google Play Store, but it is missing.

Others here may have more ideas.


Thanks for your efforts!

I was wondering whether (maybe) using Release Keys at build time (instead of the current Debugging Keys) would improve the situation?

I do have the Google Play Store installed (please don’t hate me for that, I really tried to do without on /e/ :grinning:)