Official LineageOS 18.1 for Fairphone 3/Fairphone 3+

To be honest, I’m not surprised to experience some funky issues when going “my” upgrade path. This morning I flashed LOS4microG to the other slot and booted it and now I have my camera back and both apps are working fine.

Do you have any modules active? I think they have to be disabled/removed and reinstalled on LOS18.1
I had the same when i went to LOS18.1 alpha

My Camera App “Kamera” disappeard after installing “lineage-18.1-20210811-microG-FP3.zip”. :roll_eyes:
And I can’t get any access to my camera with no app.

For me installing Lineage did not work on a Fairphone 3+ with the standard instructions. I’m quite curious what I did wrong, in case anyone can tell in retrospect. It worked in the end but only by coincidence.

I wanted to try microG instead of the (ahem) “open” gapps, and µG recommends using their slightly modified LOS 18.1 rom. The installation instructions are to just follow the official instructions, which I tried.

Versions of adb and fastboot are 1.0.39 and 1:8.1.0+r23-5 (from Debian Buster repositories, upgrading to the recently released Bullseye is next on my todo list).

  1. Unlock the bootloader, temporarily boot into TWRP and make a backup of every partition, adb pull the backup for safekeeping, and adb push the relevant files to flash.

  2. Boot the LOS recovery with fastboot boot lineage-18.1-20210811-microG-FP3-recovery.img → which just booted back into the main OS? I think I also tried the official recovery (non-µG). Okay weird, guess I’ll use trusty old TWRP instead.

  3. fastboot boot twrp-3.5.2_9-0-FP3.img → Now I’m not sure what instructions to follow, because the official LOS instructions assume I can press the ‘factory reset’ button in the LOS recovery; not sure how to replicate that with TWRP. Lucky for me, the instructions at µG tell me what to wipe specifically for a nice and clean install:

    Clean install (wipe data and installed apps)

    If you don’t care about losing your current data just reboot into recovery, wipe System, Data, Cache and Dalvik and, without rebooting, install LineageOS for microG.

  4. In TWRP: wipe → advanced wipe → check System, Data (without internal user storage), and iirc there was also one with Dalvik in the name.

  5. In TWRP: install → select rom from user storage, lineage-18.1-20210811-microG-FP3.zip

  6. The LOS instructions said it should fail at 47%, that means success. Well, it just ran through for me, no percentages just ‘step 1’ and after a while ‘step 2’, then done and a prompt to reboot.

  7. I installed magisk (Magisk-v23.0.zip) via the same method (TWRP, select from internal storage) because it said to do this before first boot. Iirc the log looked ok, then I rebooted and…

  8. Boot loop.

As far as I’ve been able to find, this should just have worked. Any idea what’s wrong at this point?

After a few failed boots it launch the stock recovery (with hindsight, it was a good decision not to flash TWRP permanently but just leave default what can be left default). This offered a few options, such as reboot to bootloader (so I can fastboot twrp again) or factory reset.

I tried a few other things:

  • flash the official LOS instead of LOS+µG,
  • full wipe data (with internal storage, also because the internal storage was now encrypted with keys it apparently didn’t know anymore),
  • install stuff to different slots (this felt very finicky in TWRP),
  • don’t install magisk,

… eventually I gave up. Never mind then, let’s hit the factory reset for a usable, known good state and rethink my life decisions.

But here’s the kicker. I hit factory reset in the stock recovery to get the stock OS back (silly, in hindsight). It seemed to just wipe /data, and upon next boot I saw… LineageOS! What the heck, why’d it work now all of a sudden :’)

Any idea why that solved it? Or what I did wrong in the first place?

For what it’s worth, I don’t have the camera issue _Julian reported just above and adaptive brightness also works for me (first thing I turned off, I was looking forward to that being broken in standard LOS :sweat_smile:)

Interesting. So I am not alone.
I decided to flash LOS4microG also to the other slot and booted from there, and now stock Kamera is back and OpenCamera works, too.

Hey, I have some issues:

  1. Like in previous Android-versions, the phone is pretty choppy, the Game Stack for example is absolutely unplayable. Switching to performance-mode in the “battery and performance”-settings makes it silk-smooth. And there is the second issue…

  2. After rebooting, the setting slider remains at the previously set position (as it should) but in the backend, the performance-setting is set back to balanced.

  3. An issue I also encountered in previous Android-versions, whenever the ambient light sensor reports 0, it drops the display-brightness down to 0 (rather than staying in the configured range). So as soon as the sensor reports 1 or more it jumps back to the configured range. In the GIF you can see the behavior in action. If the light sensor reports 0 it should go down to roughly 50% display-brightness (after a short delay) but instead it jumps all the way down to 0. As disgusted here, it seems like only systems without gapps are affected by this bug.
    recording_20210317_113937

Thanks for the great work guys, let me know if you need more information on these issues.

The auto brightness issue is the only visible and active bug/issue. We do not have a clear pointer as to what is causing this issue but will continue to investigate more on this.

Thanks for all of your support.

TeamB58.

1 Like

I just did some extensive testing. After a restart, whenever the light-sensor reports 0, brightness goes down to 0 (nothing new). However if I move the brightness slider once in any way, the behavior changes. Now if the sensor reports 0, the brightness simply gets stuck, doesn’t matter where it’s at. If the sensor reports ANY other value (1 or more), everything works just fine. So something in the system just can’t handle values of 0 somehow.

@TeamB58 can you point me to the source-code for the adaptive-brightness-routine? I am coding-scrub but I am also very very curious.

I have no idea how to work with “slots”, but my LED backlight stopped working as well. Maybe there is a connection to the camera issue.

@TeamB58
Does this mean the camera issue is solved with the next update?

I guess I have missed it.

what is the camera issue you’re talking about?

First, many thanks to the dedicated persons who allow for our beloved smartphone to enjoy recent OSes.

I’ve been monitoring this thread with lots of attention and feel I’m not ready to take the plunge yet. It’s my everyday work and personal phone, and I need everything to work smoothly, as it does presently, with LOS 17.1.

I’m not familiar with this A and B slots thing. Is is something that would allow me to attempt to install 18.1 while still being able to easily return to 17.1 if something goes wrong, without losing any data?

But most of all, I’d like some real-life feedback: on a Fairphone 3, what are the concrete benefits of switching from LOS 17.1 to 18.1, knowing that I use very few, bar no, LOS core app?

if you can run a docker image, Analyze power use with Battery Historian  |  Android Developers is the most detailed off-device app. On-device there is BetterBatteryStats from F-Droid, GSam Battery Monitor and AccuBattery from the Play store.

1 Like

Sorry, maybe it is a stupid question, but: where do I get the boot.img from? I downloaded the lineage[xxx].zip, but where is the boot.img?

@juri.gagarin.ii
After unzipping you will see a file named payload.bin. This file contains the boot image. You’ll need a payload extractor/dumper to dump its content.
See this for additional information: Extracting proprietary blobs from LineageOS zip files | LineageOS Wiki

2 Likes

Hello, since the LOS 17.1 thread is closed, I’ll post here: when abroad I do not have mobile internet while roaming.

I have had this issue with two carriers: Italian CoopVoce (this issue has already been highlighted on the LOS community), and also Spanish Llamaya.

While in Spain I could only get data from Llamaya (and not CoopVoce), when in a third country I could not use either data.

Hello. I’m very happy with LOS 18.1 :slight_smile:. Thanks again to the developers and testers!

Only thing I’m missing is the split screen feature (that I used to be able to access by holding down the ‘recent apps’ button). From what I see it should still work on Android 11. Do I need to enable it somewhere? I have had a look through the regular and developer settings, but can’t see anything obvious.

You can map this function to a button in: Settings > System > Buttons

1 Like

maybe slightly off-topic but I’m having issues installing magisk after upgrading to 18.1, I’ve extracted the boot.img from the 20210811-microG payload and then patched it using the magisk app, but I’m unable to fastboot flash the patched file, I get:

> fastboot flash boot magisk_patched-23000_aZEYN.img
fastboot: error: boot partition is smaller than boot image

any ideas why? seems to have worked for other people in this thread!

I am not sure but maybe adding the slot you wanna flash might work, like this:
fastboot flash boot_a magisk_patched-23000_aZEYN.img
fastboot flash boot_b magisk_patched-23000_aZEYN.img

2 Likes