Official LineageOS 17.1 for Fairphone 3/Fairphone 3+

Reading this communication since January 2021 i didn’t find an answer to following question:

I use fp3+ with ROOTED los17.1. Is it possible to LOCK (fastboot oem lock) the device
WITHOUT running into curruption/brick issues?

I learned, locking would be only successfull for NON-ROOTED devices.

Is that right?

Or did anybody find a solution, how to lock rooted devices?
I’d be already glad getting rid of the warning “device not locked”, that comes within every restart of device.

Thanks very much!

Are you sure this is wise? I don’t know exactly how you rooted LineageOS, did you use something like Magisk? Whatever you did, it might not survive an OTA update from the official LineageOS - and then you would have to unlock the bootloader again to re-apply system or boot partition patches, thus losing data on the device. See this page for some possible issues with the Magisk OTA dance.

Yep, this would result in a not-booting OS. That’s not possible. You can only lock your bootloader if you have a non-rooted FP3+.

I’ve rooted my FP3. I can update LOS4microG regular but I have to reflash Magisk before I restart the device. There’s an install option exactly for this case within the Magisk-App. It’s called "Install to Inactive Slot (After OTA) " Otherwise I have to reflash Magisk manually…

1 Like

Thanks a lot for your opinion!

I used magisk.

(By the way: I’m using rooted LOSmicroG to be able, using AFWALL-Firewall (doesn’t run without root) and lookout.)

Thanks a lot for quick answer!

Does anybody know a way, how to get rid of the “device not locked”-warning, which comes within every restart of device (that uses a different OS)?

By the way the audio is also different and that on the main board and not updatable from the FP3 to FP3+

Did you receive any update for LOS4microG after April 14th? This is the last one I got. It is not exactly monthly…

no, that’s the latest build available:
LOS4microG builds are created very irregularly…

I am thinking that it would have been better to use the official version without microG and use nanodroid patcher. Unfortunately I went with the microG-version…
Or to use self-built LOS, in that is beyond my capabilities.
@dk1978 would it be possible to switch from the microG-version to the one without microG without loss of data?

I don’t know. Can try to test that based on this image in the following days. Do you happen to know when you migrated from stock Fairphone OS to micro-g-patched LOS? This would tell us what revision of the keymaster partition you are using.
As was mentioned in the posts above, the micro-g build does not include these partitions in their updates, so you would still be using those coming from stock Fairphone OS.

I was hoping to get rid of it by locking my bootloader (I’m running LOS non-rooted), but then you’ll just get another message (with the same 10-second delay) warning about running a non-standard OS.

Google’s Android specification requires these messages to be shown on all Android phones. I’m pretty sure the message changed (slightly) after I upgraded my Fairphone firmware from Android 9 to 10 a while ago, so it must be possible (in theory) to suppress it by flashing a custom bootloader or something.

However, that sounded way too scary to me, and while the 10-second delay is annoying when tinkering with custom ROMs etc., I barely notice it in my daily use. (Plus, isn’t it a badge of honor? :wink: )


Thanks a lot for your opinion! I hoped, to find out something like a “bit somewhere” that could be changed quickly. But it doesn’t seem so.

Thus: Please forget it; was more “luxury question”. Normally i do not restart my phone and therefore don’t see that bl… warning. :wink:

Thank you very much!
To be honest, I can’t really recall my steps. I think that my way was the following, but maybe I am mistaken:

  • I received my FP3 and it was loaded with A9.
  • I took part in the beta testing of /e/ as soon as it became available and used it some time
  • as soon as LOS4microG became available I switched to LOS

The thing is, I can’t remeber whether I flashed stock ROM between /e/ and LOS. I have Fairphone_FP3_FP3_9_8901.2.A.0111.20200131_01311418_user_release-keys laying around in my download-folder, which makes me think that maybe I reflashed stock before switching to LOS, but I am not sure. And if I reflashed stock maybe I updated to the latest available version at that point.

Does anybody know why there isnt a new microG update for LOS17.1 or has anyone additional knowledge why the latest update within the system update (still) keeps showing the latest update, ready to install, even if youve installed it before?

The team behind Lineage for MicroG is very unreliable… thats why many people including me are building the ROM themself.
The installed version showing as an update is a bug in the OTA Server that was fixed some time ago, but the Lineage for MicroG people seem to not update their server.

Hm, alright. Cheers. That would be a first for me, havnt worked with docker before either. Its a shame, but I might have to look for an alternative.

So is there a guide on how to build LOS with microG for yourself? Do I need special files like modem files and where can I get them?

Furthermore: I only own a quite old Laptop and I am afraid that building might take even longer than waiting for an updated build of LOS4microG…

You can follow these instructions: GitHub - lineageos4microg/docker-lineage-cicd: Docker microservice for LineageOS Continuous Integration and Continous Deployment
For me the build itself takes about 2 to 3 hours (Desktop PC with a Ryzen 5 3600), without the time needed for syncing the repo taken into account. The first build will take quite some more time, because of the initial repo sync. Also it is worth mentioning that you will need a lot of disk space. IIrc about 150 to 200 GB.

Thanks! I guess the disk space would be the biggest issue then, having only 190 GB free on the internal SSD. The external disk is an HD connected via USB 2 which is not exactly the fastest combination…
And if I understand it correctly, the build process will pull the updated proprietary files such that I am up to date and maybe won’t suffer from so many spontaneous shutdowns during phone calls?

FYI: Today I switched from LOS4microG to official LOS. First I did a backup with TWRP. The switch worked flawlessly.
Then I flashed Magisk to regain root access again.
Then, I installed the Magisk Module MinMicroG (the NoGoolag version)
So far, everything seems to work flawlessly.