Official LineageOS 17.1 for Fairphone 3/Fairphone 3+

This seems to be a bug in Android: Major flaw in the Do Not Disturb feature - Pixel Phone Community

If I understood the response in that article it might be an option to disable the “repeat caller” option of DND.

1 Like

Can anyone explain to me how exactly the following gerrit page can be interpreted?

https://review.lineageos.org/q/topic:"FP3-eleven-bringup"+(status:open%20OR%20status:merged)

If I get it right, those are commits that enable LOS 18 Builds for the FP3. Right now they do not belong to any branch and in the review system they do not have a status or an asignee.

I am just interested in how the process works, where those commits come from and want to know if I understand things right :slight_smile:

Yes, those are the 18.1 commits. They are meant to be merged/rebased onto the 18.1 branch device branch which is currently a few commits behind 17.1 since I am still fixing things for the current 17.1 release. The status is open - and I am the reviewer and have control over if and when they are merged.

3 Likes

Updated to lineage-17.1-20210405-nightly, no problems so far.

I checked the changelog and nothing seem to stand out, if I’m correct.

After the last 2 OTA updates I’ve encountered certificate issues and I’m not certain what might be causing the problem or how to diagnose it. My browser (Lightning) warns me of untrusted certificates and the DBNavigator (german train services) refuses to process a booking with an error message that “… no valid certificate was found on the device to establish a secure connection…”. I have absolutely no experience with debugging android, but I saw some CA- and KeyChainService-related errors using logcat that might be related to this?

...
8297   │ 04-08 14:51:35.670 18652 18720 I cr_X509Util: Failed to validate the certificate chain, error: java.security.cert.CertPathValidatorException: Trust anchor for certification path not found.
8298   │ 04-08 14:51:35.674 18652 18722 E chromium: [ERROR:ssl_client_socket_impl.cc(924)] handshake failed; returned -1, SSL error code 1, net_error -202
8299   │ 04-08 14:51:36.611  7318  7318 V b       : is Ticking: 76552 millis remaining.
8300   │ 04-08 14:51:36.612  7318  7318 V j       : updateNotificationProgress
8301   │ 04-08 14:51:36.612  7318  7318 V j       : createNotification
8302   │ 04-08 14:51:36.698  2303  2865 D QCNEJ/WlanStaInfoRelay: Received action: android.net.wifi.RSSI_CHANGED
8303   │ 04-08 14:51:37.613  7318  7318 V b       : is Ticking: 75550 millis remaining.
8304   │ 04-08 14:51:37.614  7318  7318 V j       : updateNotificationProgress
8305   │ 04-08 14:51:37.614  7318  7318 V j       : createNotification
...
8677   │ 04-08 14:52:00.658  1205  3122 W ActivityManager: Unable to start service Intent { act=android.security.IKeyChainService cmp=com.android.keychain/.KeyChainService } U=10: not found
8678   │ 04-08 14:52:00.660  1984 18445 I SecurityController: failed to get CA certs
8679   │ 04-08 14:52:00.660  1984 18445 I SecurityController: java.lang.AssertionError: could not bind to KeyChainService
8680   │ 04-08 14:52:00.660  1984 18445 I SecurityController:    at android.security.KeyChain.bindAsUser(KeyChain.java:814)

I’m not really sure what I should look for to get to the root of this. Any help or tips would be appreciated! I’m using the most recent LOS17.1 +micro-g + Magisk + EdXposed for FakeGApps. I guess any of these might be the problem.

Since I got my Fairphone 2 weeks ago I struggle with very poor video during videocalls on WhatsApp and Signal. This was one of the reasons I switched to LineageOS but also on this ROM the problems are there.
On Whatsapp the receiver and myself see a very poor image, the skin quality is very bad and the image is pixelated.

On Signal the picture is even worse for the receiver. The pixels seem to swirl around on clothing. Also very pixelated picture. The weird thing is that I see myself clearly without distortion during the video call.

On Google Duo there are no problems however. Picture quality is clear for me and the receiver.

I am on Lineage-17.1-20210405-nightly.
Apps versions are:
Signal 5.5.5
Whatsapp 2.21.6.17
Google Duo 131.0.363693714.DR121_RC01

I tested on WiFi and Mobile data, there are no differences in quality. Speedtest results are:
4G 67,9 Mbps down and 21,2 Mbps up with a ping of 22ms.
Wifi 187 MBps down and 132 Mbps up with 9 ms ping.

Are there other people with the same issues?

Presumably you mean my Fairphone 3 two weeks ago

I had no such problem with FOS. If you had the issue with the default OS it would have been prudent to contact support with your concerns especially in the first 14 days as you could have asked for a refund or a replacement.

You problem sounds a bit off as there are quite a few complaints about audio volume but not video.

1 Like

Not that I know of at least. Is the quality of normal video captures using a camera app ok? That would probably rule out a simple hardware issue with the cameras themselves. Did you have a look at adb logcat output, or maybe adb shell top to examine the system load with and without a video call?

About the video and selfie camera quality: I come from a Samsung A50 and there is a clear difference in quality, the Samsung makes better selfies and videos. I’m not sure if what I’m seeing is normal, so here a selfie and a video of my dog :slight_smile:

Picture of my Kooikerdog

video

(I made these with the selfie camera on the latest stock rom)

The video calls are very poor in quality compare to the picture and video.

I didn’t knew these commands. However I saw a noticable delay in the videocalls, now you mentioned it. I will have a look at your suggestions when I can do that. (have to flash the rom again.

Thanks!

Hi all,
I am using LineageOs MicroG, the latest available version.
When I use the Signal app, I am not able to share my position. It opens up the menu and the location, but it never sends the position.
Do you have similar issues?

Thanks!

Hi @in-go,
are notifications waking up the display again using the current LOSmicrog version or is it still broken?

Hello,

back in december I installed @dk1978 's alpha image of LOS17.1 on my daughter’s brand new FP3+, and it has worked flawlessly until now.
Question 1: Now I’d like to switch to the official LOS17.1 image. Do I just flash it over the alpha like I did for the alpha at the time ? Will I need to reset the phone ?

Question2: I didn’t bother with relocking the bootloader at the time since it was only for testing… but the little devil took it and used it like the present that it was :slight_smile: So now, if I relock the bootloader, will I loose the data ?

Thanks,

Rémi

Hi @knefl,
I updated to the latest version (20210414) yesterday and notifications still don’t show up.

Thanks for your feedback, @in-go !

I suspect that it is not a problem of LineageOS though, but possibly a problem of FP3-specific components.
We have two LineageOS-for-microg 17.1 devices (including an FP2) here in our household that do not have the problem. The screen activates when a message is received.
But my wife has the FP3 with the FairphoneOS (Android 10) and here too the screen does not wake up. However, that had still worked on FairphoneOS on Android 9.

Maybe @dk1978 can say something about my assumption?

Just as a reminder: It did work with the GSI version of LineageOS 17.1 microG…

Looking at https://eu.community.samsung.com/t5/galaxy-s10-series/s10-notifications-not-waking-up-screen/td-p/979612

It appears that in that situation it will work with native apps, but not WhatsApp for example. Though the ref is A10

@amoun
You can’t compare Samsung phones with stock android. Samsung devices run OneUI, a highly modified android interface. This means that many things don’t look or don’t work the same. In this case, notification bubbles are not implemented in stock android yet (at least not in A10, still experimental in A11), while they are in OneUI.

Edit: Precision about notification bubbles added

4 Likes

Thanks for all the hard work on lineage os for fp3!

I’m on the April 12, 2021 build and restarting actually turns the phone off - I’ll try the next build when it comes out to see if that fixes it…

Hi everyone, I had already posted here some issues I’ve been having with LineageOS on FP3+, but didn’t get any replies, so let’s see if I have better luck here.

When my Fairphone 3+ arrived 2 weeks ago, I immediately installed the latest LineageOS on it, but I have been experiencing some problems. I’m not sure if the phone is at fault, or if it is due to LineageOS. Hoping you can help, or if not, point me in the right direction to get some assistance.

  1. the most serious problem is the headphone jack. Listening to music or calls is fine, but the microphone seems to be very badly distorted. I tested it on multiple headsets which are working fine on other phones. Currently I can’t use the jack for phone calls as the other party can’t hear what I’m saying.

  2. Wifi/mobile is much weaker than my previous phone (Xiaomi Mi5). For example, in my bedroom I am a long distance from the wifi modem, but this wasn’t much of a problem for my previous phone. With the FP3 I get no wifi signal. Same with the mobile data, it’s much weaker than the previous phone.

  3. Whatsapp calls seem to occasionally lose connection when screensaver comes on. It gives a message saying it’s trying to reconnect and the other party can’t hear me (nor me them). If I turn on the caffeine feature, the problem doesn’t happen.

  4. This is a minor issue but it would be nice to have a solution. I like to listen to music in bed before I sleep, and I usually have the volume at the minimum. However on the FP3, the volume is too loud at min setting - is there any way to lower it further?

Many thanks.

1 Like

Sadly the best option would be to return to FPOS and compare :frowning: