Official LineageOS 17.1 for Fairphone 3/Fairphone 3+

Hello guys,

Hope i’m not coming with a bug everyone already knows about, but right after a fresh install where I activated WiFi and installed a few apps on a new FP3+, I noticed I don’t have 4G connection working…

I can see the mobile network type in the icons drawer (when I pull from status bar, in the “mobile data” icon; it is activated and says it has 4G or H+ connectivity), but status bar network icon does not show the 4G text… And when trying to load a page it says I don’t have internet.
The icon in the status bar is in the same state as when you disable mobile data (which I did not of course)

I tried with or without roaming, checked every option I could find…

Anyone having the same issue ? Or knowing how to debug this?
I installed without opengapps. Installation went smoothly except I had to re-flah LOS after changing recovery to twrp.

Than you in advance !

Thank you for your reply. Unfortunately I’m unsure how to verify that. Does anybody else have deeper insight ir an idea?

3 steps here as having the same issue its a crock of shit.

  1. Go buy yourself a pay as you go sim for a £ from a corner shop/ Tesco etc on another network.
  2. Put the sim in the phone does it work. Yes/No
  3. If it works the issue is your provider. Phone them. Certain phone providers are very 1984 in the UK.
  4. If it doesn’t check your APN numbers

Failing that scream into the void and phone Fairphone when they open on Monday

I don’t think that helps as long as LineageOS is installed.


OH yes :slight_smile: Fairphone have no desire or design to support anything other than FP OS A10

I tried two different pay as you go sims. Both Vodaphone and EE PAYG sims work (Calls & data) on the fairphone, two different EE contract sims do not work with data in the Fairphone but work with calls. The same contract sims works in a different phones with data and calls . It’s not a Linage issue its a contract network provider issue and it’s preventing data getting to the phone. I believe EE are actively preventing this to discourage normal users choosing less invasive OS, this is done automatically without permission by the network by checking for particular traditional signifying outgoing API’s, if they don’t find them your phone gets the silent treatment. The issue has been raised to 3rd tier support. They don’t have a clue or are playing dumb, tbh I’m not sure. I will be running wireshark over the next few days and post my findings here.

UPDATE >>> Fixed they rang this morning to tell me my device had been blacklisted and it took 48 hours to appear. They removed me from the list hay hoo data is back.


Of course APN parameters! Why didn’t I think of that XD

Thank you very much, that was my problem. I checked all settings and I think the one that differs was IPv4 only vs IPv4/IPv6.

I believe EE are actively preventing this to discourage normal users choosing less invasive OS

That feels a bit far fetch to me, would you have any source of a network provider doing something like that? I don’t see why a network provider would care about something like that, except to get more support tickets… They are not the ones owning the more invasive OS anyway, all they can hope is that you install their voicemail app… I would more bet on something like Lineage following a standard for data it expects from the provider (parameters such as APN) and some network providers are just not providing it in this exact format.
Interested in your findings if you get anything!


Glad the APN details helped, the issue was resolved for me as-well. See original post.


Thank you @Gert123 and all others involved! As the battery calculates a remaining battery time of approx 5h I also suspect battery issues…

EDIT: Futhermore, the APN settings are fine…

(LineageOS 17.1-20210215, without MicroG, Fairphone 3)

Live Display not working.

Does anyone have the same problem / know any solution to this? When I adjust basically any settings related to the screen colors of my FP3, it doesn’t take any effect!

So none of these are working for me:

  • Live Display adjustments in System Settings
  • night colors
  • greyscale mode (put display into black and white for reading etc.)

Any tipps or help would be much apreciated. Thank you

1 Like

These are known bugs at the moment. Unfortunately, our maintainer is a bit “time challenged”, but i guess/hope this will change again one day :wink:

1 Like

Fairphone 3+, Lineage 17.1 - 20210127 - microG

Hi, i just wanna report some issue:

  • Contact synchronisation is not working with Twint. It is only working when I save a new contact though twint.
  • Sometimes during phone call, phone freeze and need to be hard restart. (Batterie away) Sorry not have more details
  • app is not able to notify, also with all permission
  • The 48MP Camera is still working on 12MP

Thanks for your work, I’m really happy with Lineage!

I know thats sad to hear, but it isn’t really a 48MP camera. The camera has a so-called quad-bayer sensor that combines 4 pixes into one whicht results in a 12MP output.
Take a look here:

Have you had those issues with normal phone calls or with messaging apps like Signal/WhatsApp?
Similar issues with messaging apps were mentioned here before and @lklaus opened an issue at GitLab


Thanx for the answer!!
I didn’t know about the camera, but it seems logical!
About the restart issue, i had that 3 times the ladt week and only by normal phone call.

Hello all,
I am waiting for @dk1978 to come online.

In the mean time, here’s a treat to all users from my side.


Moderators/Admins, am I allowed to share this unofficial build via a new post?

1 Like

You are free (and very welcome!) to post a link to the unofficial image with a disclaimer that it is an unofficial image, and users are free to decide to click on it or not :wink:





The FP3 image runs very stable. Many thanks to @dk1978 .

The following problems I currently still have in the Bluetooth area:

  • Volume in the car (with bluetooth) partly too loud / too quiet
  • Starting a call in the car (from contacts) not possible. Nothing happens. Pairing is ok.

Are there others with the same problem?
I am currently on 17.1-20210222-NIGHTLY-FP3.

Thanks for feedback.

Am i doing something wrong? I tried to follow the steps on LineageOS wiki for installing, and when i did “temporarily” flash recovery, it immediately rebooted, i have had no time to hold volume up and power to access recovery mode. Now when i do manage to get into recovery, its a dead android with “no command”. Should i repeat the steps and make sure i get into recovery on first try else the original system will wipe it ?