English

Official LineageOS 17.1 for Fairphone 3/Fairphone 3+

Thank you for that clarification. After having read all facts, i am chilling down for now. I consider the phone as enough secure for my needs and a stolen phone could only be wiped for reusing, as far as i got it. That seems ok to me. Knowing the advanced methods of accessing the device when bricked is helpful, too for the future. Very interesting!

How would one achieve your level of security “re-locked bootloader with additional security measures” - By chance is there a guide on this? Or would you be willing to name those addiotnal measure so we can all benefit?

Thank you

Thank you.
I have to read more about this google / android build process.
Maybe I find a forum to discuss questions.

got some more information for the video conf crasshing-issue at LOS:

It looks like some media related processes die and can’t get restarted

Sure!

In summary, here is what I did:

  • Sign with my own keys (instead of the google test keys): see the official LOS guidance.

  • Enable verity mode: comment out following line in device/fairphone/FP3/BoardConfig.mk:
    BOARD_AVB_MAKE_VBMETA_IMAGE_ARGS += --set_hashtree_disabled_flag

  • Create a ‘user’ build (instead of ‘userdebug’): use breakfast FP3 user instead of the default breakfast FP3

Let me know if any questions.

2 Likes

Hey Guys,

I’m stuck here…Has anybody done this on Mac

( OEM unlocked, device state unlocked on the restart bootloader menu on screen, connected to mac )

xxxxx:platform-tools imac$ ./fastboot devices
Axxxxxxxxx fastboot

ziparchive W 02-13 14:55:56 36481 2197659 Unable to open ‘lineage-17.1-20210208-recovery-FP3.img’: No such file or directory
fastboot: error: failed to open zip file ‘lineage-17.1-20210208-recovery-FP3.img’: I/O error

or I get this…

xxxxx:platform-tools imac$ ./fastboot update lineage-17.1-20210208-recovery-FP3.img
fastboot: error: failed to open zip file ‘lineage-17.1-20210208-recovery-FP3.img’: Invalid file

I’m following this ✏ [ALPHA] FP3/FP3+: Complete guide for installing LineageOS I’m stuck on stage 5 as per above.

I think I’m going wrong here…

As I have the img on my desktop and I don’t know where the equivalent of the destination above is for OSX.

Any help would be appreciated.

Thank you

You should copy the file from your desktop to the folder where you run your adb commands, so where ‘platform-tools’ is located.

Thank you - It’s already there…Still nadda. Please see above

xxxxx:platform-tools imac$ ./fastboot update lineage-17.1-20210208-recovery-FP3.img
fastboot: error: failed to open zip file ‘lineage-17.1-20210208-recovery-FP3.img’: Invalid file

I just quit out of terminal and reestablish the directory and it worked partially but I got this…

XXXX:platform-tools imac$ ./fastboot flash recovery lineage-17.1-20210208-recovery-FP3.img
Sending ‘recovery’ (65536 KB) OKAY [ 1.706s]
Writing ‘recovery’ FAILED (remote: ‘partition table doesn’t exist’)
fastboot: error: Command failed

Maybe the alpha documentation isn’t up to par any longer… Might be easier to follow the instructions from the LOS wiki (in doubt see post # 1)

Where did you get this command from? I don’t see it in the guide you linked and it is just wrong.

1 Like

check the file for corruptions. i had the same issues on another device and the hint on that install guide was to rename the image file to something short, like recovery.img.

Good Evening,

The line you are questioning was my attempt at improvisation as I could not get the Alpha or offical Wiki guide to work.

I’ve gone back to the offical Wiki which is here Install LineageOS on FP3 | LineageOS Wiki and I’m stuck here.

See attempts below.

XXX:platform-tools imac$ fastboot devices
-bash: fastboot: command not found

XXX:platform-tools imac$ ./fastboot devices
AXXXXXXXXX fastboot

XXX:platform-tools imac$ ./fastboot flash boot recovery_lineage-17.1-20210208-recovery-FP3.img
fastboot: error: cannot load ‘recovery_lineage-17.1-20210208-recovery-FP3.img’: No such file or directory

XXX:platform-tools imac$ ./fastboot flash boot lineage-17.1-20210208-recovery-FP3.img
fastboot: error: Couldn’t parse partition size ‘0x’.

The tutorial which you mentioned above is written for Minimal ADB and Fastboot and not for plattform tools. Since this tool is only available for Windows, you have to use the original Android SDK Platform-Tools. The procedure should be more or less the same, although the place where you can put the plattform-tools folder might differ. And the command line tool on macOS is - of course - also a different one :wink:
I’m still planning to expand the tutorial for plattform-tools and thus for other operating systems like Linux and macOS…

You obviously don’t have the recovery in this directory. Only the full lineage. Might help if you show us the contents of your actual directory: ls

@lklaus here’s the file directory

@HolosericaCaligo thank you, I’ll remove the Platform Tools version I’m using and use the Android SDK Platform tools

Well,m looks like the “recovery_” in front of this filename is too much, the file name starts with lineage…

regarding my problems with video conference, looks like the mediaserver is crashing. Added more info in the lineage os tracker issue I opened.
Paging @dk1978 , but be assured it’s only for letting you know, I’m not expecting a reaction as long as you’re still busy with your personal needs!

Yep if you look at the line below the line your quoting you will see I did both… as I was cross referencing two different guides to see if either worked in this particular instance. Neither did…thank you for following up though :slight_smile:

Actually, no. First, you flashed recovery, then you flashed boot…
But, according to the LOS wiki, you’re supposed to flash boot.
So, this should work, if your image is correct.
I’m not sure whether you’re supposed to flash to boot_a or boot_b, though, as I always use a different approach: I temporarily boot twrp: fastboot boot twrp.img (from twrp.me)