Official LineageOS 17.1 for Fairphone 3/Fairphone 3+

On a Linux system you will have a command sha256sum. Open a terminal application and give it the downloaded filename as argument, then compare the hash values.

I know how to do it. :slight_smile: To clarify my question:
How to be sure that the images were not modified at the mirrors when the sha256 sums also come from the mirrors ?

With Fedora, the checksums are signed with GPG, so you can check the checksums then check the images with the checksums.
But here, how can we do a correct check ? Is there a place where I can securely get the sha256 sums ?

1 Like

First of all, thank you for the great work!
I had LOS 17.1 GSI installed and have now switched to the official LOS. Now I have the following finding: whenever I want to reboot, the phone shuts down and stays off. Only a very long press on the power button restarts it. However, then the time is set incorrectly, only when it (presumably) reaches an NTP server, it sets the correct time.

Hi @dk1978 and others,

Massive thanks for all the hard work! I have been using the unofficial builds for months now and they work like absolute charms :slight_smile:

Even upgrading from the latest unofficial build to the now official builds was a breeze. So kudos for all this.

I do have 1 question, but I can’t seem to find any clues on Reddit/Discourse/Wiki/Interwebz. I now run a FP3 with the ‘original’ vendor firmware with security patches from August 2018.

How should I approach when I want to update the vendor image? I haven’t tried it yet, but I also assume that the vendor image should be updated before I upgrade to LOS17.1?

Again thanks for all the work, enjoy your coffee! :wink:


1 Like

I hope I understand you better this time. First off, we agree that the sha256-checksum will not do more for you than verify that files did not get corrupted in transit between the mirror and your machine, as in only halfway downloaded stuff etc. They don’t serve to authenticate the build. For that you have an OTA signature mechanism using LineageOS or Micro-G public/private key pairs as discussed in several posts above.

1 Like

I don’t quite get what you mean by “vendor image”. Included with the update you will get an image of the vendor partition vendor.img with proprietary binaries originating from this stock OTA release. For example, on my device I have “Vendor security patch level: October 5, 2020”. How exactly did you do the upgrade from unofficial to official? Feel free to PM me if we get into too much detail.

Today i had the same issue. I ran a timer and noticed that the wrong finished sound was played. It played the default sound although I had changed it. Sound selection showed a number as “selected sound” and no other elements to choose.

I had also thought about whether there is perhaps old firmware in my phone and causes the problem with the restart, but if it is updated by LOS that can not be.
What I also noticed: during video calls with signal, the others do not hear me. And when I hang up, the phone freezes, so only removing the battery helps.

“Couldn’t parse partition size ‘0x’” when running the “fastboot flash”

I also bumped into this today. I had installed /e/ OS earlier, not sure if that is related.
I followed the instructions they have in the /e/ documentation about this error, I installed lineage-17.1-20210104 successfully after that:

  fastboot getvar current-slot

This will show the current active slot. Use the other slot, so if it shows a , run the commands below:

  fastboot --set-active=b
  fastboot flash boot_b boot.img

Oh nice, for my previous phone I had to download the vendor images myself :slight_smile: and I couldn’t find any ‘Vendor Firmware’ zips, but good they aren’t needed :slight_smile:

I upgraded by ‘just’ sideloading the latest release, so I didn’t do anything special.

I’m on the official version now and led settings and colors work as expected.


So I tried upgrading from LOS16 to LOS17.1 and it broke my data partition, I used the following steps:

  1. Check if you run the latest official LOS16 ( in my case)
    1a. I removed disk encrpytion password by setting screen protection to ‘none’
  2. Boot TWRP via fastboot (fastboot boot twrp-3.4.0-0-FP3.img)
  3. adb sideload
  4. Sideload other stuff (OpenGApps/Magisk etc)
  5. Reboot & bust :frowning:

Swithcing back to ‘the other’ slot, doesn’t help, I had to reset the phone and restore from backups. (You did make backups before you attempted this, right? RIGHT? :slight_smile: )

Is there something I did wrong?

I’m not sure, but I did it differently, and kept data:

  • left encryption in place
  • boot twrp via fastboot
  • adb sideload
  • reboot into twrp (This probably is the crucial step, as the flashing of the system goes into the inactive slot, the reboot switches to that)
  • add other stuff
  • reboot
1 Like

Oh, right, forgot to mention, I did the reboot step before sideloading other stuff :slight_smile: (for those that don’t know, it’s mandatory as TWRP needs to switch slots to activate your freshly flashed OS in order to put other stuff in it)

Did you run your phone with the unofficial versions as well?

No idea what went wrong then, good thing I have titanium backup and a sync script on my phone :wink:

Oh, sorry, didn’t pay enough attention. I came from LOS17 unofficial, not LOS16, so my experience doesn’t count (I also lost my data from 16 to 17, but other people reported success)

1 Like

Can I see under LOS17 somewhere which camera modules have been detected? The OpenCamera app apparently only sees 12 MP (4000x3000px). It should be the FP3+ cameras.

The FP3+ Camera is a 4 x 12Mpx that reads as 12 Mpx

Newbie question :slight_smile:
The updater reports that the 2021-01-11 update is available. I did lock my bootloader, will that just work? Without wiping user data?

I guess not, or I haven’t found but I don’t own a FP3 so I can’t be sure).

As @anon9989719 said, that’s normal. See this topic for further explanations:

Hi i flash dirty the New Update 2021-01-11 but i run in a Boot loop . i see the lineage icon for some times then the phone boot new in recovery. I switch to the other Boot device and the last lineage boots.

Has anyone the same Problem?