Official LineageOS 17.1 for Fairphone 3/Fairphone 3+

That is not good. My advice - before you do anything else, go into TWRP, do a backup of your data partition and use adb pull to transfer the backup to your PC. At least then, you have a good change of restoring the phone to the state it was in before, if necessary with a factory reset + TWRP restore, and then backups of vital stuff like contacts, photos, etc.

Then, with that done, you can think of how to update.


I was waiting for this ROM. It solved some issues I had with the official build, finally my phone works properly. I see that Lineage expanded the support for dual sim operation but the button to turn off sims is still missing, not too bad.
Thank you veeeery much


OK, confirmed that Night Light does not work (might not ever have worked actually). Putting it on the To-Do list then.


I’m interested in building my own LOS 17.1. Following the instruction, I see that I need to be root to extract proprietary blobs… Is there another way to obtain them ? I’m currently running the official Fairphone OS.
I get a lot of “file not found in source” when executing the Not to all files but a lot of them.

Great that you want to build yourself! The more people that get skills and experience with own 17.1 builds, the better. :+1:

First of all, you probably don’t need to mess with extracting blobs yourself. Just PM me and I will point you to the location where you can download them, ready to be used by the build.

I am not sure what you mean by being root. You mean being root on your Linux PC? That is definitely not necessary, since adb can be used as a normal user.

The reason you got “file not found in source” is likely that I decided to move some of the Qualcomm blobs out of the system partition (where they do not belong, that should be AOSP-only land) to the system/product subdirectory. We are not using a dedicated product partition, since the stock one is just too small (128 MB) to be of use.


Maybe you can use this bash script from @maba007?
I didn’t use it for my own FP2->FP3 migration, probably would have tried it out if I’d found it last monday :slight_smile:

Now that I’m on 17.1 I’ll try out SeedVault, which ships by default from LOS17.1+ and can be found in Settings.

First of all, thank you @dk1978 and all contributors for the work! I am very happy about a running FP3 with LOS 17.1. I can confirm the night light issue here, too. On the other hand i feel the difference of the sound volume of some notifications and touch feedback is minimal changing by the sliders. As others described before, all in all the speaker seems to be a little bit too loud in my case. Some times the fingerprint reader triggers too fast (feeling pulsing vibrations), or tries to recognize that fast, the max try is triggered. Display touch seems to hang a little some times, but i guess both, finger print and display responsiveness depend on the cpu load. Most of the time those issues do not appear. I am really glad not having the gapps stuff running. :slight_smile:
One question:
I am moving from a POCO F1, LOS 17.1 to the FP3. In the advanced display options there was a “tap to wake” (double tap to wake display) feature. This is missing on FP3. Is that feature device specific? I thought this is a LOS feature…?

It’s device specific (or perhaps rather display specific). Some bits from when this was discussed for the Fairphone 2 …


Thank you, I did the backup. But now I am having trouble to restore it again. Everytime I install a rom (Lineage OS 17.1, or the stock rom) it goes well until I want to go to TWRP again. When I just use fastboot flash boot <twrp-image>.img to start TWRP and even if I do nothing in it, just a restart of the system, it just can launch TWRP and not the OS.
That’s why I also installed stock rom again, but same thing is happening there. I guess it has something to do with the kernel. Is there anyway to reinstall the kernel.

EDIT: What makes me think this, is when I try the Fix Recovery boot option in TWRP, I get this error:
cd /tmp/repackorig/ && /sbin/magiskboot hexpatch kernel <a_long_hex_number> <another_long_hex_number> process ended with
Error: 1
Error patching kernel.​

That writes TWRP to the boot partition. If I understood the use case correctly, you can boot TWRP once (rather than installing it) via fastboot boot <twrp-image>.img


Ok, thank you @Ingo and thank you @dk1978 all what you said worked. But I still can’t restore the backup, I guess it already was problematic as I did the backup… I will try some more stuff, but I think that’s it… sadly

Can Lineage Recovery used like TWRP? So that I can boot into it to install a never version of gapps or install magisk later to root my phone?

On the official download page of LineageOS for Fairphone 3, the OS and recovery images come from a mirror. As well as the sha256 sums.

So, how can I check the downloaded images to see if they have been modified or not ?

How do I unlock my bootloader?
I did everything written under
and after fastboot oem unlock it says < waiting for any device >. Yes. Because you asked me to reboot it. That’s why there is no device.

Are you sure you are in fastboot mode? What is shown on the screen?
You don’t have to just simply reboot the phone but to reboot in fastboot mode.

I guess it can. But the LOS recovery just doesn’t allow as many options as TWRP, but for flashing zips it should work I suppose.

On a Linux system you will have a command sha256sum. Open a terminal application and give it the downloaded filename as argument, then compare the hash values.

I know how to do it. :slight_smile: To clarify my question:
How to be sure that the images were not modified at the mirrors when the sha256 sums also come from the mirrors ?

With Fedora, the checksums are signed with GPG, so you can check the checksums then check the images with the checksums.
But here, how can we do a correct check ? Is there a place where I can securely get the sha256 sums ?

1 Like

First of all, thank you for the great work!
I had LOS 17.1 GSI installed and have now switched to the official LOS. Now I have the following finding: whenever I want to reboot, the phone shuts down and stays off. Only a very long press on the power button restarts it. However, then the time is set incorrectly, only when it (presumably) reaches an NTP server, it sets the correct time.

Hi @dk1978 and others,

Massive thanks for all the hard work! I have been using the unofficial builds for months now and they work like absolute charms :slight_smile:

Even upgrading from the latest unofficial build to the now official builds was a breeze. So kudos for all this.

I do have 1 question, but I can’t seem to find any clues on Reddit/Discourse/Wiki/Interwebz. I now run a FP3 with the ‘original’ vendor firmware with security patches from August 2018.

How should I approach when I want to update the vendor image? I haven’t tried it yet, but I also assume that the vendor image should be updated before I upgrade to LOS17.1?

Again thanks for all the work, enjoy your coffee! :wink:


1 Like

I hope I understand you better this time. First off, we agree that the sha256-checksum will not do more for you than verify that files did not get corrupted in transit between the mirror and your machine, as in only halfway downloaded stuff etc. They don’t serve to authenticate the build. For that you have an OTA signature mechanism using LineageOS or Micro-G public/private key pairs as discussed in several posts above.

1 Like