OEM Unlock getting stuck on Processing - Server 503

Hello all,

I received a new Fairphone 3 yesterday and after charging it fully I updated to Android 10. Then I wanted to install /e/ so I began with the process of unlocking the bootloader. However I can not get the phone to verify the unlock code.

  1. Go to FP3 'verify code' generator to get a verification code for the IMEI and serial because the official site gives me an error.
  2. Go to Unlock OEM in Dev Options, enter PIN, enter above code and wait.
  3. Nothing happens

logcat says that the request is being made, then it takes a couple of minutes for a response, and the response is most of the times a 503, there’s been also a 500 at some point.

I’ve contacted support but is this just something on their server side or am I doing something wrong?

1 Like

Hi @subdee and welcome to the forum.

I’ll not be of much help as I’m yet to try but, you mean you updated A!0 to the latest version as FP3 comes with Android 10. Could you confirm that you actually updated the Android 10 with the latest security patch 0107 dated June 5th.

Not sure about that link I can type 1234512345123345 and 12345123451 and I get a code ??

There’s a post about clearing cache, I’ll look for it

Hey @amoun, thanks!

You are right, it was just the latest patch update, not Android 10.

As for the code, if I go to Bootloader Unlocking Code for Fairphone 3 - Fairphone and enter the IMEI and Serial, the page doesn’t respond for a while, and then I get an error. If you are referring to browser cache, then it is definitely not the issue, since I’ve tried clearing the cache, using another browser and even trying from different networks.

1 Like

Confirmed: Yes after 10 min of greyed out button I get the message “An error occurred. Please try again later”


Did you check this topic as it at least sounds similar?

The solution suggested in the topic you cite was already tried.

I had the exact same issue.
When I tried to get the unlock code from the official page, the browser send a request to the server that got stuck.
I even try the request from another location, via the curl command:

curl 'https://factory.fairphone.com/api/unlock-codes/12345/XXXX' -H 'User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:89.0) Gecko/20100101 Firefox/89.0' -H 'Accept: */*' -H 'Accept-Language: en-US;q=0.7,en;q=0.3' --compressed -H 'Origin: https://www.fairphone.com' -H 'DNT: 1' -H 'Connection: keep-alive' -H 'Referer: https://www.fairphone.com/' -H 'Sec-GPC: 1' --data-raw ''

(I replaced the IMEI and serial number in the above request, but I tried with the correct ones).

The request is stuck for several minutes. Before failing.

I retried 30 minutes later, and… It worked!


The successful time was it with curl or the website?

It works now for me, the code as well as the OEM unlock. My guess is that they had a small hiccup on their API server and now it’s fixed.

Thanks for the update @JohnLi


Confirming that the official site now produces a code immediately.


Curl. I just launched it again when replying here… :slight_smile:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.