Notifications on FP1U stopped working after 1.6 update?

Hi everyone,

A couple days ago I updated my fresh FP1U to 1.6 and now I’m no longer seeing notifications for Gmail, Facebook, and Twitter.

  • For Gmail, I have to open the app and manually refresh to see new emails, even though notifications are enabled.
  • For Facebook, as soon as I open the app, I can see the red indicators for new FB messages and new FB notifications but my phone never receives these. (Again, notifications are enabled in the app.)
  • For Twitter it’s the same, but when I disabled notifications and tried to enable them again, Twitter hangs on an “Enabling…” prompt and it never actually succeeds.

I didn’t manually change anything about notifications after updating, and all three were working just fine before. Anyone know what the problem might be? I’ve already tried removing the accounts and clearing the caches.

Did you also try do open the PlayStore?

I’ve got several issues since the update & repartitioning, but missing notifications went away after I logged in to Google Play Store; seems to get the messaging up and running again. Threema was complaining beforehand that it needed the Google servers for it’s traffic, and I should log in.

Thanks for the suggestion. Is there any specific way to log out of Play and log back in again?

I’m able to update stuff within the Play Store just fine. I’ve now tried uninstalling (the updates for) Play Store and Play Services, but still not receiving push notifications. Also tried removing my Google account on the phone and adding it back again.

When I use this Push Notification Test app it doesn’t seem to do anything – apparently that means it can’t get a GCM connection at all? (Have tried on wifi and on data signal.) Ahhhhhhhh!

As far as I know, no. I was just prompted (after resetting) to enter my credentials. When I restored Threema via Titanium Backup, I had lost WiFi connection (poor signal, here). I was then prompted to “install Play Services” and given the option to open Google Play Store. Which I did, and promptly received some Threema (= GCM-transported) messages, instantly.

Sorry it does not work for you that way. :frowning: Also sorry to ask that, but have you tried turnin’ it off an on again after unintsalling/re-installing the PlayStore stuff? [Edith says I should suggest to you to boot into recovery mode after uninstalling the PlayStore, and wipe the cache there].

Argh, apparently I’m not receiving text messages either. :\ (EDIT: Okay this particular problem was just a strange coincidence: my friend’s phone was at fault here!)

Maybe it’s related: i had my hangouts totally messed up. Gave me cannot contact google or something. In the end i applied the 1.6 cherry update again and all was fine.

How exactly did you apply it again? By following the instructions here?

Started the fairphone updater again and went for the update like I did the first time :slight_smile:
No manual stuff…

Opened the guardian (i.e. the newspaper) app this morning. Prompted me that this app would not properly run until I updated GooglePlay Services, and sent me to the PlayStore to do so.

I did - and the app still does not want to open. It still sends me to update GooglePlay Services, which are now shown as up to date.

Apparently, something is broken - and it’s possibly related to push messages.
(For the record: SMS, Threema, TextSecure up and working.)

I’ve experienced similar issues. Whenever I updated my Fairphone to the next software release, notifications of many apps would stop working (Mail, K-9 Mail, Telegram, Threema, Quizduell…). The only way I saw to solve this was to reinstall all of the apps.
I did a little research and found that this would be related to “GCM” Services (Google Cloud Messaging), with which apps register on your phone and implement notifications via this service. So my idea is that, due to the fact that one has to reinstall the Google apps after a Fairphone OS update, GCM forgets the registered apps (although they’re still installed) and doesn’t show their notifications. A re-registration is only possible by reinstalling the app. Threema has a particular option in the settings menu to re-register itself with GCM, but many apps don’t.

Now that FPOS 1.8 is out, I really want to avoid reinstalling all my notification-firing apps, so my question is: Would logging out and back in again with Play Store really help? This is something I haven’t tried so far.