Not working as USB device – dodgy bottom unit?

Hi everyone! Quick question about hardware, I think. When I plug my phone in to charge, it charges fine. When I plug it into the computer, it charges, but it’s not recognised as a USB device. I’ve tried almost every solution I can find online regarding cables and drivers and MTP device settings and opening Developer Options and far far more, yet nothing helps – it always comes up in a little speech bubble “USB Device Not Recognised”. Does anyone know the cause of the problem? Not too long ago it was working, and it would work if I held it in a certain position, but then it would cut out, and now it just charges and that’s it.

Does this mean the lower unit’s on the fritz and I need a new one? Worth mentioning the primary microphone isn’t really working either, so that would be my guess – but whilst I’m going to get a new lower unit anyway, I was just wondering if that was the likely/possible cause of the USB issue, or if there was something else that needed work/I could use to transfer document over. I’m sorry if I’ve not been very descriptive – I’m really not good with tech and hardware – so I could explain it in more detail if needed, but simply, is it most likely a broken microphone unit, or are their other fixes?

And also, are there any ways to get my documents (mostly pictures and videos) from my phone to my PC without a USB cable? Thanks a lot in advance!

1 Like

Check notification on your FP2. It is set by default to “Charging only”, so it is not identified as MTP, nor anything else by your computer. You can alter this setting by clicking on the notification. You can change the default e.g. in the developer options.


To me it sounds like the bottom module as well, especially if it worked before and degraded (halding at a special angle).
File backup could be done by MyPhoneExplorer and establishing a connection to it via Bluetooth or WiFi.


To check if it is the module, a missing driver or a setting, you could use the android debug bridge (

You can install this tool, on Mac and Linux it’s very easy, use the package manager or brew. Then connect your phone, make sure developer options in general and USB debugging specially are turned on and type
adb devices
in your terminal or command prompt to get a list if currently connect the android phones. If that works, you can use adb to copy the files to.

1 Like

Hi @NicholasH,
I’m experiencing exactly the same issues with my phone as you do: Disfunctional USB and spotty microphone.

I opened a ticket with fairphone support on September 19th, but as everybody knows, they are currently a little overwhelmed. So after a first response that gave me some info on the microphone issue but did not address the USB situation, I’m back to waiting.

What I can tell you to mitigate your issues:

  • My bottom module is not the only source of trouble: I switched my bottom module with a friends’ and her phone managed to run USB connections with my bottom module, while my phone wouldn’t with hers.
  • To get documents to my PC, I exchange data through a SMB connection with my Network Attached Storage (NAS) (install Total Commander and use their built-in SMB client to do this). It’s a workaround, but it’s fine.
  • You can check your microphone in the maintenance section of the settings. I have noticed that my primary mic will stop working randomly, forcing me to really shout into my phone in order for the other person to hear me. I always carry a wired headset or do my calls over a bluetooth speaker. Kinda sucks. Anyway, whenever I reboot my phone, there is a 95 % chance that the mic will start working again (not the USB connection though, stop dreaming :stuck_out_tongue: ). But then, after some uptime, the mic will stop working. I have not been able to reproduce how exactly the mic is being disabled: e.g. if it’s a specific app, a specific duration of uptime, duration of airplane mode, lunar phase or sunburst period.

I will send you the content of my ticket by private message and I hope we can get this to work.


1 Like
Fairphone 2
OS: Fairphone Open
Computer: iMac with High Sierra

Hi There

I experience the following strange behaviour of the USB connectivity:

2 days ago, I transferred files successfully from my iMac to the FP2 using Android File Transfer :slight_smile:
This morning that was not possible. Here my observations:

  1. I charged the FP2 up to 95% using the charger of my old iPhone 4 without any trouble :slight_smile:
  2. I connected the running FP2 to my iMac:
    NO REACTION, not even the electricity flash in the battery symbol :cry:
  3. I switched off (shutdown) and on the FP2 leaving FP2 connected to iMac:
    The battery symbol showed the electricity flash but the Battery was not being charged (probably because it was full) :slight_smile:
  4. I disconnected from and reconnect the FP2 to my iMac on the same USB port:
    NO REACTION, not even the electricity flash :cry:
  5. I connected the FP2 to the iPhone Charger:
    The electricity flash appeared :slight_smile:

I have tried all points with the same USB cable, which I also used 2 days ago.
I have connected FP2 to several USB ports of my iMac - anyway all ports are working.

Has anyone got an idea what is happening ?

1 Like

Hi klt,

what does your iMac say when you connect the phone? Anything like the “USB Device Not Recognised” that Nicholas was talking about?

Not exactly. If udev-setup is “wrong” (which is the case for many common Linux variants) adb must be run with root otherwise the device is not recognized.

1 Like

I have not checked what my iMac is saying: Where would I check this ?

Anyway I can solve and reproduce the USB problem:

I have tried again to transfer files without success.
So I decided to install android debug bridge and switch on USB debugging.
Once I switched on USB debugging under Developer options:

File Transfer is working again :relaxed:

So I switched off USB debugging and File ransfer kept working.

However after rebooting the phone, I cannot transfer files anymore until I switch on USB debugging.

I hope this helps.

True, but it’s better to fix the udev rules instead of running adb as root. But thats an entirely different topic :wink:

1 Like

I tried activating USB debugging before reconnecting - this does not change anything, unfortunately.

To check all connected devices on your Mac, use the system profiler:

1 Like

The Fairphone does not appear in the system profiler but I can transfer files to and from the phone. Not entirely true: It shows in the Bluetooth section because I connected the phone once via Bluetooth:

Adresse:	84-CF-BF-8A-F9-57
Major Type:	Phone
Minor Type:	Smartphone
Dienste:	OBEX File Transfer, OBEX Phonebook Access Server, SIM Access, Android Network Access Point, Advanced Audio, Handsfree Gateway, Dial up Networking, OBEX Object Push, SMS/MMS, Android Network User, AV Remote Control Target, Headset Gateway
Verbindung eingerichtet:	Ja
Konfiguriert:	Ja
Verbunden:	Nein
Hersteller:	Unknown (0x7, 0x7D3)
Firmware-Version:	0x1436
Hersteller-ID:	0x001D
Produkt-ID:	0x1200
Geräteklasse:	0x02 0x03 0x5A020C
EDR wird unterstützt:	Ja
eSCO wird unterstützt:	Ja
SSP wird unterstützt:	Ja

But FP2 does not show up in the USB section.

Is your Fairphone on set to MTP?

and I can transfer fils from/to the FP2 even though FP2 does not appear in the system profiler (USB).

I have the same problem of USB recognition.
I use a data cable (checked between my PC and another samsung phone)
When I connect to the PC, it starts charging.
But the PC does not see the FP .
And the FP (in parameters, connexion sharing menu) says USB is not connected.
I am pn PC, this was working well a few months ago.
Any advice ?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.