No way to go without GApps?

Hi mates!
Just this morning i tried to restore my FPU to get deeply rid of Google Apps (since I could live with alternative software).
The backup went all well but the GApps were still all there, so I did the update to Cherry 1.6 to uninstall them. This worked, but I noticed that, although the wi-fi was connected and the signal was full, there wasn’t data transfer and when I searched anything with the web browser or with a search widget (Duckduckgo) I only had the “welcome to nginx” page: in fact the wi-fi icon was white and never turned blue.
So I tried different tricks, also changing DNS, but the situation was still the same.
At the end I gave up and I used the GApps Installer widget: now the wi-fi works again, the icon is blue and mostly now I can navigate the Internet.

So my question is: Is actually there a way to do it without the Google Services?

(I apologize for my english but I’m not an anglophone)

Yes, the phone works very good for me without having the Google apps ever installed.

If you want to uninstall them, you need to wipe /data and /system. The Google apps modify Android deeply. Better not install them at first. :wink:


Good to know: Without GApps the WiFi-symbol will not turn blue because blue indicates the Google Services. It should be greyish.


I did not know this. But my WiFi worked fine, nevertheless.

And what about the “welcome to nginx” page I recived before installing the GApps?

Did you modify your /etc/hosts and/or install nginx on your phone?

I seriously don’t know how this could be related to GApps.

No…in fact I didn’t know what nginx was before this morning…

I can guarantee you that you don’t need to have the proprietary Google Apps installed for a working Android phone. I never installed them and I’m perfectly happy with it.
Why you got an nginx welcome page when accessing duckduckgo (!?) is a complete mystery to me.

well, this could be a misconfiguration at the DDG site. Nginx is a commonly used reverse proxy used by many web servers, but you normally never run or even install nginx on a phone (because running a server on your phone is a bit unusual). Try accessing another site without the DDG search. You might also want to try accessing an IP address directly, maybe your DNS is somehow misconfigured.

It seems to be solved.
I did factory restore by Recovery Mode, this time.
No GApps and already the Cherry 1.6 ver. Same story with wi-fi (greyish, although now I know that it’s at this way when there aren’t Google Services) and application (with no connection and “nginx page”).
So I changed the DNS, setting the Comodo Secure ones, and all went well :wink:
Now I’m Google free, mainly using F-Droid, and 1Mobile for some proprietary apps and updates.

P.S: before to install 1Mobile, i tried the Amazon App-Store, but, to my great astonishment, there aren’t some common apps like Whatsapp.

Whatsapp can be downloaded from their website and even updates itself. :slight_smile:

Yes, it does, but isn’t the same for other apps like Prontotreno.

But its fine with my phone

There are enough other ways for getting your apps:

If the Installation of doesnt work, you will need to install a tool called Maps API:
Installation on the FP:
Copy this file to this path (with any Root compitable File Explorer): to /system/etc/permissions
And: to /system/framework
Much location based services arent working on a Google-Free FP before this installation.
Maps API belongs to the same project as BlankStore, but the official installation doesnt work.


… this is why I always refer to Google apps as malware. They really are and once installed, you lose control.

1 Like

I would advocate installing the only fully harmfree app store I know, F-Droid, and systematically starting with them for a new app ; getting back to other, non-open stores only when something is not available (and open) on F-Droid.

In my experience most other stores are intrusive by themselves even if separate from Google (for instance, Mobogenie is quite cool but never quits unless you kill it, and it inserts ad banners in your notification menu, etc.)
-does 1Mobile behave correctly? (I mean, among others does it indeed quit when asked so?)

1 Like

Hey Dreadrasta,
so now in the new Forum: I finally managed to copy the files as explained, but still can’t use a couple of apps, for example car2go or (for testing purposes) ÖBB Scotty, which tell me that my device doesn’t support google services and i should contact its producer. I don’t know if this refers to the Map or even to other google services the app uses.

Can you explain how the alternative Maps API works? To my understanding Apps like car2go access to the Maps API to provide mapping services inside the app (in this case to show the exact positions of the cars on a map). The alternative API should do the same, pretending to be the google API but using OSM data. Do i get this right? Thanks a lot for your efforts!

By installing Maps API more apps are compitable with your Google-Free Fairphone, but not all. I also tryed to install car2go, but the installation crashed.
I got this log error:
"E/PackageManager( 511): Package com.car2go requires unavailable shared library; failing!"
I already mentioned this problem here (german):
I dont know a solution for this problem.


Ok, now i researched a little and managed to correctly install the Maps API. I didn’t enable neither Root Access in the Settings (Grayed out because of the missing but necessary BusyBox as mentioned here) nor the displaying of system files which is to be found by clicking the Eye button inside the file manager. So by default the file manager started in the phone storage folder where i manually created the system folder…

Now i got it right, apps installed correctly and i’ll try the functionality in the lunchbreak!

Hi all ye tec-cracks!
To be honest I don’t understand most of the advices given here… :smiley: But I hope you can help me with this one:
On one of my start pages - the one with the silent button - there is a permanent link to install Google Apps - which I don’t want. Is there any way I can delete that link?
Thanks for your help!