English

'No service' notifications after Android 9 update

I’ve been using 2 SIM cards for some time, an EE-Phone Coop in slot 1 and an O2-Giffgaff in slot 2. The EE signal is very poor where I live, the O2 signal is good. Since the recent OS upgrade to 9 21.03.0 I’ve been pestered with ‘No service’ notifications telling me that I have no mobile service for O2 (which is wrong - my O2 service is OK, it’s the EE service that’s poor). So as I move around my house my FP2 is gonging me with yet another ‘No service’ notification! The fact that it’s mentioning the wrong SIM isn’t a great problem, but can someone tell me how to disable this notification? Many thanks.

Did you try to long press the notification? That there should appear some possibility to deactivate the notification.

Hi Volker, thanks for the suggestion. Today the EE signal has improved and the notification is less frequent - it was firing earlier when I was busy outside, but not now I’m waiting to catch it. You have to be quick because it usually clears after a few seconds. I’ll try again tomorrow when the stormy weather is expected, which should affect the EE signal.

1 Like

Yes, the long press does produce a dialogue for disabling the notification (I had tried a double-tap, but that just takes you to the mobile network settings). I selected to turn the notifications off and got a confirmation “you will not see notifications…”. Immediately after that I got several more notifications! I’ve now restarted the phone and so far it’s been quiet. There do seem to be some problems with notifications in this version - my incoming emails have stopped giving me a notification even though they are enabled.

Maybe the emails are not downloaded and therefore there’s no notification? Maybe you should configure your email app to always run in the background?

2 Likes

Well I did get an email notification today when I switched the phone on, so I think the problem may be the related to the large number of emails coming in and the way the notifications are triggered—or maybe I’m getting a bit deaf! I’ll change the notification sound to something louder. Thanks for all the advice.

Today, I also got the famous “update available” message so after the mandatory backup, I let run the Fairphone updater. The good news: Update process worked flawlessly (coming from Android 7.1.3). In the past, I often needed the manual way using USB cable and Linux.

Since I have weak 3G/3G signal I also often get these notifications so I am also interested how the disable the acustic message for network service lost or restoration.

Update: I found the needed option when long tapping:

I hope this helps other who have the same issue/question.

Also to note by the way: MTS file transfer over USB which stopped with the previous lates Android 7.1.3 update is now working again, i.e. an old bug which is fixed now.

2 Likes