No Premium (short number) SMS

I cannot send by SMS in the Messages app using Premium - or ‘short number’ - SMS. For example, the UK 60066 SMS service to report broken train loos!

How do I turn on Premium SMS?

Fairphone 2 running Fairphone OS 17.10.1 (latest available to me).

Thank you

This can also be a provider-level setting. Many providers allow you to bar premium-rate numbers/calls. This often also disallows text messages to premium numbers.

I can’t test whether it doesn’t work on the FP2 in general, maybe somebody else here has a similar report though. Alternatively, if you can borrow a different phone you could test whether it is related to the FP2 or your SIM/provider.

1 Like

Perhaps this will help.
Go to Settings,
tap on the :low_brightness: in the right upper corner,
tap on App permissions
tap on SMS
make sure that Contacts are green.

Now go to the app Contacts and make an entry of the premium number.
If necessary restart your phone.
You just could be lucky.

You could also try to put a ‘#’ in front of the number and see if this works.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.