No mobile data connection after rolling back to FairphoneOS

Recently I reinstalled FairphoneOS following the official guide following a long period on LineageOS. At first I thought everything worked flawlessly, but I later discovered that my phone now doesn’t connect to mobile data.

I’ve checked the sha256sum and made sure that I installed the correct file (assuming there is no regional difference). I’ve also tried enabling roaming, setting the mobile data carrier manually, and resetting all APN connection points with no success.

A thing worth mentioning is that I did not remove the SIM during the flashing, since I’ve never had to do that when flashing custom ROMs. I’ve been told that this shouldn’t be the cause, though I am planning on reflashing with the SIM card out when I get home to see if that helps.

If anyone knows any other possible causes or solutions that I could try out before my commute homewards, I’ll gladly listen!

Did you create a new APN and did you verify the settings resetted are really correct?

No, I did not create a new one as I’ve never had to touch that before. The only reaosn I thought to reset them was bcause of the official guide.

How can I check whether or ont the resetted settings are correct?

Check with your provider what the settings should be, most have it online.

1 Like

This seems to have worked! Thanks!

1 Like