English

No google playstore

Yes, but you need to use #dic:fastboot.

https://code.fairphone.com/projects/fp-osos/user/fairphone-open-source-os-going-back.html

1 Like

Do I have to install the nano or the pico version of OpenGApps, that the playstore works?
Thank you so much, I`m absolutely new to this teritorry!

Choose ARM - 6.0 - Pico for the minimal package to get the Play Store into your Fairphone Open OS.
There are descriptions of how much Google the different packages contain when you hover over their names, you can choose a larger package for more Google stuff.

Downloading will give you a ZIP file. You will have to put that on an SD card in the phone or into Internal Storage (where you can find it easily).

Then you would boot the phone into the recovery program (should be TWRP) by rebooting or starting the phone with the Volume up button pressed.
In TWRP, there will be an “Install” button where you can then select the downloaded ZIP file and start installing it.

Once installing finished, you can reboot the phone into the OS and use the Play Store.

That all being said … If you are used to the default Android experience with all Google services and Apps, you should rather follow @paulakreuzer’s hint and switch over to the standard Fairphone OS. You can still easily explore more open and less Google options later if you got more of a grip with the phone :wink: .

3 Likes

Thank you so much for your very detailed answer! I made it to install everything as you said und I can open the playstore. But I can`t install any apps :frowning:
There always comes an error that the app is not compatible to my phone…

Now it works! Thank you so much, you really made my day!! :slight_smile:

Best regards from Munich,
Anita

2 Likes

It is another issue, but in my own opinion, if I got a fairphone with FairphoneOpen OS, I would be glad.
Fairphone Open is a great operating system for your phone to get rid of all the google spyware.
You need not use google, not even as a search engine and if you use FPOpen and additionally fdroid as a repository instead of play store, there is no spyware on your phone any more.

I use FairphoneOpen now for more then 1 and a half year, I find it great and feel more secure about my data in the internet.

1 Like

Glad you got it to work :+1: .

Just as a reference for others maybe stumbling upon this …
What step(s) made it work after the initial error messages in the Play Store?
Another reboot? Some Google account setting? Disabling Root?

If you continue to use Fairphone Open OS, you might want to check whether your phone is rooted or not.
Fairphone Open OS comes prepared for Root, whether it actually is rooted or not is a simple setting in Settings - Developer options - Root access (or something like that).

If Developer options aren’t visible, you can enable them by tapping repeatedly on the Build number you saw earlier until it says that you are developer now.

Knowing the Root status is important because there are Apps (e.g. certain games and banking Apps) which will by default not run on a rooted phone.

2 Likes

I did excatly what you wrote before. After that there came the error, and I just tried to download any apps a view times more and after about half an hour it worked :slight_smile:

And you are right, my banking app doesn`t work…
Do you also know how I can fix this?
Sorry for all this questions :frowning:

Set Root access to “Disabled”.
If the App still doesn’t work, try again after a reboot.

I set the Root access to “Disabled” and rebooted the mobile phone. But unfortunately it still doesn`t work.

Which banking App do you use and what error message does it give you?

pushTan from Kreissparkasse an the error is “pushTAN was ended” and than the homepage of the bank opens and tells me that my mobile phone was rooted and because of that that there exist system authorisations, which can not ensure the safetey.

Sorry, I didn’t know enough about this as I don’t use such Apps and am always rooted.
It seems the setting might not be enough for very strict Apps, as they can detect (and they don’t like) even just the possibility to root.

If you put your priority on such Apps to work, the fail-safe way is switching to Fairphone OS (which is unrooted).

Else … @Roboe: Does your unroot ZIP for Fairphone Open OS still work with Android 6?

And a Google-lesser way would be switching to LineageOS for the Fairphone 2 (based on Android 7.1 currently), which is unrooted by default. It’s pretty popular here.

For reference … a wiki about excessive tinkering around … not recommended for beginners or the faint of heart :slight_smile:

Whatever you do, backup your important data first :wink: !

I can’t assure it, I didn’t tested it on Marshmallow OSes yet.

I can see that your problems have their source in you using the non-regular Fairphone Open (pre-rooted and without Google Services), instead of Fairphone OS (default OS with full Google support).

Unfortunately, if you stick to FP Open without being minimally tech-savvy or wanting to make you sovereign over the technology by #livingwogoogle, then you’ll have a lot of issues.

I must recommend you to return to Fairphone OS for a more hassle-free and regular experience. You can probably get local help to do this from a #fairphoneangels near you (probably quicker, maybe on-person support) or #contactsupport (usually slower, always in the distance).

Edit: Based on your user profile, @Anita, I can see you are near Munich. @jayy and @JBap are on charge of the Munich Fairphone Heaven, and @jayy (again) and @Paule are on charge of the Augsburg Fairphone Heaven.

1 Like

Bringing the device back to the normal Fairphone OS should be easy and solve most of the points. I just have to setup ADB on my Linux Laptop - right now I just have it on my desktop Mac.

Only point is that I am not so often in Munich (being scared of the big city :joy:). I’d prefer if some of the Munich angels could help out. If that’s not possible I can try to arrange to be at the next Munich Meetup.

1 Like

Great. Just let me know (anyone, really) should you have any troubles with adb or fastboot on GNU/Linux, :+1:

Ok? :smile:

That should do it, :slight_smile: (In Ubuntu there are some udev rules issues, that’s why I mainly offered to help)

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.