No data without reboot

My setup

Fairphone 4
One eSim on Wingo provider (CH, Swisscom network)
One SIM on SFR (FR)
Build FP4.FP4K.A.179.20230116 (currently, but issue has always been here)

My workflow

I’m commuting almost daily between France and Switzerland. I have access to almost unlimited mobile data in both country, so I disabled roaming and I’m manually switching the “Preferred data” setting when I cross the border to switch from one SIM to the other. Twice daily.

My issue

When switching the “Preferred data” setting, sometimes the phone does not achieve to activate data at all. No matter what I try (switching the setting back and forth, disabling data and back, switching to airplane mode and back,. switching to another network like 3G instead of 4G, …), the phone seems to be locked without data. Calls are working fine. The only solution I’ve found is to reboot the phone.


Once the phone is rebooted, data is back very quickly, so there is no setting issue, and probably no long term cell issue
Issue happens at least once a week on average
Same issue also happened before my Fairphone 4 on my previous phone as well, never achieved to get support from my providers at the time and never took the time to find a community who could help.
Issue happens an a variety of travels, so I’m not always trying to reconnect on the same cell but on many different ones (> 50 km appart, so definitely no the same one ^^). But still in the same area (< 100km wide at most) so maybe there is some equipment in common between all these cell. Not sure if this happened somewhere else.
It happens mostly when switching from CH to FR, very rarely from FR and CH (not sure it happened once during last months).
Aside this issue, I have no other problem with mobile data, hoping from cell to cell, switching between 4G and LTE, everything works fine.


I searched the forum and did not find much, except few topics which where discussing that on rare occasion the phone was stuck without data after discussing with a bad functioning cell and had to be rebooted. Not exactly my issue (or I have many malfunctioning cells in my region) and no real solution was provided.

So I assume you’ve also tried airplane mode maybe as a faster solution?

Yes, he tried airplane mode.

Yes, I tried airplane mode … without any luck.
Does any have you know any tool I might use to get a bit of information on what is going on ?
I did a bit of Android app development in the past and I know how to debug them / use adb tools but for such a low level issue I have no clue about what I should look after.

In my eyes you already confirmed the issue is with the provider, and I guess only Fairphone and/or the provider can you help to solved this…

The only thing that was mentioned somewhere once or twice, was the roaming setting in the APN ipv4/ipv6 so maybe changing this helps?

And just for the records: did you already receive and install the Android 12 upgrade?

1 Like

Still on Android 11
Thanks you for your PoV

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.