English

No data connection when roaming/unable to save APN

solved
mobiledata
Tags: #<Tag:0x00007fefc11791a8> #<Tag:0x00007fefc1178fa0>

#1

I have owned a FP 2 for a year and a bit at this point, but I have not yet been able to get data roaming when abroad. As a person who travels a lot, this is a big annoyance, as I do rely on the data connection being relatively stable. At this point, it has been an issue in Ireland, UK, Norway, Sweden, Germany. So far I’m drawing a blank when trying the suggestions on the forum. Data roaming IS enabled with my provider, and I have never had this issue before, with the same plan, but different phones. I am using FP OS 19.02.1. I only use a single SIM card in the phone. I have tried the following:

  • Replacing the SIM card with a brand new one. No change.

  • Enabling/disabling data connectivity when abroad. No change.

  • Enabling/disabling flight more. No change.

  • Restarting phone. No change.

  • Manually selecting provider. No change.

  • Manually entering the APN for the one provider my phone wants to connect to. Here things become interesting. I can enter all the details just fine, but as soon as I enter an MCC and a MNC different from my default (currently 238 and 01 respectively), the system refuses to store the APN information I just entered. It simply does not appear in my list of APN options. This is likely related to the issue with not being able to get data connectivity, but I’m at a loss about what to do. Any ideas what to try next?


#2

Android only shows a list of APNs that are usable with the SIM card(s) that is/are present. It selects these by matching the MCC/MNC codes reported by the SIM to those stored in in the APN lists. The MCC/MNC code in the APN should always be that of your SIM provider; it does not change when you go abroad.
Make sure the APN matches with what your provider recommends. Some providers have different settings for different plans, so make sure the settings match those for your plan.

Outside of APN settings, on the phone you can check:

  • Whether the SIM is registered to a network, or reporting ‘emergency calls only’. If the latter, check whether automatic network selection is on, or try other networks. If you’re in rural areas, there may be no networks with which your provider has a roaming agreement.
  • Whether data roaming is activated on the phone (not sure whether that’s what you meant by ‘enabling data connectivity when abroad’)
  • Activate ‘automatic network selection’ again, even if it is already activated. One of the places I travel, I need to do this every once in a while to keep mobile data running. Seems to be a network issue as this happens with different phones.
  • Whether 3G/4G is activated and whether switching to 3G helps (not all roaming agreements between providers cover all frequencies).

Possible provider-side issues (none of these apply if you get a working connection when you place the SIM in a different phone - though don’t assume that if that worked 6 months ago it will still work today, I already got bitten by that once):

  • Some providers only allow roaming on SIMs a certain number of months after the SIM is activated. If your SIM is new, this can be a problem.
  • Account misconfiguration, or accidental roaming block (e.g. by accidentally dialling the short code to block it when trying to do something else like disable voicemail)
  • Rumour has it that some providers block EU roaming if you exceed the roaming fair use policy (i.e. >50% of use is roaming AND >50% time is spent abroad in any 4 months window).

Your mileage may vary. One SIM I have never gets a data connection in Belgium, but works fine everywhere else. The other does work in Belgium.


#3

Hi Johannes,
Thank you for your suggestions. I was not aware of the APN restrictions you mention. In that case I’m not entirely sure what the various suggestions on the forums about manually entering the APN to solve data connectivity are all about? In any case, I tried to set up a new APN, keeping the MCC/MNC codes alone, but changing the rest to the vodafone.de internet APN, again with no luck (currently in Germany and registered on the vodafone network).

  • Just to clarify, then yes, the SIM is registered on the network, I can call and text just fine, it’s only the data connection that is missing.
  • Data roaming is activated.
  • I reactivated “automatic network selection” several times, no luck
  • I also tried switching to 3G, which sadly did also not help.

I don’t think there should be any issues on my provider side, but sounds like I will have to give them a call to see if I can get this sorted.


#4

Please tell us from which operator in which country your SIM card is.

That’s for people who have no data connection on their home network either.

Yes I also think you should do that.


#5

My operator is Telmore and I’m based in Denmark.

And thanks for elaborating on the APN issue, now it makes more sense :slight_smile:


#6

I have had similar problems being able to connect to any network when using my FP2 in East Africa. I am UK based and have been able to connect to other networks when roaming in Europe, but not across Kenya, Tanzania and Uganda, whether in cities or rural areas across the three countries. The one exception, oddly, is that I can connect to a network in the capital of Uganda and in DR Congo.

I try manually selecting networks in East Africa and several different networks are available (all the usual for those countries - Safaricom, Airtel, Orange, Tigo, Vodacom, MTN) but every time I select any of them, it says ‘Cannot register on network.’

I have tried ordering a new sim card in my FP2 but that didn’t work. My home network provider assures me they have not blocked data roaming but also suggest I need to text from the phone in East Africa to got any roaming bans lifted, and of course I cannot text from East Africa as can’t connect to a network.

I have also tried using a local sim card in my FP2 and occasionally that will work, suggesting it is a sim issue. But on the other hand, sometimes a local sim will not work in my FP2 even though it will work in an old nokia phone I travel with, suggesting it is the FP2 not the sim.

I have tried all the tricks above like toggling flight mode one/off and rebooting. I have pretty much given up trying now and rely on wifi or an old nokia with local sim for emergency calls, but travel to E Africa a lot and there often isn’t wifi, so it would be very helpful to have roaming data and indeed any network connection at all with the FP2.


#7

Forgot to add that on some occasions when I have managed to get a local sim to work in my FP2, I have to remove my UK sim for the other slot for the local sim to work; the local sim won’t work in the FP2 if my UK sim is in there.


#8

@Rel, could you open a new topic if you want help with that? I have had none of those problems when I was in Kenya. Last week roaming worked just fine there, and 2 years ago when I was there too I had a Safaricom SIM in my phone without any problem.


#9

Hi, I am presently in Tanzania and roaming does not work with my Fairphone 2 while it works perfectly when putting my SIM card in another type of phone. Did you find a solution in the meantime?


#10

Hi Val, no, I’m sorry, I haven’t managed to find a solution despite trying many! Let me know if you do! Safe travels.


#11

Dear Rel,

Even if it was working well on another phone, I still decided to try to call my provider in Switzerland. The funny thing is that the provider said that the problem was not on their side but due to the phone. But juste after the call, suddenly roaming was working perfectly. So maybe it was still a problem on the provider’s side???

Val


#12

Ok, it turns out that there was indeed an issue that had to do with my provider, and not related to the phone at all. I guess I had just not been using this service for that long… At some point in the past they split up calling/texting abroad from “using data” abroad in their services. It used to be bundled together in one thing. Once I became aware of this, I also got “data connectivity abroad” enabled on my plan, and the FP2 has now worked flawlessly also with data connectivity when traveling abroad.

My bad for not checking up on this in more detail, but at least it was not due to anything related to the phone, which, I must admit, made me real happy. I was starting to suspect that it was a weird quirk of the phone. Very happy to be proven wrong on that one!