"No command" message

I was updating my Fairphone 2 today with the uptader, but suddenly a black screen appeared with the android sign lying down and the message “No command”. I’ve tried to remove the battery many times and restart it… I’ve tried to apply update from ADB and from SD card…I’ve tried to wipe cache partition…I’ve tried to wipe data/factory reset… AND NOTHING WORKS!!!
The “no command” message keeps showing up everytime I reboot the system or I restart the phone.
Anyone can help me??

1 Like

Welcome to our community forum. :slight_smile:

Once you see this …

… briefly HOLD the power button and briefly PRESS the volume UP button. This should take you to the AOSP recovery. You should see yellow (and really small) letters stating which operating system is installed right now. Let us know if it says Android 7 (Fairphone OS 19.11.2) or Android 9 (Fairphone OS 21.03.02).


I have the same problema. Don´t start with Hold + Up. The message is no command. The phone don´t start. :frowning:

It says 7.1.2/19.11.2/gms-24df0be9

In this case, you can manually re-install Fairphone OS 19.11.2 (Android 7):

This should keep your data intact.

I started the Android 9 update last night, after the installation I was asked to restart, but ever since it repeatedly keeps restarting (screen says ‘fairphone powered by android’). I have tried to turn it off, let the battery die and turn it on again but it keeps trying to restart constantly. When I press the power button and the volume up button simultaneously the message ‘no command’ appears. When I press the power button and the volume up button briefly a menu in yellow and blue appears saying:
Android Recovery
use volume up/down and power
Reboot system now
… etc.

I can’t use my phone now since last night. What should I do now?

Hi, I moved your post here. See my most recent previous reply above for a way to get your FP2 working again.

I tried to manually install the software but the script keeps saying:

WARNING: No Fairphone 2 found in fastboot mode.
WARNING: Make sure that a Fairphone 2 is connected.
WARNING: To check for devices, type ‘/Users/emmelinedemooij/Downloads/fp2-gms-19/bin-darwin/fastboot devices’.

I repeated all the steps, but no result. What do you advice?

I can only guess that there is a problem with the Fastboot capabilities of your computer. I cannot really guide you there, the “Prerequisite(s)” instructions in the link are probably relevant here.

So I’ve manually re-installed Android 7 (It worked with a different cable!). How do I update to Android 9 from here?

I cannot figure out why your first upgrade attempt failed. Check Settings > Storage to see how much free space is left on your built-in internal storage – i would say not more than 25 GB should be used. Another user reported that she ran an anti-virus app on her FP2 that blocked the successful upgrade and she was only able to upgrade after deactivating that one. But these are just wild guesses what might have caused the problems.

If you want to be on the safe side, you can just wait until the installation file in the instructions you just used is replaced by the Android 9 installation file. Then you would just need to use the same instructions again to upgrade to Android 9, just with the new file.


When I try to follow the instructions, in the device manager I can’t find my phone, or my fathers one under with the tag ‘ANDROID’.
What can I do, to overcome this step?
(windows is updated to the latest version)

so you tried to install manually and your device is in fastboot/bootloader mode? If so I think it is normal that you do not see it in the device manager. Else, are you sure you have a data cable? When you have issues during the manual installation, i.e. there is no device found in fastboot mode you may need to update the driver, this is e.g. explained under prerequisites in the manual installation guide. Or are you already trying to update the driver and there you cannot find Android? I think the step to search for Android in the device manager is not mandatory, here another guide to update the driver.

Edit: in the device manager turn on hidden devices, I think you should find Android under other devices then, no need to have the FP connected . If FP is in fastboot mode and connected and driver are up to date you shoud find under Kedacom USB Devices-Android Booloader Interface.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.