English

No calls possible

Hi together,
I bought a used fp2 but before checking the functionality i installed Lineage 17.1 via twrp.
Everything worked well when I started the phone afterwards. But after a short time (maybe 15 mins) i noticed that calls are not possible. I have done a factory reset then and was able to do calls again, but after a few minutes it was not possible again. Mobile data always works.
I tried installing AOSP 11 but the OS did not work properly, the display flickered. Then I tried Fairphone OS 19.11 but had the same call problem. After factory reset it worked again for like 5 mins.
Unfortunately I did not do a backup of the stock rom and now i cannot find the stock rom.
I do not understand the problem here, the hardware should actually work because the first minutes always allow to make a call but then again different roms deliver the same issue so it should not be an OS issue.
Did anyone have such problems? Is there an option to test the hardware?
I’d be thankful for any help.
Best regards

Welcome to the FP community.
I’ve never heard of a similar problem.
For installing the current FPOS follow the official support documentation:

What does “calls are not possible” mean? Do you get any error message?
Is it the same while any data connections (wifi/mobile data) are disabled?

2 Likes

How old is your SIM card? It might not work reliably anymore.
You can also try if it works in the FP2’s other SIM slot.

A few basic hardware tests on the FP2 are available from Settings > Maintenance > Checkup (if you are on Fairphone OS 19.11.2 / Android 7) or Settings > System > Maintenance > Checkup (if you are on Fairphone OS 21.05.0 / Android 9) or can be installed from www.f-droig.org (App “Fairphone Checkup”) if you are on any other Android system (e.g. LineageOS) that is not Fairphone OS.

3 Likes