No 4g connection in SIM1

Hello all,
I am having an issue with the access to 4G mobile connection of SIM 1 in my FP2:
I recently received a replacement SIM from my mobile operator, as the old one had a bug. Since I inserted it, I no longer have 4G connection, but can only see the letter E next to the icon and the connection is super slow. In the mobile network settings, at first only 4G was selected for this card but I couldn’t change it to 3G or 2G - it seemed stuck. So I tried changing the positions of both cards, then reinserted them back as they were. I managed to change the settings from 4G to 2G (just to see if the buttons are responsive) and it worked, but now the whole field (“preferred network type”) is grey and I can’t even click on it.
I called the network operator and they told me that I have a 4G card and is activated. So it seems that the problem is with my phone…
Does anyone have an idea how I can fix this?
Thank you in advance!!

Afaik there is no option to “reset” those settings. I would remove both sim cards after shutdown. After some seconds I would reinsert the battery and perform a full boot cycle. Then reinsert both cards when shutdown and boot up again.
Both sim card slots are 4G capable, but with dual sim only one card can utilize/be set to 4G while the other therefore is limited to 2G.
This never caused any troubles for me.
You could now try to reconfigure each card. Whether first set your preferred sim to 4G then the second should already be limited to 2G. Or first set your preferred sim to 2G and the second to 2G/3G/4G as you wish.

1 Like

If one SIM is set to 3G or 4G then for the other one the network type is greyed out. This is because the modem just supports one SIM with more than 2G.
Set both SIMs to 2G and then set the one you use more for data to 3G or 4G.
EDIT: after re-reading your text I understood what happened: when you did put your SIM into the second slot you enabled 3G or 4G for that slot. Now when you go back to SIM settings you default to first SIM. Tap at the right top to change to second SIM and you’ll see the setting of second SIM slot with 3G or 4G.


Dear both,
thank you so much for your responses!

Patrick1, could you tell me how I can do this “full boot” you are referring to? I think that’s the next thing I should try.
Volker - I am trying to do as you say, but in either position (SIM 1 or 2) the problematic card (Telenor) is unresponsive even when I set the other one to 3G (there’s no 2G option for it)
I usually have the cards in this position and am mostly using Telenor for my main card. Here one can see the grey-outed field:

The other card in this variant - only 3G as option. I can freely select and deselect the preferred type of network:

Then I switched the position of the cards:

Giffgaff looks normal again:

Here it seems I can choose between the three types, but the button is stuck at 2G (I can’t select 3G or 4G as it doesn’t allow me to select either)

Not sure if this makes it clearer :confused:

Is your Giffgaff SIM somehow incapable of 2G connections? From what I read they use the O2 UK network which does offer 2G services.

You should usually be able to set 2G on Giffgaff and then enable 4G on Telenor. This seems to be an issue specific with Giffgaff SIM cards as I have not yet encountered a SIM where 2G was not possible. 2G ought to be always available as an option as the phone can handle two SIMs on 2G.

1 Like

Something just miraculously happened and now I can select 4G on Telenor!!!
Perhaps it was just a problem with the network tower (?) as a friend had suggested to me!

Thank you so much for your responsiveness and help! :slight_smile:


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.