No 4G connection in android6 - only 3g

After upgrading, I initially had some problems getting my 2 SIMs set up right for data, but now they are fine in ‘mobile data’ settings - SIM1 shows “4g” and SIM2 shows “2g”.

However, since upgrading to Android6, I’ve never had better than a 3g signal shown on SIM1. I see 3g/ G [GPRS] / E displayed on the top bar next to the signal strength, but never “H” (4g) which I usually got at home, and at the office, with the previous FP2 software version.

Any suggestions how i could get 4g back? I’ve turned SIMs on and off, reset network settings, factory reset and reinstalled Android6 from the full image, none of which have changed this problem.

2G = G or E
3G = H or H+ (UMTS)
4G = 4G (LTE)



If you have never ever seen 4G next to the signal strength, your SIM card or contract is most likely not 4G enabled. You should ask your network operator.


In addition to @ChuckMorris 's advice, make sure your Fairphone is connected to the respective APN of your mobile service carrier:

If you are not sure which APN is the correct one, just ask your service provider. Some of them offer the possibility to send a message that includes the appropriate configuration to your Fairphone automatically.

I have the same problem here.
With Android 5.x I had the 4G/H+/H/3G connection signs.

Now, same sim Card, new Android 6.x the max. connection is 3G.

Just wanted to get in touch with my provider, but if other fairphoners with Android 6 have the same problem,it could be the Android version.


Thanks everyone!

I’ll check the APN settings just in case.

The thing that was most confusing was the change from Android5 to 6, which changes the display. It sounds like what used to be displayed as H/H+/3G is now all displayed as “3G”, even if it’s really H. So it’s just a display thing, not that I’m getting slower internet.

(As an aside, is there a way to check what data speed i’m actually getting, technical info somewhere, not in the top bar signal strength indicator?)

“H” in Android 5 is 3G and is shown in Android 6 as “3G”, but Network Cell Info still shows “HSDPA”, “HSPA” or “HSPA+”. So, in fact, it is the same network type and only a change in the display. I cannot say whether this is intended or a bug.

You could check the following if you have no 4G:

  • If another phone is available, test it there.
  • Look if 4G is enabled in the settings.
  • Look if your provider supports 4G. In Germany, other providers than Telekom and Vodafone (“third-party providers”) in the Telekom or Vodafone network (like “Congstar”, “”, “Lidl Connect”) do not have 4G.
  • Look if 4G is available in your area. Most providers have a map where you can look at. For example, O₂ Germany has many 4G-less areas in rural regions and small towns.
  • Check if your SIM card supports 4G.

Since de update to Android 6.0 my FP2 makes no connection to a 4G network.
Although 4G is set as “preferred connection” I always get connection with the 3G network, even on locations where 4G is very strong.
Anyone else has the same issue or an solution?


Maybe this sounds trivial, but just to make sure:
Is your SIM capable of 4G, and is 4G included in your data plan?

1 Like

It would be useful if you could state your provider as well. I’ve had this impression before with mine (Three), while when roaming in the Netherlands (KPN) I’d get 4G just fine.

The three posts above were moved here to avoid duplicate topics. Apologies for any confusion.

Try to disable and re-enable your SIM card you are experiencing the problem with. It sounds quite similar to this one:

Although you might not operate your Fairphone with two SIM cards…

Thanks all! It turns out my network switched my plan invisibly… So I was back on 3G only without realising :slight_smile:


How frustrating! However, thanks for reporting back! :slight_smile:

My problem is ‘solved’. It is my provider (and not the update) who is responsible for the issue.

Walter (wwerquin)


Maybe your phone is connected to the same mobile network provider of @LaurieJ .

Anyway, thanks for reporting back! :slight_smile:

Hello. I have the same problem after the upgrading.
My FP2 works whit 2 SIMs, first one English provider and second one Vodafone Italy. In UK never had problems, when I come in Italy my connection doesn’t work.
Before last upgrading I switched the English SIM on 2G and the Italian SIM could work with 4G (they didn’t switch aoutomatically). Now I’m in Italy and I can’t switch the SIM2 (English) on 2G: I can choose just between 4G and 3G. SIM1 (Italian - Vodafone Italy) is switched on 4G. But I can’t have data connection (signal strenght shows always E).
If I remove the English SIM the Italian one works properly (4G). I need both SIM to receive calling from UK. My WhatsApp account is with English number.
I already tried to switch off the English SIM and switch on but doesn’t change. It’s no more possible switching the second SIM on 2G. Do you have some suggestion because I can use both SIMs in Italy with 4G connection?

Hi Roby
I just had the same problem: Swiss SIM1 and Italian SIM2. With the Italian SIM data connection was not possible (only E), but as I am am in Italy i wanted to use this SIM for data and not the Swiss one. I tried several thing (switch of one SIM, change APN, …). In the end it worked with a simple manual change of the SIM-slots: Now data SIM (Italian) is SIM1, works with 4G and SIM2 is the Swiss one - which now seems to work with 4G too, but I disabled data because of roaming prices we unfortunately still have in Switzerland :wink: Maybe its already enough to remove and push in the SIM in the same slot but if not I would suggest to switch them.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.