NFC RFID reading of passport fails


I urgently need to apply for my US visa ESTA.
They made me use the mobile app.

RFID reading of my passport fails again and again, with a very short display of an error message
“secure messaging not activated”.

What do I need to do?

NFC is activated.
There is a vibration, and the app says reading RFID, then falis.

Which Fairphone do you have?


Which phone are you using? From your profile I assume the FP4?
Did you ever manage to read any RFID tag before?

Yes, I’m using the FP4.

It has worked on reading my ID card for Ausweis App.

Is there any way to activate secure messaging with NFC?

I don’t find any such control.

I tried again. It read, and put out an error “failed smart card” this time.

Does that give a clue?

Now managed to read the full message now:
“LAYER6: secure messaging not activated”

Any clue?

Meanwhile, when googling for that full error message, I see multiple German passport holders complaining that RFID reading always fails.

It looks like I cannot use the ESTA mobile app then :(.

Hope I find another way that works …

You can just use the online application and upload a picture.

Good ol’ German IT… :disappointed:

1 Like

Please delete “Good”.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.