NFC hit or miss frequently on FP4

Isn’t it only the contact which connects to the main board? I believe the actual antenna is the large black area. You can see it’s connected to the golden rectangle using thin black wires. Nonetheless, you definitely need to aim way lower than where the cameras are.

5 Likes

I guess you guys are right. :blush: The corresponding receiving part is probably the two silvery golden pocks on the camera module’s bottom right here:

Originally, I was expecting a more pointed area because the NFC symbol on the FP3 back cover (mis?)suggests so, but then again I found myself that the (presumable) NFC antenna on a debit card appears to be much larger than a mere NFC symbol:

1 Like

I use a Yubikey and daily I use NFC. But from time to time NFC just stops working on the FP4. The issue also happens when using Google Pay. Please address this problem at FP support so they can put it on their todo list.

3 Likes

My only NFC experience on the FP4 was trying to read my ID card. And that was really not easy to do. In fact, I had already pretty much given up when it suddenly read the data after all. The card had to be placed in a very specific center place behind the phone to get a read. No idea if it’s the phone’s or the card’s fault, though. :man_shrugging:

Just in case anyone is using a case, this was discussed RE the FP3

1 Like

I haven’t tried Google Pay with FP4 yet but reading NFC cards works without problems, even with the protective case.

I used this app for testing:

5 Likes

It works about 9 out of 10 times, but when using NFC a lot, like I do. Then issues arrise a few times a week. I guess it’s a software issue. When it fails a reboot is needed, or a restart of an NFC app such as Yubico Authenticator.

I connect my Sony Bluetooth headphones (WH-1000XM3) using NFC 1-2 times a day, and I have to restart NFC via the status bar almost every time that I do that.
When it works, it connects in seconds, and I don’t have to hold the headphones at a very specific location, and it doesn’t matter if the case is on or off the phone.
When it doesn’t work, it’s simply that. I can move the headphones around, try different spots, but it simply does not work. Only an NFC restart helps.

I thought it’s maybe the battery optimization, so I’ve set the “Nfc Service” to “Not optimized”, but the issue persists.

Did anyone find a more reliable fix than restart NFC everytime you want to use it?

3 Likes

I don’t think there is a definitive solution. Please make sure to #contactsupport. The more people report this, the more likely it is that it will be fixed.

2 Likes

I haven’t noticed this problem in the first week of my new FP4. Do you guys still encounter this issue?

Yep, sometimes a payment doesn’t go through and the phone vibrates like crazy (with a message “Phone moved too fast”). In most cases it’s fine, but definitely not 100%.

That sounds like a different issue than I was having. I sometimes had to kill the app Yubico Authenticator because it couldn’t detect my Yubikey via NFC. Google Pay also had this issue a few times. I haven’t used Google Pay a lot the last week.

However, I wasn’t able to reproduce the Yubikey issue in the last week. I sometimes also have issues that I’m too fast with the NFC connection. But I also had this with my old phone. NFC needs some time. I’m using the official protective case by the way.

@NiceColdRum do you still experience this issue? Or is it similar to what @Razem said, that the connection needs some more time?

Yesterday the NFC didn’t work (at all), I had to launch the app that’s the default for NFC communication by hand before it worked again. This only happens with an uptime of about 24 hours. So maybe some process crashes or goes into deep suspend after a while. I didn’t have these issues with my old phone (Android 9-12).

Can you clarify what’s actually happening? Does NFC turn off by itself and you basically have to turn it back on? Or was it turned on but didn’t work unless you opened some app that uses NFC? None of this has happened to me so far, except for weird cases like NFC deactivates itself automatically - #3 by Razem.

Can’t say what actually is going wrong. But I use a Yubikey for 2FA so I use NFC on a daily basis. Sometimes it just stops working with the Yubikey Authenticator app (NFC is still on). I then have to start the app myself. Normally when I hold the key at the back of the phone the app opens automatically. But then it stops doing that, and manual intervention is needed. I don’t think it’s app related, because it works fine on my Pixel 3. Another theory is that because the Pixel 3 has less RAM, it may kill processes faster. My FP4 has 8GB, so maybe keeping it in the background for a long time triggers a bug. Just guessing.

It also happened once with Google Pay.

Yes I still have regular issues with trying to pay contactlessly it’s just Incredibly fussy about where your holding the phone I think it’s some kind of signal issue between the devices because it’s especially bad with handheld wireless payment terminals I suspect because both the phone and payment terminal are moving ever so slightly at all times I have to practically shove my phone on the terminal and hold both together to get it to work :smirk:

1 Like

Interesting, the payment terminals in The Netherlands have strong NFC fields. The moment it fails for me is when the software refuses to open the default app for the task, i.e. Google Pay for payments (only happened once) or opening my Yubikey Authenticator (happens after 24+ hours of uptime once in a while). The connection is quite strong, also with my Yubikey.

It’s not that it doesn’t detect the NFC device from a short distance but that if I don’t hold it against the device it won’t take the payment the phone will just vibrate constantly and the terminal will just say it that it didn’t take payment because the phone/card is moving too much

2 Likes