New software update Kola Nut 1.8.5 is ready

Aah, that’s what you meant with that version 2 launcher. I thought it was about the Fairphone updater app. I’ll install that one then :slight_smile:


The pre-update went ok (I guess), but Koala Nut 1.8.5 wont install. App says there is an update. Download seems to go ok. After download I have to restart the Fairphone, but when pressing the restart button in the update app it says “File not found: /cache/”.

I tried manual reboot, but no update occurs.
I noticed that each time the update app is opened (due to closing the app or screensaver) I have to re-download the update.
Last time I paid more attention to what happens (while writing this post) and noticed there is a brief moment after download where the app says “no space on cache partition” (or something close to this).

I will come back later after a cache purge and retry.

Hi Nadir,

Thank you for your feedback. We are currently going through the French translations and we will optimize it.

The interactive tutorial in French is our first step towards more supported languages on the support page. Unfortunately we don’t have the capacity yet to fully translate all support articles. We will work on this in the feature :]


1 Like

Hi Dave,

Sorry to hear this. Try to download the Kola Nut 1.8.5 update again (through the Fairphone Updater app) while keeping the screen active. This might does the trick. Let me know!


Nope, sorry.
Went into recovery. Wiped cache. Rebooted.
Started update, download ok. Errormessage: No space left on /cache.

Will try manual update through recovery.

(I have a repartitioned phone using the Meteos MTK6589 ROM edit to have a 4GB /data, maybe that messed up the update)

I moved a post to an existing topic: What’s wrong with consistency?

Update went ok - but I have lost ALL MY ICONS now.
brilliant. :frowning:

Question: Could try to get them back with “restore” of older saved version, or do I have to set them all up completely again?

Tnx for help.

I’m afraid you will need to put them back. >;’[

Sorry but this update is really not done in a thoughtful manner. Half of my contacts are gone!
Edit: MOST of my contacts are lost. Any suggestion why a system update wipes out my data? Very dissappointed.

After doing the update, I didn’t ser any differens. So I did one more (don’t know why really, I liked how it was). Somehow I now have the Cherry update and I can’t change anything becase there is this thing coming up on my screen saying “ have been stopped”. What does it mean and how do I do an update again!?

You most likely still need to reinstall the app store on your phone.
After you have done that please add your Google account again.

Once your phone is done synchronizing with Google your contacts will most likely be back again! :smile:

After updating you still need to reinstall the app store again.

Ah, they’re back. I think it takes 5-15 minutes before Google syncs with the phone’s data.


But that’s the problem, I can’t. I am told that the process is stopped and I can’t do anything…

And my Fairphone updater says that there are no updates available.

I have updated successfully, but after the automatic reinstall of the apps, I now can’t get past the sign-in to google services. I keep getting the following message:
no stable connection to the server can be established, this may be a transitory problem of else your android device does not support data services. If the problem persists, go to customer support.
The wi-fi connection works fine, but the screen for choosing your wi-fi connection is the only one I can access, there is a button “next” which isn’t normally there and that takes me back to the previous message.
I have rebooted the phone several times, it doesn’t make a difference.

Help, please

exactely the same problem here.
and apparently google-services get killed within the pre-update, so i can’t usw those now.

1 Like


  • Can you tell us, from which version you did the update? Was it Cherry 1.6 or KolaNut 1.8?
  • How your contacts are stored at your FP? Are they stored at “Telephon” or directly at the “Google-Account”? Only the latter would explain the behaviour you observerd…


  • Am I right, that you updated from KolaNut 1.8 to 1.8.5? Then this explains the loss of the icons…I am sorry to say. While updating from 1.6 --> 1.8.5 Icons should be kept!

Cheers, Robert

OK. (and thank you Techaddict)
I just did a quick first round of manually putting them back and have 70 % of them already. My system with the icon-groups must have been quite plausible.
So everything seems to be fine here.
(but of course I don’t bother with google apps - using f-droid instead - so it’s cool).

btw: the icons are smaller again? but still clear and bright, so no problem there.

P.S. it would be better if posts answering to other posts actually end up there, - this one is an answer to Techaddict’s reply to my post from 44 min ago.

1 Like

I just solved the problem, I rebooted again, saw on the top line that there were two new emails, so the phone obviously was connected to google services. So when I was asked to sign in, I chose the option “not now”, went through the various stages and now it does seem to work.

1 Like