New software update Kola Nut 1.8.5 is ready

Thanks a lot, worked now!!!

Well you can at least with free apps, please have a look at BlankStore from NOGapps project, I use it frequently and it works very well :smile:

1 Like

Does this mean that we should wait with trying to update again until you have found a solution? I tried three times in the same way which was described on top.

Please provide more information:

  • What exactly is your current setup (which OS version, unified partition or not)?
  • Describe the troubles, you are experiencing.
  • What have you done to solve it? (What is “the same way which was described on top”? You can do quotes by marking a sentence and clicking “quote reply” in the label, which will appear.)

Thank you! :blush:


First of all: Thanks to the moderators for the great support. You are doing a great job. :smile:

For me the update worked fine, no problems when upgrading from 1.8 to 1.8.5 on my FP1U. The home screen arrangement was deleted as announced. So everything worked as designed.

I want to give some feedback to the new layout. Should I post it here, or should I open a new topic for that?



Well the layout is not really new. The launcher from 1.6 is back because people were not digging the 1.8 launcher (or version 2 launcher).

There is a topic on how to get the 1.8 launcher back and a wiki post about launchers, but no topic about the original fairphone launcher yet. So if you want to discuss it a new topic is probably best.

1 Like

Hi Karsten,

your described behaviour with phone visibility is normal. For mounting your phone in a way your computer sees it you can either mount it in another mode, or simply turn on “USB Debugging” in System settings -> Developer options on your phone.

thanks for your reply. But the Kola Nut Updates seems to be fine now. instead I am asked to install Android Jelly Bean 4.2.2. … which I don’t need? how can I stop these notifications?

Hi Stefan!
Thank you for answering so quickly!

Unfortunately I do not know where to find information about OS version or unified partition?

This is what I find under “about phone”

android verison 4.2.2
baseband version MOLY:WR8.W1248.MD.WG.MP.V14.F1.P1, 2014/07/14 13:31
Kernel version 3.4.5
Buld number

This is what happens.

I try to start the update. It take a lot of time. Then it asks me to pull the google apps to the screen. Since it is already there I just press it to install. Then I get a new message about an update and I see that the “Install” on google apps is still there. I try again, and again… same result. I now have a new notification about the update.

Do I have to do a backup for photos, videos, messages, bank id, apps etc? And how do I do that? When I connect to the computer I am able to save the photos to dropbox because a window opens offering this option. But otherwise I cannot find the Fairphone anywhere. It is not in finder only in iphoto but I cant make a back-up from there. Where do I find it and then how do I back up all the apps and messages? I have tried pressing USB tethering, no result. I entered Storage but the option "eternal usb storage / mount usb storage/insert usb storage for mounting " is not selectable.when i connect through bluetoth i cant find the hone in finder either. i can download things from the computer to the phone but nit the other way around.

There is also a problem with the connection by cable. It seems to continously disconnect. I had this problem with the charger as well for a few days. Then it was ok again. At that time I could only charge it if the phone was off. Is this connected to my problems of connecting it to the computer? And what to do about it? but i still get a notice when it connects and disconnects and when it is connected i still cant find it on the computer. The weird thing is that it seems to continue charging although it says its disconnected. or rather i keep gettin questons about connecting to mac and it disappears from iphoto so i assume it disconnects but keeps on charging? On the other hand it looks like its charging but it stays on 53%… Something is definitly not ok.

Thank you!

If you open the updater app what does it say is your current operating system? I don’t think anybody on Fairphone OS gets notified about updating to Jelly Bean.
Or is the notification maybe coming from another app? Open your Notifications, long-tap the notification and click “App-Info”.

To find out which OS you have installed open the updater app and you’ll see your current operating system. To find out if you have successfully unified your partition go to settings > storage and see if you still have a “phone storage” and an “internal storage” or just the internal storage.

When I open the updater app there is no information on OS. Then only thing it says is:

Release Notes:
Relsease notes: for the full list of changes, please… etc
Then I have the options cancel or install.

And it says superuser granted to fairphone and a please wait… with a circle showing it is working on somehting.

It says only Internal storage only and not phone storage

I do not want to update anything until you can guarantee that I will not loose apps (eg. my bank id) and messages. And if there is a risk I can loose them I would like to get help with how to back it up. I have described the situation in the previous email.

I have tried different modes (USB, MEDIA DEVICE, CAMERA) and developer options USB debug and I can still not find the phone on the computer. And it is still connected and it seems to be charging now. It jumped to 61%.

Try thinking about your Smartphone as being a computer. You can have a big variety of different possible installations. Can Windows guarantee you not losing data while updating? No they can’t. They can just assure you they have done their best for you not losing your data.

Fairphone has done their best for you being able to make a backup. There is, amongst others, e.g. Titanium backup. But neither is this an easy tool, but I find all backup solutions have pitfalls. In my opinion there is not the “easy one fits all”. Some restores may fail because of different memory layout and maybe other reasons.

When updating OS while not changing storage layout I have not experienced loss of data. But I was also always successful connecting the phone to my computer when I had turned on “USB debug”. It may depend on your computer OS and its settings, too.

I have not experienced yet the Fairphone Updater App telling nothing but “Fairphone” as version number and giving details about release notes. Mine tells in the headline “Fairphone Updater” with blue thin characters on white ground, below I find (translated) “Your current operating system Fairphone Kola Nut 1.8.5 Your operating system is current”, and on the bottom it says “Are you an experienced user? Enter the advanced mode”.

Since the phone is usually charging when attached to the computer via USB, and yours didn’t do (before), I assume it was not firmly connected to the cable. Or can you try a different cable?

From my understanding the Android USB settings are irrelevant when you want to use the SP Flash Tool, the phone should still be operating in its ‘factory settings’ mode.

My point was that my ‘factory settings’ looked different than described in other place: it didn’t start into recovery mode right away but into a different menu first.

However the ADB mode was my saviour :smile: and thanks for your help!

  1. The charging problem happened independently of charger. I tried three kinds. I read that many people had this and similar problem with the charger. I tried the connection to the computer with two cables with the same result. It does not appear.
  1. read a bit about this backup on other threads just now and it seems to be a very difficult tool. And that you need to do some tricks to make it save all contacts, sms, apps etc etc. Hard to follow those tips since I am new to smartphones and would need a manual with stepwise instructions of each step on the fairphone. Does this manual exist anywhere? Is there no stepwise instruction of backup before updating on Fairphone homepage? I cant find it.
  1. to me it looks like the updater has got stuck during the udating process and is not continuing. I did give it superuser acces and it seems to remeber this but then it is stuck on that “moving ring” and please wait…

  2. I wonder if the problem could be a loss of Wifi connection at any point during the update? I have Wifi now but sometimes it does disappear and possibly it happened at some point during the update. BUT, I did get as far as re-installing google apps so I thought the update was done. Then I got a new notification of update, and then again, and now it is stuck on that moving ring.

  3. When entering system settings/Apps/ALL, I found an app called Fairphone OS 1,47 MB. When I enter this it says version 1.1. Could this be my OS? I cant see it in the updater for the reasons I said before. It is stuck. (NO IT WAS NOT SEE BELOW: )

  4. I entered the system settings/Apps/ALL/Fairphone Updater and selected “Clear data”? It stopped the “stuck” updater and now I can see that the OS is Cherry 1.6 (but still needs to know how to update step by step).


1 Like

Hi all,

We are happy to announce a fix is available for users who are unable to reinstall Google Apps after installation of the faulty Storage Upgrader 1.8.5 on the software update release day (19 May).

The fix is easy to install, just visit this link: through the standard browser on you device and you should be able to install the APK file from there. If the short url link above doesn’t work for whatever reason, here’s the full link:

After that you will see this screen:

Just press “FIX”, allow Superuser access when asked and restart your device after this.

After the restart you should be able to install Google Apps through the Fairphone Updater app as normal.

Good luck with the process, and we are sorry for the inconvenience this issue has caused some of you.




Thanks for the fix, though i’ve fixed it already using the SP-Flash-method. One question: Does this also fix the somehow ‘broken’ bootloader (no sdcard found, updates via adb quit after ~25%)?

1 Like

Thanks. The fix worked for me.


Unfortunately did not work for me… Although I haven’t been able to install GAPPS through the installer since the first 1.8 betas.

Doesn’t work for me as well… the Fix runs successfully, then after reboot I am in the same situation again. (tried twice)

I am one of those that repartitioned the phone shortly after release with the XDA method though, maybe has something to do with that?

It worked for me!